pkgsrc-wip/webcleaner/patches/patch-aa
Michal Pasternak 238817e345 WebCleaner is a filtering HTTP proxy (and yes, it is half Python, half C).
Features:
* HTTP/1.1 support
* integrated HTML parser, removes unwanted HTML (adverts, flash, etc.)
* integrated JavaScript engine, allows popup filtering
* compress documents on-the-fly (with gzip)
* disable animated GIFs
* filter images by size, removes banner adverts
* reduce images to low-bandwidth JPEGs
* remove/add/modify arbitrary HTTP headers
* usage of SquidGuard domain and url blacklists
* Basic, Digest and (untested) NTLM proxy authentication support
  per-host access control
* configurable over a themable web interface

WebCleaner is licensed under the GNU Public License (GPL).
2004-02-27 17:09:31 +00:00

25 lines
758 B
Text

$NetBSD: patch-aa,v 1.1.1.1 2004/02/27 17:09:31 mpasternak Exp $
--- setup.py.orig Thu Jan 15 21:40:59 2004
+++ setup.py Fri Feb 27 18:02:05 2004
@@ -120,7 +120,7 @@
def run_commands (self):
- cwd = os.getcwd()
+ cwd = os.getenv("PREFIX", "/usr/pkg") # os.getcwd()
data = []
data.append('config_dir = %s' % `os.path.join(cwd, "config")`)
data.append('template_dir = %s' % `os.path.join(cwd, "templates")`)
@@ -321,8 +321,8 @@
['config/bl2wc.py',
'config/dmozfilter.py',
]),
- ('share/locale/de/LC_MESSAGES',
- ['share/locale/de/LC_MESSAGES/webcleaner.mo',
- ]),
+# ('share/locale/de/LC_MESSAGES',
+# ['share/locale/de/LC_MESSAGES/webcleaner.mo',
+# ]),
]
)