pkgsrc-wip/ion3/patches/patch-aa
Paulo Matias e21a6bdb9f Ion is a tiling tabbed window manager designed with
keyboard users in mind.

It supports tiled workspaces with tabbed frames and
has fully documented configuration and scripting
interface on top of the lightweight Lua extension
language.
2008-02-13 21:20:48 +00:00

56 lines
1.8 KiB
Text

$NetBSD: patch-aa,v 1.1.1.1 2008/02/13 21:20:48 pmatias Exp $
--- system.mk.orig 2008-02-05 15:42:06.000000000 -0200
+++ system.mk
@@ -8,7 +8,7 @@
# Installation path prefix. Unless you know what you're doing, the default
# of /usr/local is likely the correct choice.
-PREFIX=/usr/local
+PREFIX=@PREFIX@
# Unless you are creating a package conforming to some OS's standards, you
# probably do not want to modify the following directories:
@@ -16,11 +16,12 @@ PREFIX=/usr/local
# Main binaries
BINDIR=$(PREFIX)/bin
# Configuration .lua files
+EXAMPLEDIR=$(PREFIX)/share/examples/ion3
ETCDIR=$(PREFIX)/etc/ion3
# Some .lua files and ion-* shell scripts
SHAREDIR=$(PREFIX)/share/ion3
# Manual pages
-MANDIR=$(PREFIX)/share/man
+MANDIR=$(PREFIX)/man
# Some documents
DOCDIR=$(PREFIX)/share/doc/ion3
# Nothing at the moment
@@ -62,8 +63,8 @@ DL_LIBS=-ldl
# If you have installed Lua 5.1 from the official tarball without changing
# paths, this should do it.
-LUA_DIR=/usr/local
-LUA_LIBS = -L$(LUA_DIR)/lib -llua
+LUA_DIR=$(PREFIX)
+LUA_LIBS = -R$(LUA_DIR)/lib -L$(LUA_DIR)/lib -llua
LUA_INCLUDES = -I$(LUA_DIR)/include
LUA=$(LUA_DIR)/bin/lua
LUAC=$(LUA_DIR)/bin/luac
@@ -85,7 +86,7 @@ X11_PREFIX=/usr/X11R6
# SunOS/Solaris
#X11_PREFIX=/usr/openwin
-X11_LIBS=-L$(X11_PREFIX)/lib -lX11 -lXext
+X11_LIBS=-R$(X11_PREFIX)/lib -L$(X11_PREFIX)/lib -lX11 -lXext
X11_INCLUDES=-I$(X11_PREFIX)/include
# XFree86 libraries up to 4.3.0 have a bug that can cause a segfault.
@@ -113,7 +114,7 @@ DEFINES += -DCF_XFREE86_TEXTPROP_BUG_WOR
#DEFINES += -DCF_NO_LOCALE -DCF_NO_GETTEXT
# On some other systems you may need to explicitly link against libintl.
-#EXTRA_LIBS += -lintl
+EXTRA_LIBS += -lintl
# You may also need to give the location of its headers. The following
# should work on Mac OS X (which needs the above option as well) with
# macports.