33 lines
1.1 KiB
Text
Executable file
33 lines
1.1 KiB
Text
Executable file
$NetBSD: patch-Makefile,v 1.2 2013/02/02 20:42:22 noud4 Exp $
|
|
|
|
adjusting python, mind we break the 2.6 rule.
|
|
|
|
--- Makefile.orig 2012-12-01 02:57:25.000000000 +0000
|
|
+++ Makefile
|
|
@@ -24,7 +24,7 @@ ASCII2MAN = a2x -D $(dir $@) -d manpage
|
|
ASCII2HTMLMAN = a2x -D docs/html/man/ -d manpage -f xhtml
|
|
-MANPAGES := docs/man/man1/ansible.1 docs/man/man1/ansible-playbook.1 docs/man/man1/ansible-pull.1 docs/man/man1/ansible-doc.1
|
|
+MANPAGES := man/man1/ansible.1 man/man1/ansible-playbook.1 man/man1/ansible-pull.1 man/man1/ansible-doc.1
|
|
|
|
-SITELIB = $(shell python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
|
|
+SITELIB = $(shell @PYTHON@ -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
|
|
|
|
# VERSION file provides one place to update the software version
|
|
VERSION := $(shell cat VERSION)
|
|
@@ -111,13 +111,13 @@ clean:
|
|
rm -rf docs/js
|
|
|
|
python:
|
|
- python setup.py build
|
|
+ @PYTHON@ setup.py build
|
|
|
|
install:
|
|
- python setup.py install
|
|
+ @PYTHON@ setup.py install
|
|
|
|
sdist: clean docs
|
|
- python setup.py sdist -t MANIFEST.in
|
|
+ @PYTHON@ setup.py sdist -t MANIFEST.in
|
|
|
|
rpmcommon: sdist
|
|
@mkdir -p rpm-build
|