4f52f39718
GNU Octave is a high-level language, primarily intended for numerical computations. It provides a convenient command line interface for solving linear and nonlinear problems numerically, and for performing other numerical experiments using a language that is mostly compatible with Matlab. It may also be used as a batch-oriented language. Octave has extensive tools for solving common numerical linear algebra problems, finding the roots of nonlinear equations, integrating ordinary functions, manipulating polynomials, and integrating ordinary differential and differential-algebraic equations. It is easily extensible and customizable via user-defined functions written in Octave's own language, or using dynamically loaded modules written in C++, C, Fortran, or other languages.
25 lines
956 B
Text
25 lines
956 B
Text
Common subdirectories: ../math/octave/CVS and octave/CVS
|
|
diff -u ../math/octave/Makefile octave/Makefile
|
|
--- ../math/octave/Makefile 2014-10-14 07:54:01.321303474 -0500
|
|
+++ octave/Makefile 2014-10-14 07:53:24.038735037 -0500
|
|
@@ -98,6 +98,13 @@
|
|
${WRKSRC}/src/mkoctfile.bak > ${WRKSRC}/src/mkoctfile
|
|
chmod a+x ${WRKSRC}/src/mkoctfile
|
|
|
|
+# Test hack for Linux
|
|
+post-install:
|
|
+ (cd ${DESTDIR}${PREFIX}/lib/octave/3.6.4/oct && \
|
|
+ ln -s x86_64-redhat-linux-gnu x86_64-redhat-linux)
|
|
+ ${INSTALL_DATA} ${WRKSRC}/libgnu/charset.alias \
|
|
+ ${DESTDIR}${PREFIX}/lib
|
|
+
|
|
.include "../../audio/libsndfile/buildlink3.mk"
|
|
.include "../../devel/ncurses/buildlink3.mk"
|
|
.include "../../devel/pcre/buildlink3.mk"
|
|
Common subdirectories: ../math/octave/patches and octave/patches
|
|
Only in octave/: .svn
|
|
Only in ../math/octave/: work
|
|
|
|
Problem was reportedly fixed, but the patch has not been committed:
|
|
|
|
http://mail-index.netbsd.org/pkgsrc-users/2014/03/26/msg019464.html
|