pkgsrc-wip/libatomic_ops/patches/patch-ab
2007-11-05 06:53:56 +00:00

70 lines
1.6 KiB
Text

$NetBSD: patch-ab,v 1.1 2007/11/05 06:53:56 bsadewitz Exp $
--- configure.ac.orig 2005-09-28 17:29:49.000000000 -0400
+++ configure.ac
@@ -3,12 +3,13 @@ AC_INIT([libatomic_ops],[1.2])
AC_CANONICAL_TARGET([])
AC_CONFIG_SRCDIR(src/atomic_ops.c)
AM_INIT_AUTOMAKE
-AC_PROG_RANLIB
+AC_PROG_LIBTOOL
AM_CONFIG_HEADER(src/config.h)
# Checks for programs.
AC_PROG_CC
+AM_PROG_CC_C_O
AM_PROG_AS
# Checks for functions.
@@ -18,49 +19,11 @@ AC_FUNC_MMAP
AC_HEADER_STDC
# AC_CHECK_HEADERS([ ])
-# Determine PIC flag, adjust default CFLAGS
-need_asm=false
-PICFLAG=
-AC_MSG_CHECKING(Determining PIC compiler flag)
-if test "$GCC" = yes; then
- AC_MSG_RESULT(-fPIC)
- PICFLAG=-fPIC
-else
- case "$host" in
- *-*-hpux*)
- AC_MSG_RESULT("+Z")
- PICFLAG="+Z"
- if test "$GCC" != yes; then
- CFLAGS="$CFLAGS +O2 -mt"
- fi
- ;;
- *-*-solaris*)
- AC_MSG_RESULT(-Kpic)
- PICFLAG=-Kpic
- if test "$GCC" != yes; then
- CFLAGS="$CFLAGS -O"
- need_asm=true
- fi
- ;;
- *-*-linux*)
- AC_MSG_RESULT(-fPIC)
- PICFLAG=-fPIC
- # Any Linux compiler had better be gcc compatible.
- ;;
- *)
- AC_MSG_RESULT("<none>")
- ;;
- esac
-fi
-CFLAGS="$CFLAGS -DNDEBUG"
-
-AC_SUBST(PICFLAG)
AC_SUBST(DEFS)
AM_CONDITIONAL(NEED_ASM, test x$need_asm = xtrue)
AC_CONFIG_FILES([Makefile src/Makefile src/atomic_ops/Makefile src/atomic_ops/sysdeps/Makefile doc/Makefile tests/Makefile])
-AC_CONFIG_COMMANDS([default],[[]],[[PICFLAG=${PICFLAG}
-CC=${CC}
+AC_CONFIG_COMMANDS([default],[[]],[[CC=${CC}
DEFS=${DEFS}]])
AC_OUTPUT