The goal of the Subversion project is to build a version control system that is a compelling replacement for CVS in the open source community. The software is released under an Apache/BSD-style open source license. This package is based on the devel/subversion and devel/subversion-base ones present in pkgsrc. It tries to keep as much as possible to them Version 1.7.5 - client and server-side bugfixes - windows example distribution scripts Version 1.7.4 - various fixes - don't build mod_dontdothat if not building with httpd (r1243976) Version 1.7.3 - ship mod_dontdothat with the standard release - various fixes - replace a couple of assertions in favor of errors (r1207858, -949) - make 'svnadmin recover' prune the rep cache (r1213331, et al) - make svnmucc use values from --config-dir option - update and clarify the merge help text (r1154121, et al) - replace wc assertion with informative error (r1222521, -693) - improve 'svn log --with-all-revprops' over ra-dav (issue #4082) - improve correctness of 'svn patch --dry-run' (r1231944, -5) - enforce revisions given in 'svn:externals' (issue #4053) - make 'svn status --xml' show new files (issue #4097) - improve SASL error messages (r1236343, et al) - improve server cert error code for ra_serf (r1232413) - log some mod_dav_svn errors, rather than ignoring them (r1237720, -9596) - relax requirements for canonicalization in mod_dav_svn (r1236173) - allow committing the result of some copy operations (issue #4059) - allow running tests on UNC shares (r1225491) - skip 'svnrdump dump' tests over ra_serf (r1242537) - convert a few ra_serf assertions to errors (r1242607) Version 1.7.2 - various fixes - improve configure error message if apr-util uses old or no bdb (r1186784) - make 'svn patch' ignore '/dev/null' targets for compat with git (r1197998) - omit "Committed revision N." output from 'svn commit --quiet' (r1200837) - make working copy operations fail if nodes have no base checksum (r1202630) - make mod_dav_svn ignore non-Subversion POST requests (r1187695) - recognize empty (only byte order mark) UTF-8 files as text (issue #4064) - remove empty parent dirs of removed externals on update (issue #4044) - make 'svn diff -c N' work for files added in rN (issue #2873) - don't assert when committing an incomplete directory (issue #4042) - JavaHL: allow 'status -u' to function properly (r1189190, -395) - don't put '\r' characters in our generate sql headers (r1189580) - properly define WIN64 on Windows x64 builds (r1188609) - better adherence to C89 in enum definitions (r1189665) - bump copyright year in Windows DLLs (r1189261) - log a better error when opening rep-cache.db fails (r1204610, -73) Version 1.7.1 - improve performance of 'svn info' (r1164386) - improve hash table sorting performance (r1167659) - update bash completion for 1.7 (r1177001) - make 'svn ls' continue to work with 1.0-1.3 repos (r1154278, -379, -82) - improve handling of error messages generated by Cyrus SASL (r1179767) - update INSTALL documentation file (r1182115, and others) - error instead of assert when upgrading corrupt WCs (r1182904, -9) - various fixes and performance improvements - make 'svn add --parents D/file' work if D is deleted (r1185222) - add FSFS sanity check to prevent corruption seen in the wild (r1178280) - improve correctness/performance of recursive info and proplist (r1164426) - make the server tolerate svn:mergeinfo with malformed paths (r1182771) - improve zlib configuration (r1174761, -98, -806) - improve SQLite runtime init for OS X 10.7 compat (r1181666) - improve test suite correctness (r1174111) - fill in repos_* fields of svn_wc_status3_t for repos-only nodes (r1181609) - disable the SQLite shared process cache (r1185242, r1185280) Version 1.7.0 - No longer including contrib/ in the release tarballs (r877798) - Less verbose HTTP-based repository access protocol (issue #1161, #3371) - Rewritten working copy metadata storage (issue #3357) - New 'svn patch' subcommand (issue #511) - Rewritten FSFS in-memory caching for better performance - New remote repository dump/load client 'svnrdump' - Many minor bugfixes, new features and improvements since the 1.6.x versions
13 lines
599 B
Text
13 lines
599 B
Text
$NetBSD: patch-ad,v 1.1.1.1 2012/06/04 06:23:04 ftigeot Exp $
|
|
|
|
--- Makefile.in.orig 2011-07-16 11:50:53.000000000 +0000
|
|
+++ Makefile.in
|
|
@@ -736,7 +736,7 @@ $(SWIG_PL_DIR)/native/Makefile.PL: $(SWI
|
|
./config.status subversion/bindings/swig/perl/native/Makefile.PL
|
|
|
|
$(SWIG_PL_DIR)/native/Makefile: $(SWIG_PL_DIR)/native/Makefile.PL
|
|
- cd $(SWIG_PL_DIR)/native; $(PERL) Makefile.PL
|
|
+ cd $(SWIG_PL_DIR)/native; $(PERL) Makefile.PL INSTALLDIRS=vendor
|
|
|
|
# There is a "readlink -f" command on some systems for the same purpose,
|
|
# but it's not as portable (e.g. Mac OS X doesn't have it). These should
|