615a8b2ace
Tommy Frandsen. VGAlib supported a number of standard VGA graphics modes, as well high resolution/high color modes on many popular graphics adapters. As of now, support for many more chipsets has been added. It supports transparent virtual console switching, that is, you can switch consoles to and from text and graphics mode consoles using alt-[function key]. Also, svgalib corrects most of VGAlib's textmode corruption behaviour by catching SIGSEGV, SIGFPE, SIGILL, and other fatal signals and ensuring that a program is running in the currently visible virtual console before setting a graphics mode.
12 lines
377 B
Text
12 lines
377 B
Text
$NetBSD: patch-aq,v 1.1.1.1 2003/07/27 06:03:36 bencollver Exp $
|
|
|
|
--- gl/Makefile.orig Sun Jul 18 16:14:45 1999
|
|
+++ gl/Makefile
|
|
@@ -31,6 +31,7 @@
|
|
libvgagl.so.$(VERSION): $(MODULES)
|
|
$(CC) -s -shared -Wl,-soname,libvgagl.so.$(MAJOR_VER) -o libvgagl.so.$(VERSION) \
|
|
$(MODULES)
|
|
+ /bin/ln -sf libvgagl.so.$(MAJOR_VER) libvgagl.so
|
|
|
|
libvgagl.a: $(MODULES)
|
|
rm -f libvgagl.a
|