pkgsrc-wip/biopython/patches/patch-aa

46 lines
1.7 KiB
Text

$NetBSD: patch-aa,v 1.1.1.1 2004/11/18 21:02:38 daprice Exp $
--- setup.py.orig 2004-09-22 13:20:18.000000000 -0600
+++ setup.py 2004-09-22 13:22:27.000000000 -0600
@@ -86,29 +86,29 @@
if is_installed_fn():
continue
- print "*** %s *** is either not installed or out of date." % name
+# print "*** %s *** is either not installed or out of date." % name
if is_required:
-
+ print "*** %s *** is either not installed or out of date." % name
print """
This package is required for many Biopython features. Please install
it before you install Biopython."""
default = 0
else:
- print """
-This package is optional, which means it is only used in a few
-specialized modules in Biopython. You probably don't need this if you
-are unsure. You can ignore this requirement, and install it later if
-you see ImportErrors."""
+# print """
+#This package is optional, which means it is only used in a few
+#specialized modules in Biopython. You probably don't need this if you
+#are unsure. You can ignore this requirement, and install it later if
+#you see ImportErrors."""
default = 1
- print "You can find %s at %s." % (name, url)
- print
+# print "You can find %s at %s." % (name, url)
+# print
# exit automatically if required packages not installed
if not(default):
sys.exit(-1)
- if not get_yes_or_no(
- "Do you want to continue this installation?", default):
- return 0
+ # if not get_yes_or_no(
+ # "Do you want to continue this installation?", default):
+ # return 0
return 1
class install_biopython(install):