Initial Version
This commit is contained in:
parent
b9a9abf273
commit
001e582ecd
30 changed files with 405 additions and 0 deletions
16
audio/gkrellm-xmms/Makefile
Normal file
16
audio/gkrellm-xmms/Makefile
Normal file
|
@ -0,0 +1,16 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2001/10/30 13:22:05 damon Exp $
|
||||
|
||||
DISTNAME= gkrellmms-0.5.5
|
||||
PKGNAME= gkrellm-xmms-0.5.5
|
||||
WRKSRC= ${WRKDIR}/gkrellmms
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://gkrellm.luon.net/files/
|
||||
|
||||
MAINTAINER= damon@netbsd.org
|
||||
HOMEPAGE= http://gkrellm.luon.net/gkrellmms.phtml
|
||||
COMMENT= gkrellm xmms plugin
|
||||
|
||||
DEPENDS+= xmms>=1.2.5:../xmms
|
||||
DEPENDS+= gkrellm-1.2.*:../../sysutils/gkrellm
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
5
audio/gkrellm-xmms/distinfo
Normal file
5
audio/gkrellm-xmms/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2001/10/30 13:22:05 damon Exp $
|
||||
|
||||
SHA1 (gkrellmms-0.5.5.tar.gz) = afdf60b51f2cd974943364c377ea6f45edeb7ea8
|
||||
Size (gkrellmms-0.5.5.tar.gz) = 26721 bytes
|
||||
SHA1 (patch-aa) = f0b0c9266046bcea9b97fd9ae57f41b595d1eb11
|
32
audio/gkrellm-xmms/patches/patch-aa
Normal file
32
audio/gkrellm-xmms/patches/patch-aa
Normal file
|
@ -0,0 +1,32 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2001/10/30 13:22:05 damon Exp $
|
||||
|
||||
--- Makefile.orig Sat Jan 20 15:28:38 2001
|
||||
+++ Makefile
|
||||
@@ -10,14 +10,16 @@
|
||||
XMMS_INCLUDE = `xmms-config --cflags`
|
||||
XMMS_LIB = `xmms-config --libs`
|
||||
|
||||
-FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE) $(XMMS_INCLUDE)
|
||||
+CFLAGS += -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE) $(XMMS_INCLUDE)
|
||||
LIBS = $(GTK_LIB) $(IMLIB_LIB) $(XMMS_LIB)
|
||||
LFLAGS = -shared -lpthread
|
||||
|
||||
-CC = gcc $(CFLAGS) $(FLAGS)
|
||||
+CC = gcc $(CFLAGS)
|
||||
|
||||
OBJS = gkrellmms.o options.o playlist.o
|
||||
|
||||
+all: $(BIN_FILENAME).so
|
||||
+
|
||||
$(BIN_FILENAME).so: $(OBJS)
|
||||
$(CC) $(OBJS) -o $(BIN_FILENAME).so $(LFLAGS) $(LIBS)
|
||||
|
||||
@@ -25,7 +27,7 @@
|
||||
rm -f *.o core *.so* *.bak *~
|
||||
|
||||
install:
|
||||
- install -c -s -m 755 $(BIN_FILENAME).so /usr/share/gkrellm/plugins
|
||||
+ install -c -s -m 644 $(BIN_FILENAME).so ${PREFIX}/lib/gkrellm/plugins
|
||||
|
||||
gkrellmms.c.o: gkrellmms.c
|
||||
options.c.o: options.c
|
12
audio/gkrellm-xmms/pkg/DESCR
Normal file
12
audio/gkrellm-xmms/pkg/DESCR
Normal file
|
@ -0,0 +1,12 @@
|
|||
gkrellm plugin for controlling XMMS from within GKrellM.
|
||||
|
||||
GKrellMMS Features:
|
||||
|
||||
-Local Playlist Editor
|
||||
-Title scrolling
|
||||
-Progress bar (Krell) to see where you are in a song
|
||||
-Jumping in a file, by picking up the Krell
|
||||
-LED indicator which indicates whether XMMS is on, off, stopped,
|
||||
playing or paused
|
||||
-Themeable buttons, to control XMMS
|
||||
-A menu for some misc. XMMS-commands
|
2
audio/gkrellm-xmms/pkg/PLIST
Normal file
2
audio/gkrellm-xmms/pkg/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2001/10/30 13:22:05 damon Exp $
|
||||
lib/gkrellm/plugins/gkrellmms.so
|
25
finance/gkrellm-stock/Makefile
Normal file
25
finance/gkrellm-stock/Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2001/10/30 13:23:40 damon Exp $
|
||||
|
||||
DISTNAME= gkrellstock-0.2
|
||||
PKGNAME= gkrellm-stock-0.2
|
||||
WRKSRC= ${WRKDIR}/gkrellStock-0.2
|
||||
CATEGORIES= finance
|
||||
MASTER_SITES= http://www.geocities.com/m_muthukumar/
|
||||
|
||||
MAINTAINER= damon@netbsd.org
|
||||
HOMEPAGE= http://www.geocities.com/m_muthukumar/gkrellstock.html
|
||||
COMMENT= gkrellm stock ticker plugin
|
||||
|
||||
DEPENDS+= gkrellm-1.2.*:../../sysutils/gkrellm
|
||||
DEPENDS+= p5-finance-quote-1.*:../../finance/p5-finance-quote
|
||||
|
||||
USE_PERL5= # defined
|
||||
|
||||
do-configure:
|
||||
.for FILE in GetQuote Asia.pm
|
||||
${CP} ${WRKSRC}/${FILE} ${WRKSRC}/${FILE}.ORIG
|
||||
${SED} -e "s,/usr/bin/perl,${PERL5},g" \
|
||||
< ${WRKSRC}/${FILE}.ORIG > ${WRKSRC}/${FILE}
|
||||
.endfor
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
6
finance/gkrellm-stock/distinfo
Normal file
6
finance/gkrellm-stock/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2001/10/30 13:23:40 damon Exp $
|
||||
|
||||
SHA1 (gkrellstock-0.2.tar.gz) = 09f754fdb57505e52afacb22caec6c398ecc57de
|
||||
Size (gkrellstock-0.2.tar.gz) = 19062 bytes
|
||||
SHA1 (patch-aa) = bcdc060a96420778992a75deb7244da14de68e1e
|
||||
SHA1 (patch-ab) = 22d4b7ca33f5f682849c9f05e035567c422e2d31
|
51
finance/gkrellm-stock/patches/patch-aa
Normal file
51
finance/gkrellm-stock/patches/patch-aa
Normal file
|
@ -0,0 +1,51 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2001/10/30 13:23:40 damon Exp $
|
||||
|
||||
--- Makefile.orig Tue Aug 7 10:06:13 2001
|
||||
+++ Makefile
|
||||
@@ -5,14 +5,16 @@
|
||||
IMLIB_LIB = `imlib-config --libs-gdk`
|
||||
|
||||
|
||||
-FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE)
|
||||
+CFLAGS += -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE) -I${PREFIX}/include
|
||||
LIBS = $(GTK_LIB) $(IMLIB_LIB)
|
||||
LFLAGS = -shared
|
||||
|
||||
-CC = gcc $(CFLAGS) $(FLAGS)
|
||||
+CC = gcc $(CFLAGS)
|
||||
|
||||
OBJS = gkrellstock.o
|
||||
|
||||
+all: gkrellstock.so
|
||||
+
|
||||
gkrellstock.so: $(OBJS)
|
||||
$(CC) $(OBJS) -o gkrellstock.so $(LFLAGS) $(LIBS) -lpthread
|
||||
|
||||
@@ -22,23 +24,10 @@
|
||||
gkrellstock.o: gkrellstock.c
|
||||
|
||||
install:
|
||||
- if [ -d /usr/lib/gkrellm/plugins/ ] ; then \
|
||||
- install -c -s -m 644 gkrellstock.so /usr/lib/gkrellm/plugins/ ; \
|
||||
- elif [ -d /usr/share/gkrellm/plugins/ ] ; then \
|
||||
- install -c -s -m 644 gkrellstock.so /usr/share/gkrellm/plugins/ ; \
|
||||
- elif [ -d /usr/local/lib/gkrellm/plugins/ ] ; then \
|
||||
- install -c -s -m 644 gkrellstock.so /usr/local/lib/gkrellm/plugins/ ; \
|
||||
- elif [ -d /usr/lib/gkrellm/plugins/ ] ; then \
|
||||
- install -c -s -m 644 gkrellstock.so /usr/lib/gkrellm/plugins/ ; \
|
||||
- else \
|
||||
- install -D -c -s -m 644 gkrellstock.so /usr/lib/gkrellm/plugins/gkrellstock.so ; \
|
||||
- fi
|
||||
- install -c -m 755 GetStock /usr/X11R6/bin
|
||||
+ install -c -s -m 644 gkrellstock.so ${PREFIX}/lib/gkrellm/plugins
|
||||
+ install -c -m 755 GetQuote ${PREFIX}/bin
|
||||
|
||||
uninstall:
|
||||
- rm -f /usr/lib/gkrellm/plugins/gkrellstock.so
|
||||
- rm -f /usr/share/gkrellm/plugins/gkrellstock.so
|
||||
- rm -f /usr/local/lib/gkrellm/plugins/gkrellstock.so
|
||||
- rm -f /usr/lib/gkrellm/plugins/gkrellstock.so
|
||||
- rm -f /usr/X11R6/bin/GetQuote
|
||||
+ rm -f ${PREFIX}/lib/gkrellm/plugins/gkrellstock.so
|
||||
+ rm -f ${PREFIX}/bin/GetQuote
|
||||
|
16
finance/gkrellm-stock/patches/patch-ab
Normal file
16
finance/gkrellm-stock/patches/patch-ab
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2001/10/30 13:23:40 damon Exp $
|
||||
|
||||
--- GetQuote.orig Sat Oct 20 00:52:44 2001
|
||||
+++ GetQuote
|
||||
@@ -95,7 +95,10 @@
|
||||
# Get rid of puncuation in @ARGV. This will filter out metacharacters and
|
||||
# such, which makes the script marginally more safe
|
||||
#
|
||||
-foreach (@tickers) { s/[^a-zA-Z0-9\-=_\.]//; }
|
||||
+
|
||||
+# Add ^ to the list so that we can display indices
|
||||
+
|
||||
+foreach (@tickers) { s/[^a-zA-Z0-9\-=_\.\^]//; }
|
||||
|
||||
# Check the input to make sure we can look stuff up
|
||||
#
|
5
finance/gkrellm-stock/pkg/DESCR
Normal file
5
finance/gkrellm-stock/pkg/DESCR
Normal file
|
@ -0,0 +1,5 @@
|
|||
GKrellStock is a plugin for GKrellM that displays given stock
|
||||
tickers (current point and net change).
|
||||
|
||||
Uses perl script to get Quote information from given source
|
||||
(US, European, Australian, Canadian and Asian Markets).
|
3
finance/gkrellm-stock/pkg/PLIST
Normal file
3
finance/gkrellm-stock/pkg/PLIST
Normal file
|
@ -0,0 +1,3 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2001/10/30 13:23:40 damon Exp $
|
||||
lib/gkrellm/plugins/gkrellstock.so
|
||||
bin/GetQuote
|
21
finance/p5-finance-quote/Makefile
Normal file
21
finance/p5-finance-quote/Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2001/10/30 13:23:03 damon Exp $
|
||||
|
||||
DISTNAME= Finance-Quote-1.06
|
||||
PKGNAME= p5-finance-quote-1.06
|
||||
CATEGORIES= finance perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Finance/}
|
||||
|
||||
MAINTAINER= damon@brodiefamily.org
|
||||
HOMEPAGE= http://finance-quote.sourceforge.net/
|
||||
COMMENT= perl module to get stock quotes from Yahoo
|
||||
|
||||
DEPENDS+= p5-HTML-TableExtract-1.*:../../www/p5-HTML-TableExtract
|
||||
DEPENDS+= p5-libwww>=5.48:../../www/p5-libwww
|
||||
|
||||
USE_PERL5= # defined
|
||||
PERL5_PACKLIST= ${PERL5_SITEARCH}/auto/Finance/Quote/.packlist
|
||||
|
||||
do-configure:
|
||||
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
4
finance/p5-finance-quote/distinfo
Normal file
4
finance/p5-finance-quote/distinfo
Normal file
|
@ -0,0 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2001/10/30 13:23:03 damon Exp $
|
||||
|
||||
SHA1 (Finance-Quote-1.06.tar.gz) = 9c0e3d5a22749bc607349fe51e4f1d8b83085bf4
|
||||
Size (Finance-Quote-1.06.tar.gz) = 51658 bytes
|
4
finance/p5-finance-quote/pkg/DESCR
Normal file
4
finance/p5-finance-quote/pkg/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
Finance::Quote provides access to time-delayed stockquotes from a
|
||||
number of sources. After you've installed the pacakage, try
|
||||
'perldoc Finance::Quote' for full information. Alternatively,
|
||||
you can 'perldoc lib/Finance/Quote.pm' before the install.
|
1
finance/p5-finance-quote/pkg/PLIST
Normal file
1
finance/p5-finance-quote/pkg/PLIST
Normal file
|
@ -0,0 +1 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2001/10/30 13:23:03 damon Exp $
|
14
misc/gkrellm-moon/Makefile
Normal file
14
misc/gkrellm-moon/Makefile
Normal file
|
@ -0,0 +1,14 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2001/10/30 13:24:25 damon Exp $
|
||||
|
||||
DISTNAME= gkrellmoon-0.3
|
||||
PKGNAME= gkrellm-moon-0.3
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=gkrellmoon/}
|
||||
|
||||
MAINTAINER= damon@netbsd.org
|
||||
HOMEPAGE= http://gkrellmoon.sourceforge.net/
|
||||
COMMENT= gkrellm moonclock plugin
|
||||
|
||||
DEPENDS+= gkrellm-1.2.*:../../sysutils/gkrellm
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
5
misc/gkrellm-moon/distinfo
Normal file
5
misc/gkrellm-moon/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2001/10/30 13:24:25 damon Exp $
|
||||
|
||||
SHA1 (gkrellmoon-0.3.tar.gz) = 13c774ab2acc9cadc157c7cf16776c3b6bfb42f1
|
||||
Size (gkrellmoon-0.3.tar.gz) = 51988 bytes
|
||||
SHA1 (patch-aa) = 1af28d177f7ecaabcd41608d12685398f541c33d
|
33
misc/gkrellm-moon/patches/patch-aa
Normal file
33
misc/gkrellm-moon/patches/patch-aa
Normal file
|
@ -0,0 +1,33 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2001/10/30 13:24:25 damon Exp $
|
||||
|
||||
--- Makefile.orig Sat Oct 20 01:40:33 2001
|
||||
+++ Makefile
|
||||
@@ -4,17 +4,19 @@
|
||||
IMLIB_INCLUDE = `imlib-config --cflags-gdk`
|
||||
IMLIB_LIB = `imlib-config --libs-gdk`
|
||||
THREAD_LIB = -lpthread
|
||||
-INSTALLDIR = /usr/share/gkrellm/plugins
|
||||
+INSTALLDIR = ${PREFIX}/lib/gkrellm/plugins
|
||||
|
||||
|
||||
-FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE)
|
||||
+CFLAGS += -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE) -I${PREFIX}/include
|
||||
LIBS = $(GTK_LIB) $(IMLIB_LIB) $(THREAD_LIB)
|
||||
LFLAGS = -shared
|
||||
|
||||
-CC = gcc $(CFLAGS) $(FLAGS)
|
||||
+CC = gcc $(CFLAGS)
|
||||
|
||||
OBJS = gkrellmoon.o MoonRise.o CalcEphem.o Moon.o
|
||||
|
||||
+all: gkrellmoon.so
|
||||
+
|
||||
gkrellmoon.so: $(OBJS)
|
||||
$(CC) $(OBJS) -o gkrellmoon.so $(LFLAGS) $(LIBS)
|
||||
|
||||
@@ -26,4 +28,4 @@
|
||||
# %.o: %.c
|
||||
|
||||
install: gkrellmoon.so
|
||||
- sudo install -c -s -m 644 gkrellmoon.so $(INSTALLDIR)
|
||||
+ install -c -s -m 644 gkrellmoon.so $(INSTALLDIR)
|
2
misc/gkrellm-moon/pkg/DESCR
Normal file
2
misc/gkrellm-moon/pkg/DESCR
Normal file
|
@ -0,0 +1,2 @@
|
|||
gkrellmoon is a moon clock plugin for gkrellm. It shows the
|
||||
current phase of the moon.
|
2
misc/gkrellm-moon/pkg/PLIST
Normal file
2
misc/gkrellm-moon/pkg/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2001/10/30 13:24:25 damon Exp $
|
||||
lib/gkrellm/plugins/gkrellmoon.so
|
15
misc/gkrellm-weather/Makefile
Normal file
15
misc/gkrellm-weather/Makefile
Normal file
|
@ -0,0 +1,15 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2001/10/30 13:24:58 damon Exp $
|
||||
|
||||
DISTNAME= gkrellweather-0.2.7
|
||||
PKGNAME= gkrellm-weather-0.2.7
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://www.cse.unsw.edu.au/~flam/repository/c/gkrellm/
|
||||
|
||||
MAINTAINER= damon@netbsd.org
|
||||
HOMEPAGE= http://www.cse.unsw.edu.au/~flam/programs/gkrellweather.html
|
||||
COMMENT= gkrellm weather plugin
|
||||
|
||||
DEPENDS+= gkrellm-1.2.*:../../sysutils/gkrellm
|
||||
DEPENDS+= wmWeather-1.3*:../../x11/wmweather
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
5
misc/gkrellm-weather/distinfo
Normal file
5
misc/gkrellm-weather/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2001/10/30 13:24:58 damon Exp $
|
||||
|
||||
SHA1 (gkrellweather-0.2.7.tar.gz) = 509ec48ee81022f22ebe8cfa01768bcc6db2a7a7
|
||||
Size (gkrellweather-0.2.7.tar.gz) = 17188 bytes
|
||||
SHA1 (patch-aa) = e1fed69e9ea938c1295bff7b06c29187c5a5ed4b
|
49
misc/gkrellm-weather/patches/patch-aa
Normal file
49
misc/gkrellm-weather/patches/patch-aa
Normal file
|
@ -0,0 +1,49 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2001/10/30 13:24:58 damon Exp $
|
||||
|
||||
--- Makefile.orig Sat Oct 20 01:16:36 2001
|
||||
+++ Makefile
|
||||
@@ -5,14 +5,16 @@
|
||||
IMLIB_LIB = `imlib-config --libs-gdk`
|
||||
|
||||
|
||||
-FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE)
|
||||
+CFLAGS += -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE) -I${PREFIX}/include
|
||||
LIBS = $(GTK_LIB) $(IMLIB_LIB)
|
||||
LFLAGS = -shared
|
||||
|
||||
-CC = gcc $(CFLAGS) $(FLAGS)
|
||||
+CC = gcc $(CFLAGS)
|
||||
|
||||
OBJS = gkrellweather.o
|
||||
|
||||
+all: gkrellweather.so
|
||||
+
|
||||
gkrellweather.so: $(OBJS)
|
||||
$(CC) $(OBJS) -o gkrellweather.so $(LFLAGS) $(LIBS) -lpthread
|
||||
|
||||
@@ -22,23 +24,7 @@
|
||||
gkrellweather.o: gkrellweather.c
|
||||
|
||||
install:
|
||||
- if [ -d /usr/lib/gkrellm/plugins/ ] ; then \
|
||||
- install -c -s -m 644 gkrellweather.so /usr/lib/gkrellm/plugins/ ; \
|
||||
- elif [ -d /usr/share/gkrellm/plugins/ ] ; then \
|
||||
- install -c -s -m 644 gkrellweather.so /usr/share/gkrellm/plugins/ ; \
|
||||
- elif [ -d /usr/local/lib/gkrellm/plugins/ ] ; then \
|
||||
- install -c -s -m 644 gkrellweather.so /usr/local/lib/gkrellm/plugins/ ; \
|
||||
- elif [ -d /usr/lib/gkrellm/plugins/ ] ; then \
|
||||
- install -c -s -m 644 gkrellweather.so /usr/lib/gkrellm/plugins/ ; \
|
||||
- else \
|
||||
- install -D -c -s -m 644 gkrellweather.so /usr/lib/gkrellm/plugins/gkrellweather.so ; \
|
||||
- fi
|
||||
- install -c -m 755 GrabWeather /usr/X11R6/bin
|
||||
+ install -c -s -m 644 gkrellweather.so ${PREFIX}/lib/gkrellm/plugins/
|
||||
|
||||
uninstall:
|
||||
- rm -f /usr/lib/gkrellm/plugins/gkrellweather.so
|
||||
- rm -f /usr/share/gkrellm/plugins/gkrellweather.so
|
||||
- rm -f /usr/local/lib/gkrellm/plugins/gkrellweather.so
|
||||
- rm -f /usr/lib/gkrellm/plugins/gkrellweather.so
|
||||
- rm -f /usr/X11R6/bin/GrabWeather
|
||||
-
|
||||
+ rm -f ${PREFIX}/lib/plugins/gkrellweather.so
|
11
misc/gkrellm-weather/pkg/DESCR
Normal file
11
misc/gkrellm-weather/pkg/DESCR
Normal file
|
@ -0,0 +1,11 @@
|
|||
GKrellWeather is a weather plugin for GKrellM.
|
||||
Features
|
||||
-Choose your own location by 4-letter METAR station identifier code.
|
||||
-Monitor temperature, dew point, pressure, relative humidity, sky
|
||||
condition, wind direction and speed
|
||||
-Display using imperial units (degrees Fareheight, inches of Mercury,
|
||||
miles per hour)
|
||||
-Display using metric units (degrees Celsius, millimeters of Mercury,
|
||||
kilometers per hour)
|
||||
-Display pressure in kPa, hPa and mmHg
|
||||
-Display wind speeds in kmph, mps and beaufort scale
|
2
misc/gkrellm-weather/pkg/PLIST
Normal file
2
misc/gkrellm-weather/pkg/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2001/10/30 13:24:58 damon Exp $
|
||||
lib/gkrellm/plugins/gkrellweather.so
|
16
x11/gnome-gkrellm/Makefile
Normal file
16
x11/gnome-gkrellm/Makefile
Normal file
|
@ -0,0 +1,16 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2001/10/30 13:25:49 damon Exp $
|
||||
|
||||
DISTNAME= gkrellm-gnome
|
||||
PKGNAME= gnome-gkrellm-0.1
|
||||
CATEGORIES= gnome sysutils
|
||||
MASTER_SITES= http://web.wt.net/~billw/gkrellm/Plugins/
|
||||
|
||||
MAINTAINER= damon@netbsd.org
|
||||
HOMEPAGE= http://web.wt.net/~billw/gkrellm/Plugins.html
|
||||
COMMENT= gkrellm gnome plugin
|
||||
|
||||
DEPENDS+= gkrellm-1.2.*:../../sysutils/gkrellm
|
||||
|
||||
USE_GMAKE= yes
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
5
x11/gnome-gkrellm/distinfo
Normal file
5
x11/gnome-gkrellm/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2001/10/30 13:25:49 damon Exp $
|
||||
|
||||
SHA1 (gkrellm-gnome.tar.gz) = d8d18ebdf09a4b314ac305e37c9412f44f722bc5
|
||||
Size (gkrellm-gnome.tar.gz) = 5825 bytes
|
||||
SHA1 (patch-aa) = 02414b2eb6d2697b295870a8827d9e626367f4e8
|
37
x11/gnome-gkrellm/patches/patch-aa
Normal file
37
x11/gnome-gkrellm/patches/patch-aa
Normal file
|
@ -0,0 +1,37 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2001/10/30 13:25:49 damon Exp $
|
||||
|
||||
--- src/Makefile.orig Sun Jan 14 17:03:48 2001
|
||||
+++ src/Makefile
|
||||
@@ -1,4 +1,4 @@
|
||||
-PLUGIN_INSTALLDIR ?= /usr/local/share/gkrellm/plugins
|
||||
+PLUGIN_INSTALLDIR = ${PREFIX}/lib/gkrellm/plugins
|
||||
|
||||
|
||||
GNOME_INCLUDE = `gnome-config --cflags gnome gnomeui`
|
||||
@@ -7,7 +7,7 @@
|
||||
GTK_INCLUDE = `gtk-config --cflags`
|
||||
GTK_LIB = `gtk-config --libs`
|
||||
|
||||
-FLAGS = -O2 -Wall -fPIC $(GNOME_INCLUDE) $(GTK_INCLUDE)
|
||||
+CFLAGS += -fPIC $(GNOME_INCLUDE) $(GTK_INCLUDE) -I${PREFIX}/include
|
||||
LIBS = $(GNOME_LIB) $(GTK_LIB)
|
||||
LFLAGS = -shared
|
||||
|
||||
@@ -20,7 +20,7 @@
|
||||
endif
|
||||
|
||||
|
||||
-CC = gcc $(FLAGS) $(CFLAGS)
|
||||
+CC = gcc $(CFLAGS)
|
||||
|
||||
OBJS = gkrellm-gnome.o
|
||||
|
||||
@@ -31,7 +31,6 @@
|
||||
rm -f *.o core *.so* *.bak *~
|
||||
|
||||
install:
|
||||
- install -d -m 755 $(PLUGIN_INSTALLDIR)
|
||||
- install -c -s -m 755 gkrellm-gnome.so $(PLUGIN_INSTALLDIR)
|
||||
+ install -c -s -m 644 gkrellm-gnome.so $(PLUGIN_INSTALLDIR)
|
||||
|
||||
gkrellm-gnome.c.o: gkrellm-gnome.c
|
4
x11/gnome-gkrellm/pkg/DESCR
Normal file
4
x11/gnome-gkrellm/pkg/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
This plugin will interface GKrellM to Gnome and give you session management.
|
||||
For Gnome compliant window managers, you can set the options: ontop, sticky,
|
||||
skip winlist, and skip focus. For the Gnome panel, you can set the option:
|
||||
don't put on the tasklist.
|
2
x11/gnome-gkrellm/pkg/PLIST
Normal file
2
x11/gnome-gkrellm/pkg/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2001/10/30 13:25:49 damon Exp $
|
||||
lib/gkrellm/plugins/gkrellm-gnome.so
|
Loading…
Reference in a new issue