Import of tinyproxy-1.5.2: lightweight HTTP/SSL proxy.

tinyproxy is a lightweight HTTP/SSL proxy. Designed from the ground up to be
fast and yet small, it is an ideal solution for sites where a full-featured
HTTP proxy is required, but the system resources required to run a more
demanding HTTP proxy are unavailable. tinyproxy is fully compatible with all
existing web browsers.

Package submitted by Juan RP via PR pkg/20595 with modifications by me.
This commit is contained in:
salo 2003-03-07 23:46:01 +00:00
parent b35f6572bc
commit 00619c7d9e
9 changed files with 159 additions and 0 deletions

5
www/tinyproxy/DESCR Normal file
View file

@ -0,0 +1,5 @@
tinyproxy is a lightweight HTTP/SSL proxy. Designed from the ground up to be
fast and yet small, it is an ideal solution for sites where a full-featured
HTTP proxy is required, but the system resources required to run a more
demanding HTTP proxy are unavailable. tinyproxy is fully compatible with all
existing web browsers.

16
www/tinyproxy/MESSAGE Normal file
View file

@ -0,0 +1,16 @@
===========================================================================
$NetBSD: MESSAGE,v 1.1.1.1 2003/03/07 23:46:01 salo Exp $
To use tinyproxy, you will need to perform the following steps:
1. In case you don't have PKG_RCD_SCRIPTS set in your /etc/mk.conf, copy
${PREFIX}/etc/rc.d/tinyproxy to /etc/rc.d/tinyproxy and add
tinyproxy=YES
to /etc/rc.conf.
2. Now start tinyproxy by issuing the command
/etc/rc.d/tinyproxy start
===========================================================================

55
www/tinyproxy/Makefile Normal file
View file

@ -0,0 +1,55 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/03/07 23:46:01 salo Exp $
#
DISTNAME= tinyproxy-1.5.2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=tinyproxy/}
MAINTAINER= jrp@hispabsd.org
HOMEPAGE= http://tinyproxy.sourceforge.net/
COMMENT= lightweight HTTP/SSL proxy
USE_BUILDLINK2= YES
USE_PKGINSTALL= YES
USE_GMAKE= YES
GNU_CONFIGURE= YES
RCD_SCRIPTS= tinyproxy
PKG_SYSCONFSUBDIR= tinyproxy
TINYPROXY_USER?= tinyproxy
TINYPROXY_GROUP?= tinyproxy
PKG_GROUPS= ${TINYPROXY_GROUP}
PKG_USERS= ${TINYPROXY_USER}:${TINYPROXY_GROUP}::Tinyproxy\\ user
FILES_SUBST+= TINYPROXY_USER="${TINYPROXY_USER}"
FILES_SUBST+= TINYPROXY_GROUP="${TINYPROXY_GROUP}"
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFBASE}
CONFIGURE_ARGS+= --enable-transparent-proxy
# Socks support
.if defined(USE_SOCKS) && ${USE_SOCKS} == YES
CONFIGURE_ARGS+= --enable-socks
.endif
EGDIR= ${PREFIX}/share/examples/tinyproxy
CONF_FILES= ${EGDIR}/tinyproxy.conf.default ${PKG_SYSCONFDIR}/tinyproxy.conf
post-patch:
@cd ${WRKSRC}/doc && \
for f in tinyproxy.8 tinyproxy.conf; do \
${MV} $${f} $${f}.orig; \
${SED} ${FILES_SUBST_SED} $${f}.orig > $${f}; \
done
post-install:
${INSTALL_DATA_DIR} ${EGDIR}
${INSTALL_DATA} ${WRKSRC}/doc/tinyproxy.conf \
${EGDIR}/tinyproxy.conf.default
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/tinyproxy
${INSTALL_DATA} ${WRKSRC}/doc/filter-howto.txt \
${PREFIX}/share/doc/tinyproxy/
.include "../../security/openssl/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

8
www/tinyproxy/PLIST Normal file
View file

@ -0,0 +1,8 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/03/07 23:46:01 salo Exp $
etc/rc.d/tinyproxy
man/man8/tinyproxy.8
sbin/tinyproxy
share/doc/tinyproxy/filter-howto.txt
share/examples/tinyproxy/tinyproxy.conf.default
@dirrm share/examples/tinyproxy
@dirrm share/doc/tinyproxy

7
www/tinyproxy/distinfo Normal file
View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2003/03/07 23:46:01 salo Exp $
SHA1 (tinyproxy-1.5.2.tar.gz) = 41c7e95758d5763e07b01e981f44391652cd3d41
Size (tinyproxy-1.5.2.tar.gz) = 251964 bytes
SHA1 (patch-aa) = e94f2410ae2b5dd94a1039e96635b32505de9f5d
SHA1 (patch-ab) = b6a18b859cb3260c237a98745ca9e2d0e1a1b486
SHA1 (patch-ac) = baab9768068f1d11a34c22295396726e867e32a4

View file

@ -0,0 +1,18 @@
#!/bin/sh
#
# $NetBSD: tinyproxy.sh,v 1.1.1.1 2003/03/07 23:46:01 salo Exp $
#
# PROVIDE: tinyproxy
# REQUIRE: DAEMON
. /etc/rc.subr
name="tinyproxy"
rcvar=$name
command="@PREFIX@/sbin/${name}"
pidfile="/var/run/${name}.pid"
required_files="@PKG_SYSCONFDIR@/$name.conf"
load_rc_config $name
run_rc_command "$1"

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/03/07 23:46:01 salo Exp $
--- Makefile.in.orig 2003-01-22 20:50:28.000000000 +0100
+++ Makefile.in 2003-03-07 23:04:34.000000000 +0100
@@ -298,7 +298,7 @@
install-exec-am:
install-exec: install-exec-recursive
-install-data-am: install-data-local
+install-data-am:
install-data: install-data-recursive
install-am: all-am

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1.1.1 2003/03/07 23:46:01 salo Exp $
--- doc/tinyproxy.8.orig 2001-08-27 17:45:31.000000000 +0200
+++ doc/tinyproxy.8 2003-03-07 23:13:09.000000000 +0100
@@ -41,7 +41,7 @@
connections have been handled.
.SH FILES
.nf
-/etc/tinyproxy/tinyproxy.conf
+@PKG_SYSCONFDIR@/tinyproxy.conf
/var/run/tinyproxy.pid
/var/log/tinyproxy.log
.fi

View file

@ -0,0 +1,24 @@
$NetBSD: patch-ac,v 1.1.1.1 2003/03/07 23:46:01 salo Exp $
--- doc/tinyproxy.conf.orig 2003-03-08 00:11:42.000000000 +0100
+++ doc/tinyproxy.conf 2003-03-08 00:14:15.000000000 +0100
@@ -6,8 +6,8 @@
# Name of the user the tinyproxy daemon should switch to after the port
# has been bound.
#
-User nobody
-Group nogroup
+User @TINYPROXY_USER@
+Group @TINYPROXY_GROUP@
#
# Port to listen on.
@@ -120,7 +120,7 @@
#
# The location of the filter file.
#
-#Filter "/etc/tinyproxy/filter"
+#Filter "@PKG_SYSCONFDIR@/filter"
#
# Filter based on URLs rather than domains.