py-xopen: updated to 0.4.0
0.4.0: Unknown changes
This commit is contained in:
parent
2a6b2084d4
commit
00917013e7
4 changed files with 35 additions and 10 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.4 2018/07/06 08:02:53 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2019/01/09 10:49:28 adam Exp $
|
||||
|
||||
DISTNAME= xopen-0.3.5
|
||||
DISTNAME= xopen-0.4.0
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= ${MASTER_SITE_PYPI:=x/xopen/}
|
||||
|
@ -10,9 +10,18 @@ HOMEPAGE= https://github.com/marcelm/xopen
|
|||
COMMENT= Open compressed files transparently
|
||||
LICENSE= mit
|
||||
|
||||
BUILD_DEPENDS+= ${PYPKGPREFIX}-setuptools_scm-[0-9]*:../../devel/py-setuptools_scm
|
||||
TEST_DEPENDS+= ${PYPKGPREFIX}-test-[0-9]*:../../devel/py-test
|
||||
|
||||
.include "../../lang/python/pyversion.mk"
|
||||
.if ${_PYTHON_VERSION} == 27
|
||||
DEPENDS+= ${PYPKGPREFIX}-bz2file-[0-9]*:../../archivers/py-bz2file
|
||||
.endif
|
||||
|
||||
USE_LANGUAGES= # none
|
||||
|
||||
# Python 2.7: requires bz2file
|
||||
do-test:
|
||||
cd ${WRKSRC} && pytest-${PYVERSSUFFIX} tests
|
||||
|
||||
.include "../../lang/python/egg.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2018/01/07 20:58:10 joerg Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2019/01/09 10:49:28 adam Exp $
|
||||
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
|
||||
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
|
||||
${PLIST.py2x}${PYSITELIB}/${EGG_INFODIR}/requires.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/requires.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
|
||||
${PYSITELIB}/xopen.py
|
||||
${PYSITELIB}/xopen.pyc
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.3 2018/07/06 08:02:53 adam Exp $
|
||||
$NetBSD: distinfo,v 1.4 2019/01/09 10:49:28 adam Exp $
|
||||
|
||||
SHA1 (xopen-0.3.5.tar.gz) = 953a248fe905836f65a6790e19243b5161e19ef1
|
||||
RMD160 (xopen-0.3.5.tar.gz) = 8f49eeeedb1919087833b7d257eb342e7ca45c7b
|
||||
SHA512 (xopen-0.3.5.tar.gz) = e0bf7c2218bd629f67d0e63b2b16598ed677890d0d12829890742970ce9e1309ea5b3c8f26e88befc77166e146c23fedce6436edd280ee860ef02d00a2025965
|
||||
Size (xopen-0.3.5.tar.gz) = 4736 bytes
|
||||
SHA1 (xopen-0.4.0.tar.gz) = 1d3f0e1648f3b46bcb7a48ba42e9f285c2e61c7b
|
||||
RMD160 (xopen-0.4.0.tar.gz) = ff2236e525cd37fabffb45e79057f1b50dcd2717
|
||||
SHA512 (xopen-0.4.0.tar.gz) = b0555b4543229e9f1a4683a9b3a8806eb1444a677b3a347aa225e6ba428974492cdc4bb6e188aafca73762371bcd876a31721c14d82ac802247518ccf15cb9bf
|
||||
Size (xopen-0.4.0.tar.gz) = 8881 bytes
|
||||
SHA1 (patch-setup.py) = 23184261c8c86975470b2cd82dfbfcb16a536573
|
||||
|
|
15
devel/py-xopen/patches/patch-setup.py
Normal file
15
devel/py-xopen/patches/patch-setup.py
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-setup.py,v 1.1 2019/01/09 10:49:28 adam Exp $
|
||||
|
||||
Replace non-ASCII character.
|
||||
|
||||
--- setup.py.orig 2019-01-09 10:39:25.000000000 +0000
|
||||
+++ setup.py
|
||||
@@ -11,7 +11,7 @@ with open('README.rst') as f:
|
||||
setup(
|
||||
name='xopen',
|
||||
use_scm_version=True,
|
||||
- setup_requires=['setuptools_scm'], # Support pip versions that don’t know about pyproject.toml
|
||||
+ setup_requires=['setuptools_scm'], # Support pip versions that don't know about pyproject.toml
|
||||
author='Marcel Martin',
|
||||
author_email='mail@marcelm.net',
|
||||
url='https://github.com/marcelm/xopen/',
|
Loading…
Reference in a new issue