Initial import of torrenttools-0.3.0:
The torrentutils are a set of utilities for managing BitTorrent (`.torrent') files and interactiving with BitTorrent trackers. The torrentutils contain the following programs: torrenttool is a script that extracts and displays information from BitTorrent files, as well as testing and generate checksums for files listed in them. defrag is a script that defrags files simply by making a copy of the file. The original file is then replaced by the copy. Due to the fact that BitTorrent splits files in pieces, and downloads these pieces in random order, the downloaded files are often severely fragmented. This means that reading these files will be slower, sometimes as much as 30% slower. defrag can also recurse directories.
This commit is contained in:
parent
65685231e5
commit
009df44d04
5 changed files with 84 additions and 0 deletions
14
net/torrentutils/DESCR
Normal file
14
net/torrentutils/DESCR
Normal file
|
@ -0,0 +1,14 @@
|
|||
The torrentutils are a set of utilities for managing BitTorrent
|
||||
(`.torrent') files and interactiving with BitTorrent trackers.
|
||||
The torrentutils contain the following programs:
|
||||
|
||||
torrenttool is a script that extracts and displays information from
|
||||
BitTorrent files, as well as testing and generate checksums for
|
||||
files listed in them.
|
||||
|
||||
defrag is a script that defrags files simply by making a copy of
|
||||
the file. The original file is then replaced by the copy. Due to
|
||||
the fact that BitTorrent splits files in pieces, and downloads
|
||||
these pieces in random order, the downloaded files are often severely
|
||||
fragmented. This means that reading these files will be slower,
|
||||
sometimes as much as 30% slower. defrag can also recurse directories.
|
20
net/torrentutils/Makefile
Normal file
20
net/torrentutils/Makefile
Normal file
|
@ -0,0 +1,20 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2004/03/04 15:47:34 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= torrentutils-0.3.0
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.student.lu.se/~nbi98oli/src/
|
||||
|
||||
MAINTAINER= wiz@NetBSD.org
|
||||
HOMEPAGE= http://www.student.lu.se/~nbi98oli/src/
|
||||
COMMENT= Manage BitTorrent files and interact with trackers
|
||||
|
||||
DEPENDS+= p5-Digest-SHA1-[0-9]*:../../security/p5-Digest-SHA1
|
||||
|
||||
USE_BUILDLINK3= yes
|
||||
USE_GNU_TOOLS= make
|
||||
USE_PERL5= yes
|
||||
|
||||
REPLACE_PERL= torrenttool.in
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
5
net/torrentutils/PLIST
Normal file
5
net/torrentutils/PLIST
Normal file
|
@ -0,0 +1,5 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2004/03/04 15:47:34 wiz Exp $
|
||||
bin/torrenttool
|
||||
bin/defrag
|
||||
man/man1/torrenttool.1
|
||||
man/man1/defrag.1
|
5
net/torrentutils/distinfo
Normal file
5
net/torrentutils/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2004/03/04 15:47:34 wiz Exp $
|
||||
|
||||
SHA1 (torrentutils-0.3.0.tar.gz) = d9487551e5de128c31abe7fc404ec3a51d6a83a0
|
||||
Size (torrentutils-0.3.0.tar.gz) = 21697 bytes
|
||||
SHA1 (patch-aa) = 391e7f4973629df65925233e548d688ae9a94c1e
|
40
net/torrentutils/patches/patch-aa
Normal file
40
net/torrentutils/patches/patch-aa
Normal file
|
@ -0,0 +1,40 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2004/03/04 15:47:34 wiz Exp $
|
||||
|
||||
--- Makefile.orig Sun Oct 12 14:13:16 2003
|
||||
+++ Makefile
|
||||
@@ -1,9 +1,9 @@
|
||||
# Root of installation tree
|
||||
-PREFIX = /home/usel/tmp
|
||||
+#PREFIX = /home/usel/tmp
|
||||
# Path where the executables are installed
|
||||
BINDIR = $(PREFIX)/bin
|
||||
# Path where the manual pages are installed
|
||||
-MANDIR = $(PREFIX)/share/man
|
||||
+MANDIR = $(PREFIX)/man
|
||||
# Path to Midnight Commander extfs
|
||||
MCEXTFSDIR = $(PREFIX)/share/mc/extfs
|
||||
|
||||
@@ -44,19 +44,10 @@ torrentutils.spec: torrentutils.spec.in
|
||||
if [[ "$@" != *.spec ]]; then chmod a+x $@; fi
|
||||
|
||||
install: all
|
||||
- install -d $(BINDIR) $(MANDIR)/man1
|
||||
- install -m 755 torrenttool $(BINDIR)/torrenttool
|
||||
- install -m 755 defrag $(BINDIR)
|
||||
- rm -f tmp.torrenttool.$$
|
||||
- install -m 644 torrenttool.1 $(MANDIR)/man1
|
||||
- install -m 644 defrag.1 $(MANDIR)/man1
|
||||
- install -d $(MCEXTFSDIR)
|
||||
- install -m 755 torrentmcfs $(MCEXTFSDIR); \
|
||||
- if [ -f $(MCEXTFSDIR)/extfs.ini ]; then \
|
||||
- grep '^torrentmcfs$$' $(MCEXTFSDIR)/extfs.ini || echo 'torrentmcfs' >> $(MCEXTFSDIR)/extfs.ini; \
|
||||
- else \
|
||||
- echo "$(MCEXTFSDIR) does not exist. Not installing MC extfs support."; \
|
||||
- fi
|
||||
+ ${BSD_INSTALL_SCRIPT} torrenttool $(BINDIR)/torrenttool
|
||||
+ ${BSD_INSTALL_SCRIPT} defrag $(BINDIR)
|
||||
+ ${BSD_INSTALL_MAN} torrenttool.1 $(MANDIR)/man1
|
||||
+ ${BSD_INSTALL_MAN} defrag.1 $(MANDIR)/man1
|
||||
|
||||
clean:
|
||||
rm -f torrenttool torrentmcfs defrag torrentutils.spec
|
Loading…
Reference in a new issue