No matherr on DragonFly.

This commit is contained in:
joerg 2006-01-11 21:05:24 +00:00
parent b622fea3e0
commit 00dd30bd9c
3 changed files with 33 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.9 2005/02/24 09:03:12 agc Exp $
$NetBSD: distinfo,v 1.10 2006/01/11 21:05:24 joerg Exp $
SHA1 (tclx8.3.5-src.tar.gz) = 74092449684d11dd73a4cb91fa3e1442e9e21d47
RMD160 (tclx8.3.5-src.tar.gz) = b501c1c48b54950ea7fb6d3d6d27ef3e7d58c5a5
@ -10,3 +10,5 @@ SHA1 (patch-ad) = 252a21da464267d7c7d45e168a89b29a40273359
SHA1 (patch-ae) = a43144f37706245779362026073e09d8505a3d3f
SHA1 (patch-af) = 64810cf27a40dcc6f9c12b94295e0b61db2e24a3
SHA1 (patch-ag) = 6c8876699bfe325b3370bb554d4727e05fc64b8b
SHA1 (patch-ah) = 37f883b17e3cec0266f9cd8c60cece521e59f56a
SHA1 (patch-ai) = 07572c47a3ee375f89488dbbfe52697091beccfb

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ah,v 1.3 2006/01/11 21:05:24 joerg Exp $
--- ../tcl/unix/tclXAppInit.c.orig 2006-01-11 18:50:33.000000000 +0000
+++ ../tcl/unix/tclXAppInit.c
@@ -25,8 +25,10 @@
* Even if matherr is not used on this system, there is a dummy version
* in libtcl.
*/
+#if !defined(__DragonFly__)
extern int matherr ();
int (*tclDummyMathPtr)() = matherr;
+#endif
/*-----------------------------------------------------------------------------

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ai,v 1.1 2006/01/11 21:05:24 joerg Exp $
--- ../tcl/unix/tclXunixTest.c.orig 2006-01-11 20:06:24.000000000 +0000
+++ ../tcl/unix/tclXunixTest.c
@@ -31,8 +31,10 @@ Tclxtest_Init _ANSI_ARGS_((Tcl_Interp *i
* Even if matherr is not used on this system, there is a dummy version
* in libtcl.
*/
+#if !defined(__DragonFly__)
extern int matherr ();
int (*tclDummyMathPtr)() = matherr;
+#endif
/*-----------------------------------------------------------------------------
* main --