Initial import of quake2forge-0.2.1.

This is a port of the GPL'd Quake 2 source maintained by the Quake Forge
team. They're patching it with an eye towards portability and bug fixes,
and in the future, feature enhancments.

Note that to actually USE this package you will need to obtain a copy of
the original Quake 2 from id Software.
This commit is contained in:
xtraeme 2004-04-16 15:03:20 +00:00
parent 49ee9875d3
commit 00f8ac5e15
6 changed files with 138 additions and 0 deletions

6
games/quake2forge/DESCR Normal file
View file

@ -0,0 +1,6 @@
This is a port of the GPL'd Quake 2 source maintained by the Quake Forge
team. They're patching it with an eye towards portability and bug fixes,
and in the future, feature enhancments.
Note that to actually USE this package you will need to obtain a copy of
the original Quake 2 from id Software.

View file

@ -0,0 +1,9 @@
==========================================================================
$NetBSD: MESSAGE,v 1.1.1.1 2004/04/16 15:03:21 xtraeme Exp $
To run Quake 2(TM), you must place the .pak files from your Quake 2
CD into:
${PREFIX}/share/quake2/baseq2
==========================================================================

View file

@ -0,0 +1,32 @@
# $NetBSD: Makefile,v 1.1.1.1 2004/04/16 15:03:20 xtraeme Exp $
#
DISTNAME= quake2-0.2.1
PKGNAME= ${DISTNAME:S/quake2/quake2forge/}
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=quake/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= xtraeme@NetBSD.org
HOMEPAGE= http://www.quakeforge.net/
COMMENT= Quake2Forge is the Quake II engine
USE_BUILDLINK3= yes
USE_GNU_TOOLS+= make
USE_LIBTOOL= yes
USE_X11= yes
GNU_CONFIGURE= yes
BUILDLINK_TRANSFORM+= S:-Werror:
CONFIGURE_ARGS+= --program-transform-name='s/^quake2$$/quake2forge/'
post-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/quake2forge
${INSTALL_DATA} ${WRKSRC}/docs/README* ${PREFIX}/share/doc/quake2forge
${INSTALL_DATA} ${WRKSRC}/docs/*.txt ${PREFIX}/share/doc/quake2forge
.include "../../devel/SDL/buildlink3.mk"
.include "../../graphics/Mesa/buildlink3.mk"
.include "../../mk/ossaudio.buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

42
games/quake2forge/PLIST Normal file
View file

@ -0,0 +1,42 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/04/16 15:03:20 xtraeme Exp $
bin/quake2forge
lib/quake2/baseq2/game.a
lib/quake2/baseq2/game.la
lib/quake2/baseq2/game.so
lib/quake2/ctf/game.a
lib/quake2/ctf/game.la
lib/quake2/ctf/game.so
lib/quake2/ref_glx.a
lib/quake2/ref_glx.la
lib/quake2/ref_glx.so
lib/quake2/ref_sdlgl.a
lib/quake2/ref_sdlgl.la
lib/quake2/ref_sdlgl.so
lib/quake2/ref_softsdl.a
lib/quake2/ref_softsdl.la
lib/quake2/ref_softsdl.so
lib/quake2/ref_softx.a
lib/quake2/ref_softx.la
lib/quake2/ref_softx.so
share/doc/quake2forge/README.Solaris
share/doc/quake2forge/README.axp
share/doc/quake2forge/README.install
share/doc/quake2forge/README.joystick
share/doc/quake2forge/README.linux
share/doc/quake2forge/README.sdl
share/doc/quake2forge/README.solaris
share/doc/quake2forge/TODO-ctf.txt
share/doc/quake2forge/changes-ctf.txt
share/doc/quake2forge/changes.txt
share/doc/quake2forge/joystick.txt
share/doc/quake2forge/readme.txt
share/quake2/baseq2/config.cfg
@dirrm share/quake2/baseq2
@dirrm share/doc/quake2forge
@exec ${MKDIR} %D/lib/quake2/xatrix
@dirrm lib/quake2/xatrix
@exec ${MKDIR} %D/lib/quake2/rogue
@dirrm lib/quake2/rogue
@dirrm lib/quake2/ctf
@dirrm lib/quake2/baseq2
@dirrm lib/quake2

View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2004/04/16 15:03:20 xtraeme Exp $
SHA1 (quake2-0.2.1.tar.bz2) = 258a391f54dd58e59924f78c074e614b228ff773
Size (quake2-0.2.1.tar.bz2) = 1286703 bytes
SHA1 (patch-aa) = 380078cc177fcc8b7d7c5bf2fd59620d67349d55

View file

@ -0,0 +1,44 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/04/16 15:03:21 xtraeme Exp $
--- src/main.c.orig Fri Feb 7 14:25:46 2003
+++ src/main.c Fri Feb 7 14:34:14 2003
@@ -49,12 +49,21 @@
#include <mntent.h>
#elif defined(__FreeBSD__) || defined(__bsd__) || defined (__NetBSD__)
#include <fstab.h>
+ #include <pthread.h>
#elif defined(__sun__)
#include <sys/file.h>
#endif
#ifdef HAVE_DLOPEN
# include <dlfcn.h>
+#endif
+
+/* This should probably go into configure
+ * BSDs and Linux have SIGIO, Solaris needs SIGPOLL
+ * This should probably be changed the other way round
+ * SIGIO as default and SIGPOLL only for Solrais */
+#ifndef SIGPOLL
+#define SIGPOLL SIGIO
#endif
#include "qcommon.h"
@@ -518,7 +527,7 @@
ret = fread(ptr, size, nitems, fp);
err = errno;
if (ret != nitems) {
- printf("verify_fread(...,%d,%d,...): return value: %d\n", size, nitems, ret);
+ printf("verify_fread(...,%lu,%lu,...): return value: %lu\n", (unsigned long)size, (unsigned long)nitems, (unsigned long)ret);
if (ret == 0 && ferror(fp)) {
printf(" error: %s\n", strerror(err));
printf(" fileno=%d\n", fileno(fp));
@@ -536,7 +545,7 @@
ret = fwrite(ptr, size, nitems, fp);
err = errno;
if (ret != nitems) {
- printf("verify_fwrite(...,%d,%d,...) = %d\n", size, nitems, ret);
+ printf("verify_fwrite(...,%lu,%lu,...) = %lu\n", (unsigned long)size, (unsigned long)nitems, (unsigned long)ret);
if (ret == 0 && ferror(fp)) {
printf(" error: %s\n", strerror(err));
printf(" fileno=%d\n", fileno(fp));