Bring this package closer to building under NetBSD 4.0:

- Escape some question marks to avoid weird GCC warning.
- Fix broken use of "__attributed (__packed__)". Bump package revision
  because this is a code generation issue.
This commit is contained in:
tron 2007-06-11 12:36:23 +00:00
parent 182612a847
commit 00fffaadd1
4 changed files with 52 additions and 20 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.6 2006/02/05 23:10:29 joerg Exp $
# $NetBSD: Makefile,v 1.7 2007/06/11 12:36:23 tron Exp $
DISTNAME= ppp-${PPPD_VERSION}
PKGNAME= ${DISTNAME:S/ppp/&d/}
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= net
MASTER_SITES= ftp://ftp.samba.org/pub/ppp/

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.4 2005/02/24 12:14:01 agc Exp $
$NetBSD: distinfo,v 1.5 2007/06/11 12:36:23 tron Exp $
SHA1 (ppp-2.4.3.tar.gz) = 5e2789f4dedc81943fa9f94c840cccc2407056f7
RMD160 (ppp-2.4.3.tar.gz) = 845821496bacb07d93bb7572a171854853ef722b
@ -6,7 +6,7 @@ Size (ppp-2.4.3.tar.gz) = 688092 bytes
SHA1 (patch-aa) = 8814f0f389971d07368bef95fbadbb5d7562d0a9
SHA1 (patch-ab) = 1cd0d99dac316b1c5a48c9a41104c2c25e9bb920
SHA1 (patch-ac) = 9bc88cfcd7b1a09e92aaa919f35e39afb3b45803
SHA1 (patch-ad) = c196817c32c9b8c8d367d5cb54c4c792d53b78f8
SHA1 (patch-ad) = a3140bc6cfa9fe8d4548b118e9918308f7673e24
SHA1 (patch-ae) = 3cb3f64ad7c209a8283a92c50bdb4071c6f8ad38
SHA1 (patch-af) = 178a2a2a716d6ff8e9bd0cc36ff72d8a138f6989
SHA1 (patch-ag) = f989f71dbb164e53157ba2677f29737862e137f2
@ -44,3 +44,4 @@ SHA1 (patch-bl) = 31525cf95919a534804c95121f7e69289c4220cb
SHA1 (patch-bm) = 27743760f1a5c385b5b17c0568e0736d5c3b08bb
SHA1 (patch-bn) = 2527e7f82874ad3ffaa2585bb7939fbd62ee291a
SHA1 (patch-bo) = 58edaa6a2a9d542da32f2fab678a01132235a9e0
SHA1 (patch-bp) = 34b533ae19a9006f5d09fdbe299ac30e693c20d0

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ad,v 1.1.1.1 2005/01/02 02:51:41 cube Exp $
$NetBSD: patch-ad,v 1.2 2007/06/11 12:36:24 tron Exp $
--- chat/chat.c.orig 2004-02-02 04:36:46.000000000 +0100
+++ chat/chat.c
@@ -147,20 +147,9 @@ extern char *sys_errlist[];
--- chat/chat.c.orig 2004-02-02 03:36:46.000000000 +0000
+++ chat/chat.c 2007-06-11 13:07:08.000000000 +0100
@@ -147,20 +147,9 @@
"unknown error")
#endif
@ -24,7 +24,7 @@ $NetBSD: patch-ad,v 1.1.1.1 2005/01/02 02:51:41 cube Exp $
#define MAX_ABORTS 50
#define MAX_REPORTS 50
#define DEFAULT_CHAT_TIMEOUT 45
@@ -198,12 +187,12 @@ struct termios saved_tty_parameters;
@@ -198,12 +187,12 @@
#endif
char *abort_string[MAX_ABORTS], *fail_reason = (char *)0,
@ -39,7 +39,7 @@ $NetBSD: patch-ad,v 1.1.1.1 2005/01/02 02:51:41 cube Exp $
int n_reports = 0, report_next = 0, report_gathering = 0 ;
int clear_report_next = 0;
@@ -289,12 +278,12 @@ main(argc, argv)
@@ -289,12 +278,12 @@
char **argv;
{
int option;
@ -54,7 +54,7 @@ $NetBSD: patch-ad,v 1.1.1.1 2005/01/02 02:51:41 cube Exp $
switch (option) {
case 'e':
++echo;
@@ -321,25 +310,24 @@ main(argc, argv)
@@ -321,25 +310,24 @@
break;
case 'f':
@ -86,7 +86,7 @@ $NetBSD: patch-ad,v 1.1.1.1 2005/01/02 02:51:41 cube Exp $
report_fp = fopen (report_file, "a");
if (report_fp != NULL) {
if (verbose)
@@ -351,15 +339,15 @@ main(argc, argv)
@@ -351,15 +339,15 @@
break;
case 'T':
@ -106,7 +106,7 @@ $NetBSD: patch-ad,v 1.1.1.1 2005/01/02 02:51:41 cube Exp $
else
usage();
break;
@@ -369,6 +357,8 @@ main(argc, argv)
@@ -369,6 +357,8 @@
break;
}
}
@ -115,7 +115,7 @@ $NetBSD: patch-ad,v 1.1.1.1 2005/01/02 02:51:41 cube Exp $
/*
* Default the report file to the stderr location
*/
@@ -391,17 +381,15 @@ main(argc, argv)
@@ -391,17 +381,15 @@
init();
if (chat_file != NULL) {
@ -138,7 +138,7 @@ $NetBSD: patch-ad,v 1.1.1.1 2005/01/02 02:51:41 cube Exp $
}
}
@@ -508,6 +496,7 @@ void msgf __V((const char *fmt, ...))
@@ -508,6 +496,7 @@
#endif
vfmtmsg(line, sizeof(line), fmt, args);
@ -146,7 +146,7 @@ $NetBSD: patch-ad,v 1.1.1.1 2005/01/02 02:51:41 cube Exp $
if (to_log)
syslog(LOG_INFO, "%s", line);
if (to_stderr)
@@ -533,6 +522,7 @@ void fatal __V((int code, const char *fm
@@ -533,6 +522,7 @@
#endif
vfmtmsg(line, sizeof(line), fmt, args);
@ -154,7 +154,7 @@ $NetBSD: patch-ad,v 1.1.1.1 2005/01/02 02:51:41 cube Exp $
if (to_log)
syslog(LOG_ERR, "%s", line);
if (to_stderr)
@@ -614,7 +604,7 @@ void set_tty_parameters()
@@ -614,7 +604,7 @@
have_tty_parameters = 1;
t.c_iflag |= IGNBRK | ISTRIP | IGNPAR;
@ -163,7 +163,7 @@ $NetBSD: patch-ad,v 1.1.1.1 2005/01/02 02:51:41 cube Exp $
t.c_lflag = 0;
t.c_cc[VERASE] =
t.c_cc[VKILL] = 0;
@@ -1022,11 +1012,11 @@ int c;
@@ -1022,11 +1012,11 @@
c &= 0x7F;
if (c < 32)
@ -178,7 +178,16 @@ $NetBSD: patch-ad,v 1.1.1.1 2005/01/02 02:51:41 cube Exp $
return (string);
}
@@ -1445,7 +1435,14 @@ register char *string;
@@ -1303,7 +1293,7 @@
if (verbose) {
if (quiet)
- msgf("send (??????)");
+ msgf("send (\?\?\?\?\?\?)");
else
msgf("send (%v)", s);
}
@@ -1445,7 +1435,14 @@
struct tm* tm_now = localtime (&time_now);
strftime (report_buffer, 20, "%b %d %H:%M:%S ", tm_now);
@ -194,7 +203,7 @@ $NetBSD: patch-ad,v 1.1.1.1 2005/01/02 02:51:41 cube Exp $
report_string[n] = (char *) NULL;
report_gathering = 1;
@@ -1491,7 +1488,13 @@ register char *string;
@@ -1491,7 +1488,13 @@
alarm(0);
alarmed = 0;
exit_code = n + 4;

22
net/pppd/patches/patch-bp Normal file
View file

@ -0,0 +1,22 @@
$NetBSD: patch-bp,v 1.1 2007/06/11 12:36:24 tron Exp $
--- pppd/chap_ms.h.orig 2004-11-09 22:49:05.000000000 +0000
+++ pppd/chap_ms.h 2007-06-11 13:11:59.000000000 +0100
@@ -67,7 +67,7 @@
u_char LANManResp[24];
u_char NTResp[24];
u_char UseNT[1]; /* If 1, ignore the LANMan response field */
-} MS_ChapResponse PACKED;
+} PACKED MS_ChapResponse;
/*
* Use MS_CHAP2_RESPONSE_LEN, rather than sizeof(MS_Chap2Response),
@@ -78,7 +78,7 @@
u_char Reserved[8]; /* Must be zero */
u_char NTResp[24];
u_char Flags[1]; /* Must be zero */
-} MS_Chap2Response PACKED;
+} PACKED MS_Chap2Response;
#ifdef MPPE
#include <net/ppp-comp.h> /* MPPE_MAX_KEY_LEN */