Update to 0.3.0.
Header location and library names changed, so bump API version. No users in pkgsrc (yet). Changes in GEGL 0.3.0 --------------------- • Improvements to thread safety and parallelism. • Lower overhead graph travesal due from rewrite of visitors • OpenCL support now enabled by default when detected. • Experimental multithreading, enable by setting GEGL_THREADS=<number of threads> in the environment. • Experimental mipmap rendering, which permits transparent rendering of previews on smaller sized versions, enable by setting GEGL_MIPMAP_RENDERING=true in the environment. • Operations: • new operations: alien-map, antialias, apply-lens, bilateral-filter, bump.map, cartoon, channel-mixer, color-enhance, color-exchange, color-reduction, color-rotate, convolution-matrix, copy-buffer, cubism, deinterlace, diffraction-patterns, distance-transform, displace, edge, emboss, engrave, exposure, fractal-trace, high-pass, image-compare, illusion, invert-gamma, lens-flare, linear, linear-gradient, mosaic, motion-blur-circular, motion-blur-zoom, noise-cell noise-cie-lch, noise-hsv, noise-hurl, noise-pick, noise-rgb, noise-simplex, noise-spread, n-point deformation ops, oilify, panorama-projection, photocopy, plasma, radial-gradient, red-eye-removal, scale-size-keep-aspect, softglow, stretch-contrast, texturize-canvas, tile-glass, tile-seamless, tile-paper, tile, warp, whirl-pinch, wind, cache, cast-format, lcms-from-profile, npy-save, webp-load, webp-save, scale-ratio, scale-size, seamless-clone, sinus, supernova, value-propagate, video-degradation • reimplementation of gaussian-blur faster and more accurate • support for using URIs in image loaders • Buffer: • New default tile backend, doing disk writes in a separate thread.
This commit is contained in:
parent
7aff97a169
commit
011f099a64
5 changed files with 312 additions and 292 deletions
|
@ -1,9 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.54 2015/04/25 14:23:10 tnn Exp $
|
||||
# $NetBSD: Makefile,v 1.55 2015/08/25 13:25:54 wiz Exp $
|
||||
|
||||
DISTNAME= gegl-0.2.0
|
||||
PKGREVISION= 19
|
||||
DISTNAME= gegl-0.3.0
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= #
|
||||
MASTER_SITES= http://download.gimp.org/pub/gegl/0.3/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= adam@NetBSD.org
|
||||
|
@ -35,12 +34,13 @@ CFLAGS.SunOS+= -std=c99
|
|||
|
||||
.include "options.mk"
|
||||
|
||||
BUILDLINK_API_DEPENDS.babl+= babl>=0.1.4
|
||||
BUILDLINK_API_DEPENDS.babl+= babl>=0.1.12
|
||||
.include "../../graphics/babl/buildlink3.mk"
|
||||
.include "../../mk/jpeg.buildlink3.mk"
|
||||
.include "../../graphics/jasper/buildlink3.mk"
|
||||
.include "../../graphics/openexr/buildlink3.mk"
|
||||
.include "../../graphics/png/buildlink3.mk"
|
||||
.include "../../textproc/json-glib/buildlink3.mk"
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../mk/dlopen.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,172 +1,301 @@
|
|||
@comment $NetBSD: PLIST,v 1.15 2012/05/07 08:35:57 adam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.16 2015/08/25 13:25:54 wiz Exp $
|
||||
bin/2geglbuffer
|
||||
bin/gegl
|
||||
include/gegl-0.2/gegl-buffer-backend.h
|
||||
include/gegl-0.2/gegl-buffer-iterator.h
|
||||
include/gegl-0.2/gegl-buffer.h
|
||||
include/gegl-0.2/gegl-chant.h
|
||||
include/gegl-0.2/gegl-color.h
|
||||
include/gegl-0.2/gegl-curve.h
|
||||
include/gegl-0.2/gegl-enums.h
|
||||
include/gegl-0.2/gegl-lookup.h
|
||||
include/gegl-0.2/gegl-matrix.h
|
||||
include/gegl-0.2/gegl-paramspecs.h
|
||||
include/gegl-0.2/gegl-path.h
|
||||
include/gegl-0.2/gegl-plugin.h
|
||||
include/gegl-0.2/gegl-tile-backend.h
|
||||
include/gegl-0.2/gegl-tile-source.h
|
||||
include/gegl-0.2/gegl-tile.h
|
||||
include/gegl-0.2/gegl-types.h
|
||||
include/gegl-0.2/gegl-utils.h
|
||||
include/gegl-0.2/gegl-version.h
|
||||
include/gegl-0.2/gegl.h
|
||||
include/gegl-0.2/opencl/cl.h
|
||||
include/gegl-0.2/opencl/cl_d3d10.h
|
||||
include/gegl-0.2/opencl/cl_ext.h
|
||||
include/gegl-0.2/opencl/cl_gl.h
|
||||
include/gegl-0.2/opencl/cl_gl_ext.h
|
||||
include/gegl-0.2/opencl/cl_platform.h
|
||||
include/gegl-0.2/opencl/gegl-cl-color.h
|
||||
include/gegl-0.2/opencl/gegl-cl-init.h
|
||||
include/gegl-0.2/opencl/gegl-cl-types.h
|
||||
include/gegl-0.2/opencl/gegl-cl.h
|
||||
include/gegl-0.2/opencl/opencl.h
|
||||
include/gegl-0.2/operation/gegl-operation-area-filter.h
|
||||
include/gegl-0.2/operation/gegl-operation-composer.h
|
||||
include/gegl-0.2/operation/gegl-operation-composer3.h
|
||||
include/gegl-0.2/operation/gegl-operation-filter.h
|
||||
include/gegl-0.2/operation/gegl-operation-meta.h
|
||||
include/gegl-0.2/operation/gegl-operation-point-composer.h
|
||||
include/gegl-0.2/operation/gegl-operation-point-composer3.h
|
||||
include/gegl-0.2/operation/gegl-operation-point-filter.h
|
||||
include/gegl-0.2/operation/gegl-operation-point-render.h
|
||||
include/gegl-0.2/operation/gegl-operation-sink.h
|
||||
include/gegl-0.2/operation/gegl-operation-source.h
|
||||
include/gegl-0.2/operation/gegl-operation-temporal.h
|
||||
include/gegl-0.2/operation/gegl-operation.h
|
||||
lib/gegl-0.2/add.la
|
||||
lib/gegl-0.2/bilateral-filter.la
|
||||
lib/gegl-0.2/box-blur.la
|
||||
lib/gegl-0.2/brightness-contrast.la
|
||||
lib/gegl-0.2/buffer-sink.la
|
||||
lib/gegl-0.2/buffer-source.la
|
||||
lib/gegl-0.2/c2g.la
|
||||
lib/gegl-0.2/checkerboard.la
|
||||
lib/gegl-0.2/clear.la
|
||||
lib/gegl-0.2/clone.la
|
||||
lib/gegl-0.2/color-burn.la
|
||||
lib/gegl-0.2/color-dodge.la
|
||||
lib/gegl-0.2/color-temperature.la
|
||||
lib/gegl-0.2/color-to-alpha.la
|
||||
lib/gegl-0.2/color.la
|
||||
lib/gegl-0.2/contrast-curve.la
|
||||
lib/gegl-0.2/convert-format.la
|
||||
lib/gegl-0.2/crop.la
|
||||
lib/gegl-0.2/darken.la
|
||||
lib/gegl-0.2/difference-of-gaussians.la
|
||||
lib/gegl-0.2/difference.la
|
||||
lib/gegl-0.2/display.la
|
||||
lib/gegl-0.2/divide.la
|
||||
lib/gegl-0.2/dropshadow.la
|
||||
lib/gegl-0.2/dst-atop.la
|
||||
lib/gegl-0.2/dst-in.la
|
||||
lib/gegl-0.2/dst-out.la
|
||||
lib/gegl-0.2/dst-over.la
|
||||
lib/gegl-0.2/dst.la
|
||||
lib/gegl-0.2/edge-laplace.la
|
||||
lib/gegl-0.2/edge-sobel.la
|
||||
lib/gegl-0.2/exclusion.la
|
||||
lib/gegl-0.2/exp-combine.la
|
||||
lib/gegl-0.2/exr-load.la
|
||||
lib/gegl-0.2/exr-save.la
|
||||
lib/gegl-0.2/fattal02.la
|
||||
lib/gegl-0.2/fractal-explorer.la
|
||||
lib/gegl-0.2/gamma.la
|
||||
lib/gegl-0.2/gaussian-blur.la
|
||||
lib/gegl-0.2/gegl-buffer-load-op.la
|
||||
lib/gegl-0.2/gegl-buffer-save-op.la
|
||||
lib/gegl-0.2/grey.la
|
||||
lib/gegl-0.2/grid.la
|
||||
lib/gegl-0.2/hard-light.la
|
||||
lib/gegl-0.2/introspect.la
|
||||
lib/gegl-0.2/invert.la
|
||||
lib/gegl-0.2/jp2-load.la
|
||||
lib/gegl-0.2/jpg-load.la
|
||||
lib/gegl-0.2/jpg-save.la
|
||||
lib/gegl-0.2/layer.la
|
||||
lib/gegl-0.2/lens-distortion.la
|
||||
lib/gegl-0.2/levels.la
|
||||
lib/gegl-0.2/lighten.la
|
||||
lib/gegl-0.2/load.la
|
||||
lib/gegl-0.2/magick-load.la
|
||||
lib/gegl-0.2/mantiuk06.la
|
||||
lib/gegl-0.2/map-absolute.la
|
||||
lib/gegl-0.2/map-relative.la
|
||||
lib/gegl-0.2/matting-global.la
|
||||
lib/gegl-0.2/mblur.la
|
||||
lib/gegl-0.2/mirrors.la
|
||||
lib/gegl-0.2/mono-mixer.la
|
||||
lib/gegl-0.2/motion-blur.la
|
||||
lib/gegl-0.2/multiply.la
|
||||
lib/gegl-0.2/noise-reduction.la
|
||||
lib/gegl-0.2/noise.la
|
||||
lib/gegl-0.2/nop.la
|
||||
lib/gegl-0.2/opacity.la
|
||||
lib/gegl-0.2/open-buffer.la
|
||||
lib/gegl-0.2/over.la
|
||||
lib/gegl-0.2/overlay.la
|
||||
lib/gegl-0.2/path.la
|
||||
lib/gegl-0.2/pixbuf.la
|
||||
lib/gegl-0.2/pixelize.la
|
||||
lib/gegl-0.2/plus.la
|
||||
lib/gegl-0.2/png-load.la
|
||||
lib/gegl-0.2/png-save.la
|
||||
lib/gegl-0.2/polar-coordinates.la
|
||||
lib/gegl-0.2/posterize.la
|
||||
lib/gegl-0.2/ppm-load.la
|
||||
lib/gegl-0.2/ppm-save.la
|
||||
lib/gegl-0.2/raw-load.la
|
||||
lib/gegl-0.2/rectangle.la
|
||||
lib/gegl-0.2/reinhard05.la
|
||||
lib/gegl-0.2/remap.la
|
||||
lib/gegl-0.2/rgbe-load.la
|
||||
lib/gegl-0.2/rgbe-save.la
|
||||
lib/gegl-0.2/ripple.la
|
||||
lib/gegl-0.2/save-pixbuf.la
|
||||
lib/gegl-0.2/save.la
|
||||
lib/gegl-0.2/screen.la
|
||||
lib/gegl-0.2/snn-mean.la
|
||||
lib/gegl-0.2/soft-light.la
|
||||
lib/gegl-0.2/src-atop.la
|
||||
lib/gegl-0.2/src-in.la
|
||||
lib/gegl-0.2/src-out.la
|
||||
lib/gegl-0.2/src-over.la
|
||||
lib/gegl-0.2/src.la
|
||||
lib/gegl-0.2/stress.la
|
||||
lib/gegl-0.2/stretch-contrast.la
|
||||
lib/gegl-0.2/subtract.la
|
||||
lib/gegl-0.2/svg-huerotate.la
|
||||
${PLIST.svg}lib/gegl-0.2/svg-load.la
|
||||
lib/gegl-0.2/svg-luminancetoalpha.la
|
||||
lib/gegl-0.2/svg-matrix.la
|
||||
lib/gegl-0.2/svg-multiply.la
|
||||
lib/gegl-0.2/svg-saturate.la
|
||||
lib/gegl-0.2/text.la
|
||||
lib/gegl-0.2/threshold.la
|
||||
lib/gegl-0.2/transformops.la
|
||||
lib/gegl-0.2/unsharp-mask.la
|
||||
${PLIST.v4l}lib/gegl-0.2/v4l.la
|
||||
lib/gegl-0.2/value-invert.la
|
||||
lib/gegl-0.2/vector-fill.la
|
||||
lib/gegl-0.2/vector-stroke.la
|
||||
lib/gegl-0.2/vignette.la
|
||||
lib/gegl-0.2/waves.la
|
||||
lib/gegl-0.2/weighted-blend.la
|
||||
lib/gegl-0.2/write-buffer.la
|
||||
lib/gegl-0.2/xor.la
|
||||
lib/libgegl-0.2.la
|
||||
lib/pkgconfig/gegl-0.2.pc
|
||||
share/locale/es/LC_MESSAGES/gegl-0.2.mo
|
||||
share/locale/fr/LC_MESSAGES/gegl-0.2.mo
|
||||
share/locale/pl/LC_MESSAGES/gegl-0.2.mo
|
||||
share/locale/ru/LC_MESSAGES/gegl-0.2.mo
|
||||
share/locale/sl/LC_MESSAGES/gegl-0.2.mo
|
||||
bin/gegl-convert
|
||||
bin/gegl-imgcmp
|
||||
bin/gegl-slicer
|
||||
bin/gegl-tester
|
||||
bin/geglbuffer-add-image
|
||||
bin/geglbuffer-clock
|
||||
bin/hello-world
|
||||
include/gegl-0.3/gegl-apply.h
|
||||
include/gegl-0.3/gegl-buffer-backend.h
|
||||
include/gegl-0.3/gegl-buffer-cl-iterator.h
|
||||
include/gegl-0.3/gegl-buffer-iterator.h
|
||||
include/gegl-0.3/gegl-buffer.h
|
||||
include/gegl-0.3/gegl-c.h
|
||||
include/gegl-0.3/gegl-chant.h
|
||||
include/gegl-0.3/gegl-color.h
|
||||
include/gegl-0.3/gegl-cpuaccel.h
|
||||
include/gegl-0.3/gegl-curve.h
|
||||
include/gegl-0.3/gegl-enums.h
|
||||
include/gegl-0.3/gegl-graph-debug.h
|
||||
include/gegl-0.3/gegl-init.h
|
||||
include/gegl-0.3/gegl-lookup.h
|
||||
include/gegl-0.3/gegl-matrix.h
|
||||
include/gegl-0.3/gegl-node.h
|
||||
include/gegl-0.3/gegl-op.h
|
||||
include/gegl-0.3/gegl-operations-util.h
|
||||
include/gegl-0.3/gegl-paramspecs.h
|
||||
include/gegl-0.3/gegl-path.h
|
||||
include/gegl-0.3/gegl-plugin.h
|
||||
include/gegl-0.3/gegl-processor.h
|
||||
include/gegl-0.3/gegl-random.h
|
||||
include/gegl-0.3/gegl-tile-backend.h
|
||||
include/gegl-0.3/gegl-tile-handler.h
|
||||
include/gegl-0.3/gegl-tile-source.h
|
||||
include/gegl-0.3/gegl-tile.h
|
||||
include/gegl-0.3/gegl-types.h
|
||||
include/gegl-0.3/gegl-utils.h
|
||||
include/gegl-0.3/gegl-version.h
|
||||
include/gegl-0.3/gegl.h
|
||||
include/gegl-0.3/npd/deformation.h
|
||||
include/gegl-0.3/npd/graphics.h
|
||||
include/gegl-0.3/npd/lattice_cut.h
|
||||
include/gegl-0.3/npd/npd.h
|
||||
include/gegl-0.3/npd/npd_common.h
|
||||
include/gegl-0.3/npd/npd_debug.h
|
||||
include/gegl-0.3/npd/npd_gegl.h
|
||||
include/gegl-0.3/npd/npd_math.h
|
||||
include/gegl-0.3/opencl/cl.h
|
||||
include/gegl-0.3/opencl/cl_d3d10.h
|
||||
include/gegl-0.3/opencl/cl_ext.h
|
||||
include/gegl-0.3/opencl/cl_gl.h
|
||||
include/gegl-0.3/opencl/cl_gl_ext.h
|
||||
include/gegl-0.3/opencl/cl_platform.h
|
||||
include/gegl-0.3/opencl/gegl-cl-color.h
|
||||
include/gegl-0.3/opencl/gegl-cl-init.h
|
||||
include/gegl-0.3/opencl/gegl-cl-random.h
|
||||
include/gegl-0.3/opencl/gegl-cl-types.h
|
||||
include/gegl-0.3/opencl/gegl-cl.h
|
||||
include/gegl-0.3/opencl/opencl.h
|
||||
include/gegl-0.3/operation/gegl-extension-handler.h
|
||||
include/gegl-0.3/operation/gegl-operation-area-filter.h
|
||||
include/gegl-0.3/operation/gegl-operation-composer.h
|
||||
include/gegl-0.3/operation/gegl-operation-composer3.h
|
||||
include/gegl-0.3/operation/gegl-operation-context.h
|
||||
include/gegl-0.3/operation/gegl-operation-filter.h
|
||||
include/gegl-0.3/operation/gegl-operation-meta-json.h
|
||||
include/gegl-0.3/operation/gegl-operation-meta.h
|
||||
include/gegl-0.3/operation/gegl-operation-point-composer.h
|
||||
include/gegl-0.3/operation/gegl-operation-point-composer3.h
|
||||
include/gegl-0.3/operation/gegl-operation-point-filter.h
|
||||
include/gegl-0.3/operation/gegl-operation-point-render.h
|
||||
include/gegl-0.3/operation/gegl-operation-property-keys.h
|
||||
include/gegl-0.3/operation/gegl-operation-sink.h
|
||||
include/gegl-0.3/operation/gegl-operation-source.h
|
||||
include/gegl-0.3/operation/gegl-operation-temporal.h
|
||||
include/gegl-0.3/operation/gegl-operation.h
|
||||
include/gegl-0.3/sc/sc-common.h
|
||||
include/gegl-0.3/sc/sc-context.h
|
||||
include/gegl-0.3/sc/sc-outline.h
|
||||
include/gegl-0.3/sc/sc-sample.h
|
||||
lib/gegl-0.3/add.la
|
||||
lib/gegl-0.3/alien-map.la
|
||||
lib/gegl-0.3/antialias.la
|
||||
lib/gegl-0.3/apply-lens.la
|
||||
lib/gegl-0.3/bilateral-filter-fast.la
|
||||
lib/gegl-0.3/bilateral-filter.la
|
||||
lib/gegl-0.3/box-blur.la
|
||||
lib/gegl-0.3/brightness-contrast.la
|
||||
lib/gegl-0.3/buffer-sink.la
|
||||
lib/gegl-0.3/buffer-source.la
|
||||
lib/gegl-0.3/bump-map.la
|
||||
lib/gegl-0.3/c2g.la
|
||||
lib/gegl-0.3/cache.la
|
||||
lib/gegl-0.3/cartoon.la
|
||||
lib/gegl-0.3/cast-format.la
|
||||
lib/gegl-0.3/channel-mixer.la
|
||||
lib/gegl-0.3/checkerboard.la
|
||||
lib/gegl-0.3/clear.la
|
||||
lib/gegl-0.3/clone.la
|
||||
lib/gegl-0.3/color-burn.la
|
||||
lib/gegl-0.3/color-dodge.la
|
||||
lib/gegl-0.3/color-enhance.la
|
||||
lib/gegl-0.3/color-exchange.la
|
||||
lib/gegl-0.3/color-reduction.la
|
||||
lib/gegl-0.3/color-rotate.la
|
||||
lib/gegl-0.3/color-temperature.la
|
||||
lib/gegl-0.3/color-to-alpha.la
|
||||
lib/gegl-0.3/color.la
|
||||
lib/gegl-0.3/contrast-curve.la
|
||||
lib/gegl-0.3/convert-format.la
|
||||
lib/gegl-0.3/convolution-matrix.la
|
||||
lib/gegl-0.3/copy-buffer.la
|
||||
lib/gegl-0.3/crop.la
|
||||
lib/gegl-0.3/cubism.la
|
||||
lib/gegl-0.3/darken.la
|
||||
lib/gegl-0.3/deinterlace.la
|
||||
lib/gegl-0.3/difference-of-gaussians.la
|
||||
lib/gegl-0.3/difference.la
|
||||
lib/gegl-0.3/diffraction-patterns.la
|
||||
lib/gegl-0.3/displace.la
|
||||
lib/gegl-0.3/display.la
|
||||
lib/gegl-0.3/distance-transform.la
|
||||
lib/gegl-0.3/divide.la
|
||||
lib/gegl-0.3/dropshadow.la
|
||||
lib/gegl-0.3/dst-atop.la
|
||||
lib/gegl-0.3/dst-in.la
|
||||
lib/gegl-0.3/dst-out.la
|
||||
lib/gegl-0.3/dst-over.la
|
||||
lib/gegl-0.3/dst.la
|
||||
lib/gegl-0.3/edge-laplace.la
|
||||
lib/gegl-0.3/edge-sobel.la
|
||||
lib/gegl-0.3/edge.la
|
||||
lib/gegl-0.3/emboss.la
|
||||
lib/gegl-0.3/engrave.la
|
||||
lib/gegl-0.3/exclusion.la
|
||||
lib/gegl-0.3/exp-combine.la
|
||||
lib/gegl-0.3/exposure.la
|
||||
lib/gegl-0.3/exr-load.la
|
||||
lib/gegl-0.3/exr-save.la
|
||||
lib/gegl-0.3/fattal02.la
|
||||
lib/gegl-0.3/fractal-explorer.la
|
||||
lib/gegl-0.3/fractal-trace.la
|
||||
lib/gegl-0.3/gamma.la
|
||||
lib/gegl-0.3/gaussian-blur-iir.la
|
||||
lib/gegl-0.3/gaussian-blur.la
|
||||
lib/gegl-0.3/gblur-1d.la
|
||||
lib/gegl-0.3/gegl-buffer-load-op.la
|
||||
lib/gegl-0.3/gegl-buffer-save-op.la
|
||||
lib/gegl-0.3/grey.la
|
||||
lib/gegl-0.3/grey2.json
|
||||
lib/gegl-0.3/grid.la
|
||||
lib/gegl-0.3/hard-light.la
|
||||
lib/gegl-0.3/high-pass.la
|
||||
lib/gegl-0.3/illusion.la
|
||||
lib/gegl-0.3/image-compare.la
|
||||
lib/gegl-0.3/introspect.la
|
||||
lib/gegl-0.3/invert-gamma.la
|
||||
lib/gegl-0.3/invert-linear.la
|
||||
lib/gegl-0.3/jp2-load.la
|
||||
lib/gegl-0.3/jpg-load.la
|
||||
lib/gegl-0.3/jpg-save.la
|
||||
lib/gegl-0.3/json.la
|
||||
lib/gegl-0.3/layer.la
|
||||
lib/gegl-0.3/lens-distortion.la
|
||||
lib/gegl-0.3/lens-flare.la
|
||||
lib/gegl-0.3/levels.la
|
||||
lib/gegl-0.3/lighten.la
|
||||
lib/gegl-0.3/linear-gradient.la
|
||||
lib/gegl-0.3/load.la
|
||||
lib/gegl-0.3/magick-load.la
|
||||
lib/gegl-0.3/mantiuk06.la
|
||||
lib/gegl-0.3/map-absolute.la
|
||||
lib/gegl-0.3/map-relative.la
|
||||
lib/gegl-0.3/matting-global.la
|
||||
lib/gegl-0.3/mblur.la
|
||||
lib/gegl-0.3/mirrors.la
|
||||
lib/gegl-0.3/mono-mixer.la
|
||||
lib/gegl-0.3/mosaic.la
|
||||
lib/gegl-0.3/motion-blur-circular.la
|
||||
lib/gegl-0.3/motion-blur-linear.la
|
||||
lib/gegl-0.3/motion-blur-zoom.la
|
||||
lib/gegl-0.3/multiply.la
|
||||
lib/gegl-0.3/noise-cell.la
|
||||
lib/gegl-0.3/noise-cie-lch.la
|
||||
lib/gegl-0.3/noise-hsv.la
|
||||
lib/gegl-0.3/noise-hurl.la
|
||||
lib/gegl-0.3/noise-perlin.la
|
||||
lib/gegl-0.3/noise-pick.la
|
||||
lib/gegl-0.3/noise-reduction.la
|
||||
lib/gegl-0.3/noise-rgb.la
|
||||
lib/gegl-0.3/noise-simplex.la
|
||||
lib/gegl-0.3/noise-slur.la
|
||||
lib/gegl-0.3/noise-solid.la
|
||||
lib/gegl-0.3/noise-spread.la
|
||||
lib/gegl-0.3/nop.la
|
||||
lib/gegl-0.3/npd.la
|
||||
lib/gegl-0.3/npy-save.la
|
||||
lib/gegl-0.3/oilify.la
|
||||
lib/gegl-0.3/opacity.la
|
||||
lib/gegl-0.3/open-buffer.la
|
||||
lib/gegl-0.3/over.la
|
||||
lib/gegl-0.3/overlay.la
|
||||
lib/gegl-0.3/panorama-projection.la
|
||||
lib/gegl-0.3/path.la
|
||||
lib/gegl-0.3/photocopy.la
|
||||
lib/gegl-0.3/pixbuf.la
|
||||
lib/gegl-0.3/pixelize.la
|
||||
lib/gegl-0.3/plasma.la
|
||||
lib/gegl-0.3/plus.la
|
||||
lib/gegl-0.3/png-load.la
|
||||
lib/gegl-0.3/png-save.la
|
||||
lib/gegl-0.3/polar-coordinates.la
|
||||
lib/gegl-0.3/posterize.la
|
||||
lib/gegl-0.3/ppm-load.la
|
||||
lib/gegl-0.3/ppm-save.la
|
||||
lib/gegl-0.3/radial-gradient.la
|
||||
lib/gegl-0.3/raw-load.la
|
||||
lib/gegl-0.3/rectangle.la
|
||||
lib/gegl-0.3/red-eye-removal.la
|
||||
lib/gegl-0.3/reinhard05.la
|
||||
lib/gegl-0.3/remap.la
|
||||
lib/gegl-0.3/rgbe-load.la
|
||||
lib/gegl-0.3/rgbe-save.la
|
||||
lib/gegl-0.3/ripple.la
|
||||
lib/gegl-0.3/save-pixbuf.la
|
||||
lib/gegl-0.3/save.la
|
||||
lib/gegl-0.3/screen.la
|
||||
lib/gegl-0.3/seamless-clone-compose.la
|
||||
lib/gegl-0.3/seamless-clone.la
|
||||
lib/gegl-0.3/shift.la
|
||||
lib/gegl-0.3/sinus.la
|
||||
lib/gegl-0.3/snn-mean.la
|
||||
lib/gegl-0.3/soft-light.la
|
||||
lib/gegl-0.3/softglow.la
|
||||
lib/gegl-0.3/src-atop.la
|
||||
lib/gegl-0.3/src-in.la
|
||||
lib/gegl-0.3/src-out.la
|
||||
lib/gegl-0.3/src.la
|
||||
lib/gegl-0.3/stress.la
|
||||
lib/gegl-0.3/stretch-contrast-hsv.la
|
||||
lib/gegl-0.3/stretch-contrast.la
|
||||
lib/gegl-0.3/subtract.la
|
||||
lib/gegl-0.3/supernova.la
|
||||
lib/gegl-0.3/svg-huerotate.la
|
||||
${PLIST.svg}lib/gegl-0.3/svg-load.la
|
||||
lib/gegl-0.3/svg-luminancetoalpha.la
|
||||
lib/gegl-0.3/svg-matrix.la
|
||||
lib/gegl-0.3/svg-multiply.la
|
||||
lib/gegl-0.3/svg-saturate.la
|
||||
lib/gegl-0.3/text.la
|
||||
lib/gegl-0.3/texturize-canvas.la
|
||||
lib/gegl-0.3/threshold.la
|
||||
lib/gegl-0.3/tile-glass.la
|
||||
lib/gegl-0.3/tile-paper.la
|
||||
lib/gegl-0.3/tile-seamless.la
|
||||
lib/gegl-0.3/tile.la
|
||||
lib/gegl-0.3/transformops.la
|
||||
lib/gegl-0.3/unsharp-mask.la
|
||||
${PLIST.v4l}lib/gegl-0.3/v4l.la
|
||||
lib/gegl-0.3/value-invert.la
|
||||
lib/gegl-0.3/value-propagate.la
|
||||
lib/gegl-0.3/vector-fill.la
|
||||
lib/gegl-0.3/vector-stroke.la
|
||||
lib/gegl-0.3/video-degradation.la
|
||||
lib/gegl-0.3/vignette.la
|
||||
lib/gegl-0.3/warp.la
|
||||
lib/gegl-0.3/waves.la
|
||||
lib/gegl-0.3/weighted-blend.la
|
||||
lib/gegl-0.3/whirl-pinch.la
|
||||
lib/gegl-0.3/wind.la
|
||||
lib/gegl-0.3/write-buffer.la
|
||||
lib/gegl-0.3/xor.la
|
||||
lib/libgegl-0.3.la
|
||||
lib/libgegl-npd-0.3.la
|
||||
lib/libgegl-sc-0.3.la
|
||||
lib/pkgconfig/gegl-0.3.pc
|
||||
lib/pkgconfig/gegl-sc-0.3.pc
|
||||
share/locale/bs/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/ca/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/de/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/el/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/en_GB/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/eo/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/es/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/eu/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/fr/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/gl/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/id/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/it/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/ko/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/lv/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/oc/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/pl/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/ru/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/sl/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/sv/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/tr/LC_MESSAGES/gegl-0.3.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/gegl-0.3.mo
|
||||
|
|
|
@ -1,12 +1,11 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.30 2015/04/25 14:23:10 tnn Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.31 2015/08/25 13:25:54 wiz Exp $
|
||||
|
||||
BUILDLINK_TREE+= gegl
|
||||
|
||||
.if !defined(GEGL_BUILDLINK3_MK)
|
||||
GEGL_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.gegl+= gegl>=0.2.0
|
||||
BUILDLINK_ABI_DEPENDS.gegl+= gegl>=0.2.0nb19
|
||||
BUILDLINK_API_DEPENDS.gegl+= gegl>=0.3.0
|
||||
BUILDLINK_PKGSRCDIR.gegl?= ../../graphics/gegl
|
||||
|
||||
pkgbase := gegl
|
||||
|
@ -17,6 +16,7 @@ pkgbase := gegl
|
|||
.endif
|
||||
|
||||
.include "../../graphics/babl/buildlink3.mk"
|
||||
.include "../../textproc/json-glib/buildlink3.mk"
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.endif # GEGL_BUILDLINK3_MK
|
||||
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.13 2012/11/06 14:03:00 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.14 2015/08/25 13:25:54 wiz Exp $
|
||||
|
||||
SHA1 (gegl-0.2.0.tar.bz2) = 764cc66cb3c7b261b8fc18a6268a0e264a91d573
|
||||
RMD160 (gegl-0.2.0.tar.bz2) = cc10365cff27dd42b002bf305f82de54d8c158fa
|
||||
Size (gegl-0.2.0.tar.bz2) = 7502040 bytes
|
||||
SHA1 (patch-CVE-2012-4433) = 0dd9f9714f92a511469433dcde1195371fcce580
|
||||
SHA1 (gegl-0.3.0.tar.bz2) = d6b77996740bc885fd42f5c639c9d3fce6211855
|
||||
RMD160 (gegl-0.3.0.tar.bz2) = 128819e068e618c12f4765705d09b82f4a529754
|
||||
Size (gegl-0.3.0.tar.bz2) = 5463571 bytes
|
||||
SHA1 (patch-aa) = 0f46061f7b0c213abfe422124839eec29780d039
|
||||
|
|
|
@ -1,108 +0,0 @@
|
|||
$NetBSD: patch-CVE-2012-4433,v 1.1 2012/11/06 14:03:00 drochner Exp $
|
||||
|
||||
see https://bugzilla.redhat.com/show_bug.cgi?id=856300
|
||||
|
||||
--- operations/external/ppm-load.c.orig 2012-03-29 20:05:50.000000000 +0000
|
||||
+++ operations/external/ppm-load.c
|
||||
@@ -36,6 +36,7 @@ gegl_chant_file_path (path, _("File"), "
|
||||
#include "gegl-chant.h"
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
+#include <errno.h>
|
||||
|
||||
typedef enum {
|
||||
PIXMAP_ASCII = 51,
|
||||
@@ -44,8 +45,8 @@ typedef enum {
|
||||
|
||||
typedef struct {
|
||||
map_type type;
|
||||
- gint width;
|
||||
- gint height;
|
||||
+ glong width;
|
||||
+ glong height;
|
||||
gsize numsamples; /* width * height * channels */
|
||||
gsize bpc; /* bytes per channel */
|
||||
guchar *data;
|
||||
@@ -82,12 +83,33 @@ ppm_load_read_header(FILE *fp,
|
||||
}
|
||||
|
||||
/* Get Width and Height */
|
||||
- img->width = strtol (header,&ptr,0);
|
||||
- img->height = atoi (ptr);
|
||||
- img->numsamples = img->width * img->height * CHANNEL_COUNT;
|
||||
+ errno = 0;
|
||||
+ img->width = strtol (header,&ptr,10);
|
||||
+ if (errno)
|
||||
+ {
|
||||
+ g_warning ("Error reading width: %s", strerror(errno));
|
||||
+ return FALSE;
|
||||
+ }
|
||||
+ else if (img->width < 0)
|
||||
+ {
|
||||
+ g_warning ("Error: width is negative");
|
||||
+ return FALSE;
|
||||
+ }
|
||||
+
|
||||
+ img->height = strtol (ptr,&ptr,10);
|
||||
+ if (errno)
|
||||
+ {
|
||||
+ g_warning ("Error reading height: %s", strerror(errno));
|
||||
+ return FALSE;
|
||||
+ }
|
||||
+ else if (img->width < 0)
|
||||
+ {
|
||||
+ g_warning ("Error: height is negative");
|
||||
+ return FALSE;
|
||||
+ }
|
||||
|
||||
fgets (header,MAX_CHARS_IN_ROW,fp);
|
||||
- maxval = strtol (header,&ptr,0);
|
||||
+ maxval = strtol (header,&ptr,10);
|
||||
|
||||
if ((maxval != 255) && (maxval != 65535))
|
||||
{
|
||||
@@ -109,6 +131,16 @@ ppm_load_read_header(FILE *fp,
|
||||
g_warning ("%s: Programmer stupidity error", G_STRLOC);
|
||||
}
|
||||
|
||||
+ /* Later on, img->numsamples is multiplied with img->bpc to allocate
|
||||
+ * memory. Ensure it doesn't overflow. */
|
||||
+ if (!img->width || !img->height ||
|
||||
+ G_MAXSIZE / img->width / img->height / CHANNEL_COUNT < img->bpc)
|
||||
+ {
|
||||
+ g_warning ("Illegal width/height: %ld/%ld", img->width, img->height);
|
||||
+ return FALSE;
|
||||
+ }
|
||||
+ img->numsamples = img->width * img->height * CHANNEL_COUNT;
|
||||
+
|
||||
return TRUE;
|
||||
}
|
||||
|
||||
@@ -229,12 +261,24 @@ process (GeglOperation *operation,
|
||||
if (!ppm_load_read_header (fp, &img))
|
||||
goto out;
|
||||
|
||||
- rect.height = img.height;
|
||||
- rect.width = img.width;
|
||||
-
|
||||
/* Allocating Array Size */
|
||||
+
|
||||
+ /* Should use g_try_malloc(), but this causes crashes elsewhere because the
|
||||
+ * error signalled by returning FALSE isn't properly acted upon. Therefore
|
||||
+ * g_malloc() is used here which aborts if the requested memory size can't be
|
||||
+ * allocated causing a controlled crash. */
|
||||
img.data = (guchar*) g_malloc (img.numsamples * img.bpc);
|
||||
|
||||
+ /* No-op without g_try_malloc(), see above. */
|
||||
+ if (! img.data)
|
||||
+ {
|
||||
+ g_warning ("Couldn't allocate %" G_GSIZE_FORMAT " bytes, giving up.", ((gsize)img.numsamples * img.bpc));
|
||||
+ goto out;
|
||||
+ }
|
||||
+
|
||||
+ rect.height = img.height;
|
||||
+ rect.width = img.width;
|
||||
+
|
||||
switch (img.bpc)
|
||||
{
|
||||
case 1:
|
Loading…
Reference in a new issue