Fix for PR#47761
This commit is contained in:
parent
bbd8660201
commit
0123478772
2 changed files with 33 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.23 2013/04/13 11:10:03 obache Exp $
|
||||
$NetBSD: distinfo,v 1.24 2013/05/16 13:55:42 adam Exp $
|
||||
|
||||
SHA1 (pkg-config-0.28.tar.gz) = 71853779b12f958777bffcb8ca6d849b4d3bed46
|
||||
RMD160 (pkg-config-0.28.tar.gz) = 233f0b667cfb8f2e6a5647984d6389a770132173
|
||||
|
@ -11,6 +11,7 @@ SHA1 (patch-glib_glib_gcharset.c) = b191bc3ca806cff6fa54790fc225ddb35a158d55
|
|||
SHA1 (patch-glib_glib_gconvert.c) = 11a6c7cdd3a4473ff522bf7a0e7ad33653199970
|
||||
SHA1 (patch-glib_glib_gfileutils.c) = bc52e4435ad16a7e7f6780330d4b2b174a3a4411
|
||||
SHA1 (patch-glib_glib_glib.h) = 1c1baedb0f3266d948ded595b70b132821702963
|
||||
SHA1 (patch-glib_glib_gstrfuncs.c) = 1452222f3fc943e17b948817c0c2124708fdad75
|
||||
SHA1 (patch-glib_glib_gutf8.c) = 2ed8ea7b843e3d07392671201c8dfe1111e29065
|
||||
SHA1 (patch-glib_glib_gutils.c) = 60e16596d898324261fd6ae3ab1643beb8cb3ed3
|
||||
SHA1 (patch-glib_glib_gutils.h) = 9fdca0280fa7871c231b75fd6281c72dd621fac4
|
||||
|
|
31
devel/pkg-config/patches/patch-glib_glib_gstrfuncs.c
Normal file
31
devel/pkg-config/patches/patch-glib_glib_gstrfuncs.c
Normal file
|
@ -0,0 +1,31 @@
|
|||
$NetBSD: patch-glib_glib_gstrfuncs.c,v 1.1 2013/05/16 13:55:42 adam Exp $
|
||||
|
||||
Fix for missing function errors when newlocale() is not defined.
|
||||
|
||||
--- /tmp/pkgsrc/devel/pkg-config/work/pkg-config-0.28/glib/glib/gstrfuncs.c.orig 2013-05-16 13:04:54.000000000 +0000
|
||||
+++ /tmp/pkgsrc/devel/pkg-config/work/pkg-config-0.28/glib/glib/gstrfuncs.c
|
||||
@@ -317,22 +317,22 @@ static const guint16 ascii_table_data[25
|
||||
|
||||
const guint16 * const g_ascii_table = ascii_table_data;
|
||||
|
||||
-#ifdef HAVE_NEWLOCALE
|
||||
static locale_t
|
||||
get_C_locale (void)
|
||||
{
|
||||
static gsize initialized = FALSE;
|
||||
static locale_t C_locale = NULL;
|
||||
|
||||
+#ifdef HAVE_NEWLOCALE
|
||||
if (g_once_init_enter (&initialized))
|
||||
{
|
||||
C_locale = newlocale (LC_ALL_MASK, "C", NULL);
|
||||
g_once_init_leave (&initialized, TRUE);
|
||||
}
|
||||
+#endif
|
||||
|
||||
return C_locale;
|
||||
}
|
||||
-#endif
|
||||
|
||||
/**
|
||||
* g_strdup:
|
Loading…
Reference in a new issue