x11/xdotool: update to xdotool-3.20211022.1

v3.20211022.1

  * Fix #362 to have make create-package-deb work again. by @jordansissel in
    #363

v3.20210903.1

Allow running under XWayland

  * Revert XWayland detection. Some parts of xdotool do not work under
    XWayland. However,
    many features do work on XWayland, and rejecting XWayland caused problems
    for several
    folks who were otherwise happily using xdotool under Wayland/XWayland. (#
    346, #355)

v3.20210804.2

Fixes a packaging issue in the previous release.

v3.20210804.1

  * xdotool and libxdo will now reject if it is running under Wayland/
    XWayland.
    If XWayland is detected, the program will fail. This is because XWayland
    doesn't allow xdotool or libxdo to work correctly. (#342, Jordan Sissel)
  * New command windowstate which can be used to modify properties of
    windows.
    For example, to full-screen the current window, use:
    xdotool getactivewindow windowstate --add FULLSCREEN
    (#158 by Zhai Zhao Xuan)
  * New command windowquit which is used to ask the windowed application to
    terminate. (#306, Antonio Russo)
  * New command getwindowclassname to print the window's class name.
    (#247, Dominic Mueller)
  * When sending keystrokes, enter and return now are synonyms for the
    Return key symbol (CSylvain)
  * getmouselocation now updates the window stack with the window the cursor
    is
    currently over. (#118, Jordan Sissel)
  * search command now supports searching by window role with --role flag (#
    305, altblue)
  * search command should now no longer report BadWindow errors (#335, Marek
    Marczykowski-Górecki)
  * get_window_location now reports correct value (#289, Edwin Heerschap)
  * Uppercase Latin-1/Basic Latin are now typed correctly (#283, Hasan)
  * Document the regular expressions (POSIX Extended) supported by xdotool
    (#???, Lucas Werkmeister)
  * Use the default X11 Screen instead of assuming 0 (#265, Miroslav Koškár)
  * Wrap header files with extern "C" to enable easier C++ use of libxdo.
    (#331, easyaspi314)
  * Install pkgconfig file when running make install (#229, Joakim Repomaa)
  * Set permissions correctly when installing xdo.h (#324, Dan Church)
  * Fix memory leak (#241, Andrew McDermott)
  * Fix memory leak (#299, orcNo and longqi)
  * Fixed some documentation typos (#161, Vincent Legoll; #336, yjqg6666)
  * Fix all compiler warnings during make (#344, Jordan Sissel)
This commit is contained in:
yhardy 2023-04-27 14:01:01 +00:00
parent 7cdce11171
commit 0133a2666b
4 changed files with 8 additions and 23 deletions

View File

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.5 2020/01/26 17:32:27 rillig Exp $
# $NetBSD: Makefile,v 1.6 2023/04/27 14:01:01 yhardy Exp $
DISTNAME= xdotool-3.20160805.1
DISTNAME= xdotool-3.20211022.1
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_GITHUB:=jordansissel/}
GITHUB_TAG= v${PKGVERSION_NOREV}

View File

@ -1,6 +1,7 @@
@comment $NetBSD: PLIST,v 1.2 2018/09/19 09:33:52 leot Exp $
@comment $NetBSD: PLIST,v 1.3 2023/04/27 14:01:01 yhardy Exp $
bin/xdotool
include/xdo.h
lib/libxdo.so
lib/libxdo.so.3
lib/pkgconfig/libxdo.pc
man/man1/xdotool.1

View File

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.4 2021/10/26 11:34:38 nia Exp $
$NetBSD: distinfo,v 1.5 2023/04/27 14:01:01 yhardy Exp $
BLAKE2s (xdotool-3.20160805.1.tar.gz) = dd4e5b5bfe48e8349d2e400a090f9ee679fe2e54d19550dafbae472dfb49e0a6
SHA512 (xdotool-3.20160805.1.tar.gz) = cf0b1c31e63a43759ff3f081f3b005dd9fe9cabd2f606d7d1238c7ea9c0526681f6ad7883c69ab9194d19a9584c3707f10306be1e826e5953da30838007dd471
Size (xdotool-3.20160805.1.tar.gz) = 106026 bytes
SHA1 (patch-Makefile) = fa116f5bd21ed36995acf957983b3f3e5d6bddb0
BLAKE2s (xdotool-3.20211022.1.tar.gz) = 61dd371fe4c5df9ed87c403bfb459e0a847f44e6fc067b080c7e86c6a4294c86
SHA512 (xdotool-3.20211022.1.tar.gz) = 02e599d25f402759176f200207bd7a78f333e44c4213b9dd266afd47c319e1bbf73b16aac29a31700be9a5cfd37ac0dc52271f26adc4ed46500fb35d7389e182
Size (xdotool-3.20211022.1.tar.gz) = 112033 bytes

View File

@ -1,15 +0,0 @@
$NetBSD: patch-Makefile,v 1.1 2018/09/19 09:33:52 leot Exp $
Properly set permissions of header files (do not need executable bit).
--- Makefile.orig 2016-08-05 17:37:12.000000000 +0000
+++ Makefile
@@ -98,7 +98,7 @@ installlib: libxdo.$(LIBSUFFIX)
.PHONY: installheader
installheader: xdo.h
install -d $(DINSTALLINCLUDE)
- install xdo.h $(DINSTALLINCLUDE)/xdo.h
+ install -m 644 xdo.h $(DINSTALLINCLUDE)/xdo.h
.PHONY: installman
installman: xdotool.1