upgrade to 1.12.

2003-06-14  flw  <flw@ultra.callcc.org>
	* /cvsroot/chicken/chicken/batch-driver.scm, /cvsroot/chicken/chicken/build.scm, /cvsroot/chicken/chicken/chicken.h, /cvsroot/chicken/chicken/c-platform.scm, /cvsroot/chicken/chicken/csi.scm, /cvsroot/chicken/chicken/doc/manual.tex, /cvsroot/chicken/chicken/doc/README, /cvsroot/chicken/chicken/doc/README.CVS, /cvsroot/chicken/chicken/doc/README.txt, /cvsroot/chicken/chicken/extras.scm, /cvsroot/chicken/chicken/library.scm, /cvsroot/chicken/chicken/lolevel.scm, /cvsroot/chicken/chicken/Makefile.am, /cvsroot/chicken/chicken/posix.scm, /cvsroot/chicken/chicken/runtime.c:
	- extras.scm: the first argument to `read-string' is now optional
	- runtime.c: interning of empty string referenced uninitialized memory
	- posix.scm: I/O on ports returned by `process' is now fully nonblocking
	- posix.scm: `errno/wouldblock'
	- files loaded via the `-extend' compiler option are also searched in the
	  current include-path
	- `##sys#call-with-direct-continuation' and `##sys#direct-return' (they
	  might turn out useful)
	- lolevel.scm: `unbound-variable-value'
	- posix.scm: `file-read' didn't check the buffer argument early enough
	- extras.scm: `write-string'
	- csi doesn't use the lolevel unit anymore
	- `chicken-setup.c' was not up to date
	- added BOOTSTRAP_PATH to Makefile.am, this simplifies the invocation
	  of make when bootstrapping the system from CVS sources
	  [Thanks to Peter Keller]
2003-06-06  flw  <flw@ultra.callcc.org>
	* /cvsroot/chicken/chicken/doc/manual.tex, /cvsroot/chicken/chicken/library.scm, /cvsroot/chicken/chicken/posix.scm, /cvsroot/chicken/chicken/runtime.c, /cvsroot/chicken/chicken/tcp.scm:
	- tcp.scm: tcp-listener-port
	- fixed bug in runtime.c that resulted in fopen() being called with invalid file-mode
	- tcp.scm: EWOULDBLOCK wasn't defined under Win32 with MSVC
	- the printer mixed up "input" and "output" when printing port objects
	- fixed bug in read-char handler of pipe-ports
	- fixed two unbound variable bugs in library.scm and posix.scm
	- commit updates ChangeLog at website and send message to mailing list.
	  In other words: SMTP and FTP extensions are imminent ;-)
2003-06-02  flw  <flw@ultra.callcc.org>
	* /cvsroot/chicken/chicken/compiler.scm, /cvsroot/chicken/chicken/csi.scm, /cvsroot/chicken/chicken/doc/FAQ.html, /cvsroot/chicken/chicken/doc/manual.tex, /cvsroot/chicken/chicken/doc/README, /cvsroot/chicken/chicken/doc/README.txt, /cvsroot/chicken/chicken/eval.scm, /cvsroot/chicken/chicken/extras.scm, /cvsroot/chicken/chicken/format.scm, /cvsroot/chicken/chicken/library.scm, /cvsroot/chicken/chicken/lolevel.scm, /cvsroot/chicken/chicken/posix.scm, /cvsroot/chicken/chicken/runtime.c, /cvsroot/chicken/chicken/scheduler.scm, /cvsroot/chicken/chicken/support.scm, /cvsroot/chicken/chicken/tcp.scm, /cvsroot/chicken/chicken/batch-driver.scm, /cvsroot/chicken/chicken/build.scm, /cvsroot/chicken/chicken/chicken.h:
	- fixed problem with scheduler.scm (C_msleep) under Windows
	- overhauled I/O subsystem
	- lolevel.scm: invalid-procedure-call-handler
	- declaration `safe-globals'
	- internal compiler for `##core#app'
	- eval/visit uses `##core#app'
	- debug-option `D'
	- (hopefully) settled all thread-safety issues in `format.scm'
	- nonblocking I/O for tcp-ports
	- made `##sys#errno' an int, instead of an integer (library.scm)
	- fixed bug in tcp.scm: partial writes to tcp-port didn't remove sent part
	- `##sys#thread-block-for-i/o!' for output (or mixed?) mode doesn't work properly (deactived,
	  does simple polling)
2003-05-21  flw  <flw@ultra.callcc.org>
	* /cvsroot/chicken/chicken/chicken-setup.scm, /cvsroot/chicken/chicken/doc/FAQ.html, /cvsroot/chicken/chicken/doc/manual.tex, /cvsroot/chicken/chicken/library.scm, /cvsroot/chicken/chicken/scheduler.scm:
	- scheduler.scm: timeout-values in nanoseconds where calculated incorrectly
	- chicken-setup.scm: -wrap doesn't create registry, if not existing
	- ##sys#special-read-syntax-table
	- updated FAQ a little
2003-05-19  flw  <flw@ultra.callcc.org>
	* /cvsroot/chicken/chicken/chicken.h, /cvsroot/chicken/chicken/compiler.scm, /cvsroot/chicken/chicken/doc/manual.tex, /cvsroot/chicken/chicken/eval.scm, /cvsroot/chicken/chicken/highlevel-macros.scm, /cvsroot/chicken/chicken/moremacros.scm, /cvsroot/chicken/chicken/posix.scm, /cvsroot/chicken/chicken/runtime.c, /cvsroot/chicken/chicken/scheduler.scm:
	- `define-foreign-variable' isn't seen by `visit' anymore
	- `C_flonum()' advanced allocation pointer wrongly on 64-bit platforms
	- `parameterize' accepts arbitrary expressions in the parameter position of the binding-list
	- applied patches by Sven Hartrumpf that remove unneeded special casing for ICC
	- constants defined via `define-constant' are visible inside constant-expressions for
	  that form
	- the scheduler doesn't waste CPU cycles when waiting for thread- or I/O-timeout, unless
	  other threads are ready [Thanks to Chris Double]
2003-05-08  flw  <flw@ultra.callcc.org>
	* /cvsroot/chicken/chicken/doc/manual.tex, /cvsroot/chicken/chicken/doc/README, /cvsroot/chicken/chicken/doc/README.txt, /cvsroot/chicken/chicken/support.scm, /cvsroot/chicken/chicken/build.scm, /cvsroot/chicken/chicken/chicken.h, /cvsroot/chicken/chicken/compiler.scm, /cvsroot/chicken/chicken/eval.scm, /cvsroot/chicken/chicken/highlevel-macros.scm, /cvsroot/chicken/chicken/moremacros.scm, /cvsroot/chicken/chicken/parameters.scm, /cvsroot/chicken/chicken/posix.scm, /cvsroot/chicken/chicken/runtime.c:
	- fixed bug in `process-execute', pointers to potentially gc-moved strings where retained
	  [thanks to Joerg Wittenberger]
	- `define-constant' evaluates 2nd argument at compile time
	- fixed bug with mutable constants in `define-constant' forms
	- visiting handles `define-foreign-type' and `define-foreign-variable'
	- fixed compiler bug in support.scm: `estimate-foreign-result-size' allocated one word too little if flonum result
	  has to be aligned
	- `##core#inline[_allocate]' expanded incorrectly with the hygienic macro system
	  [Thanks to Panagiotis Vossos]
	- fixed 32-bit dependencies: C_FLONUM_TAG was wrong on 64-bit platforms; C_equalp() used `int' where a `C_word'
	  was needed
	- 8-byte alignment was incorrectly handled for 64-bit platforms
2003-05-04  flw  <flw@ultra.callcc.org>
	* /cvsroot/chicken/chicken/doc/manual.tex, /cvsroot/chicken/chicken/library.scm:
	- `output-port?' returned 0 on closed port [Thanks to Burton Samograd]
	* /cvsroot/chicken/chicken/chicken.h, /cvsroot/chicken/chicken/chicken-setup.scm, /cvsroot/chicken/chicken/compiler.scm, /cvsroot/chicken/chicken/csi.scm, /cvsroot/chicken/chicken/doc/manual.tex, /cvsroot/chicken/chicken/doc/README, /cvsroot/chicken/chicken/doc/README.txt, /cvsroot/chicken/chicken/eval.scm, /cvsroot/chicken/chicken/extras.scm, /cvsroot/chicken/chicken/format.scm, /cvsroot/chicken/chicken/highlevel-macros.scm, /cvsroot/chicken/chicken/library.scm, /cvsroot/chicken/chicken/moremacros.scm, /cvsroot/chicken/chicken/parameters.scm, /cvsroot/chicken/chicken/posix.scm, /cvsroot/chicken/chicken/runtime.c, /cvsroot/chicken/chicken/srfi-13.scm, /cvsroot/chicken/chicken/support.scm, /cvsroot/chicken/chicken/batch-driver.scm, /cvsroot/chicken/chicken/build.scm:
	- `substring' signals (exn bounds)
	- replaced several occurences of `substring' with `##sys#substring'
	- moved the description of `process' into the proper manual section
	- `process' should read non-blocking, now
	- buffer grows by doubling it's size in `read-line'
	- chicken-setup: defaults options are "-O2 -d0"
	- format is thread-safe
	- the transcript port wasn't properly recognized as a tty-port
	- vector-copy! signals (exn bounds)
	- several small optimizations in library.scm
	- non-exported globals where still exported, if ref'd before definition
	- non-blocking `process' seems to work
	- `csi -setup-help' and -uninstall
	- `string-null?' is expanded inline
	- visit handling constant- and inline-definitions
	- `define-constant' wasn't consistently handled in hygienic and non-hygienic mode
	- removed procedure-definition syntax for `define-constant'
2003-04-23  flw  <flw@ultra.callcc.org>
	* /cvsroot/chicken/chicken/build.scm, /cvsroot/chicken/chicken/c-backend.scm, /cvsroot/chicken/chicken/chicken.h, /cvsroot/chicken/chicken/chicken-setup.scm, /cvsroot/chicken/chicken/compiler.scm, /cvsroot/chicken/chicken/configure.in, /cvsroot/chicken/chicken/doc/manual.tex, /cvsroot/chicken/chicken/doc/README, /cvsroot/chicken/chicken/doc/README.txt, /cvsroot/chicken/chicken/eval.scm, /cvsroot/chicken/chicken/extras.scm, /cvsroot/chicken/chicken/library.scm, /cvsroot/chicken/chicken/lolevel.scm, /cvsroot/chicken/chicken/posix.scm, /cvsroot/chicken/chicken/regex.scm, /cvsroot/chicken/chicken/runtime.c, /cvsroot/chicken/chicken/support.scm:
	- hidden globals where not properly checked for boundedness
	- the foreign return types `c-pointer' and `pointer' did not return `#f' on NULL results
	  [thanks to Peter Wang]
	- `##sys#void' is handled better by `canonicalize-begin-body' (support.scm)
	- fixed space leaks in `regex.scm'
	- `read-line' accepts optional limit
	- `-setup' gives useful error-message on non-UNIX platforms
	- there where two conflicting versions of `provided?'
	- chicken-setup handles single-file case
	- some warning-options are passed to CFLAGS
	- fixed typo in posix.scm [Thanks to Joerg Wittenberger]
2003-04-19  flw  <flw@ultra.callcc.org>
	* /cvsroot/chicken/chicken/highlevel-macros.scm, /cvsroot/chicken/chicken/runtime.c:
	- fixed a couple of 32-bit dependencies [Thanks to Panagiotis Vossos]
	- fixed bug in syntax-case version of condition-case
	* /cvsroot/chicken/chicken/psyntax-chicken.pp:
	removed psyntax-chicken.pp
	* /cvsroot/chicken/chicken/examples/ctclsh.scm, /cvsroot/chicken/chicken/doc/manual.tex, /cvsroot/chicken/chicken/doc/README.txt, /cvsroot/chicken/chicken/doc/README, /cvsroot/chicken/chicken/support.scm, /cvsroot/chicken/chicken/tcp.scm, /cvsroot/chicken/chicken/runtime.c, /cvsroot/chicken/chicken/srfi-25.scm, /cvsroot/chicken/chicken/csi.scm, /cvsroot/chicken/chicken/highlevel-macros.scm, /cvsroot/chicken/chicken/library.scm, /cvsroot/chicken/chicken/moremacros.scm, /cvsroot/chicken/chicken/optimizer.scm, /cvsroot/chicken/chicken/psyntax.scm, /cvsroot/chicken/chicken/batch-driver.scm, /cvsroot/chicken/chicken/build.scm, /cvsroot/chicken/chicken/c-backend.scm, /cvsroot/chicken/chicken/chicken.1, /cvsroot/chicken/chicken/chicken.scm, /cvsroot/chicken/chicken/compiler.scm, /cvsroot/chicken/chicken/c-platform.scm, /cvsroot/chicken/chicken/Makefile.am:
	- fixed bug in c-backend.scm: heap-limit settings [Thanks to Sven Hartrumpf]
	- fixed bug in runtime.c: handling of -:t... was bogus [Thanks to Sven]
	- the default output-file for `chicken' is now the original-filename (+ ".c") [Thanks to Panagiotis Vossos]
	- syntax-case uses `##sys#void' in expansions
	- removed `error-handler'
	- diversified exceptions a little
	- srfi-25: signals more sensible exn types
	- added `condition-case'
2003-04-08  flw  <flw@ultra.callcc.org>
	* /cvsroot/chicken/chicken/compiler.scm, /cvsroot/chicken/chicken/doc/manual.tex, /cvsroot/chicken/chicken/eval.scm, /cvsroot/chicken/chicken/examples/prolog.scm, /cvsroot/chicken/chicken/examples/schelog-support.scm, /cvsroot/chicken/chicken/library.scm, /cvsroot/chicken/chicken/match-support.scm, /cvsroot/chicken/chicken/posix.scm, /cvsroot/chicken/chicken/regex.scm, /cvsroot/chicken/chicken/runtime.c, /cvsroot/chicken/chicken/scheduler.scm, /cvsroot/chicken/chicken/script-utils.scm, /cvsroot/chicken/chicken/srfi-13.scm, /cvsroot/chicken/chicken/srfi-14.scm, /cvsroot/chicken/chicken/srfi-18.scm, /cvsroot/chicken/chicken/srfi-1.scm, /cvsroot/chicken/chicken/srfi-37.scm, /cvsroot/chicken/chicken/srfi-4.scm, /cvsroot/chicken/chicken/syntax-case.scm, /cvsroot/chicken/chicken/tcp.scm:
	- eval.scm: `##sys#environment-is-mutable' isn't hidden anymore.
	- scheduler.scm: ##sys#fetch-and-clear.
	- simplified some code in tcp.scm.
	- `(build-platform)' returns 'intel for ICC.
	- removed `interrupts-disabled' declaration.
2003-04-03  flw  <flw@ultra.callcc.org>
	* /cvsroot/chicken/chicken/configure.in, /cvsroot/chicken/chicken/doc/manual.tex, /cvsroot/chicken/chicken/runtime.c:
	- Changed calls to AC_INIT and AM_INIT_AUTOMAKE in configure.in to new syntax.
	- Recreated autotool files using newest versions.
2003-03-31  flw  <flw@ultra.callcc.org>
	* /cvsroot/chicken/chicken/batch-driver.scm, /cvsroot/chicken/chicken/build.scm, /cvsroot/chicken/chicken/chicken.1, /cvsroot/chicken/chicken/chicken-setup.scm, /cvsroot/chicken/chicken/compiler.scm, /cvsroot/chicken/chicken/c-platform.scm, /cvsroot/chicken/chicken/csc.bat, /cvsroot/chicken/chicken/csc.in, /cvsroot/chicken/chicken/csi.scm, /cvsroot/chicken/chicken/doc/manual.tex, /cvsroot/chicken/chicken/doc/README, /cvsroot/chicken/chicken/doc/README.txt, /cvsroot/chicken/chicken/eval.scm, /cvsroot/chicken/chicken/highlevel-macros.scm, /cvsroot/chicken/chicken/library.scm, /cvsroot/chicken/chicken/moremacros.scm, /cvsroot/chicken/chicken/posix.scm, /cvsroot/chicken/chicken/support.scm:
	- Removed syntax checks from internal `##core#...' forms.
	- `require-at-runtime' setup-specification.
	- `csi -setup -init' did not install core extensions.
	- `seconds->string' (posix.scm) couldn't handle large (but valid) non-fixnum integers
	  [Thanks to Anthony Carrico]
	- `visit' and `-visit' options to csi and chicken.
	- `(gc #t)' didn't return number of free bytes.
	- `pathname-directory-separator' was #\\ under Cygwin (is now #\/).
	- Removed fixnum->flonum coercion warning in reader.
2003-03-23  njbeckford  <njbeckford@ultra.callcc.org>
	* /cvsroot/chicken/chicken/runtime.c:
	Got rid of buffer overflow in C_get_environment_variable.
2003-03-22  njbeckford  <njbeckford@ultra.callcc.org>
	* /cvsroot/chicken/chicken/Makefile.am:
	Undid change that made both MORE_LIBS and MORE_STATIC_LIBS be the same thing.
	* /cvsroot/chicken/chicken/Makefile.am:
	Made both MORE_LIBS and MORE_STATIC_LIBS be the same thing.
	* /cvsroot/chicken/chicken/Makefile.am:
	-all-static replaced by -static.  On Solaris, need libdl.so and
	libnsl.so since no libdl.a nor libnsl.a.
	* /cvsroot/chicken/chicken/Makefile.am:
	"make doc" and "make testsuites" now use CHICKEN=../chicken
	* /cvsroot/chicken/chicken/Makefile.am:
	Uses MORE_STATIC_LIBS instead of MORE_LIBS for
	lib[xxx_]chicken_la_LDFLAGS so that libtool does not add "-ldl"
	whenever something links with lib[xxx-]chicken.la.
	* /cvsroot/chicken/chicken/chicken-config.in, /cvsroot/chicken/chicken/configure.in, /cvsroot/chicken/chicken/csc.in, /cvsroot/chicken/chicken/Makefile.am, /cvsroot/chicken/chicken/runtime.c:
	configure.in: Made new variable SHLIBS which has -ldl or -ldld, which will only be used in non -all-static code.
	Makefile.am: Use SHLIBS to differentiate MORE_LIBS from MORE_STATIC_LIBS.
	runtime.c: Do not even try to use dl.h/dlfcn.h/dlopen/shlopen when in all-static mode.
	chicken-config.in, csc.in: Use MORE_STATIC_LIBS (%morestaticlibs%) in static mode.
This commit is contained in:
itojun 2003-08-27 08:52:57 +00:00
parent be18c8dd69
commit 0135f9dbcb
5 changed files with 26 additions and 23 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.6 2003/07/21 16:54:00 martti Exp $
# $NetBSD: Makefile,v 1.7 2003/08/27 08:52:57 itojun Exp $
#
DISTNAME= chicken-1.0
DISTNAME= chicken-1.12
CATEGORIES= lang
MASTER_SITES= http://www.call-with-current-continuation.org/

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2003/05/21 19:43:03 seb Exp $
@comment $NetBSD: PLIST,v 1.3 2003/08/27 08:52:57 itojun Exp $
bin/chicken
bin/chicken-config
bin/chicken-static
@ -164,7 +164,10 @@ share/doc/html/chicken/manual-Z-H-45.html
share/doc/html/chicken/manual-Z-H-46.html
share/doc/html/chicken/manual-Z-H-47.html
share/doc/html/chicken/manual-Z-H-48.html
share/doc/html/chicken/manual-Z-H-49.html
share/doc/html/chicken/manual-Z-H-5.html
share/doc/html/chicken/manual-Z-H-50.html
share/doc/html/chicken/manual-Z-H-51.html
share/doc/html/chicken/manual-Z-H-6.html
share/doc/html/chicken/manual-Z-H-7.html
share/doc/html/chicken/manual-Z-H-8.html

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.4 2003/05/21 19:43:03 seb Exp $
$NetBSD: distinfo,v 1.5 2003/08/27 08:52:58 itojun Exp $
SHA1 (chicken-1.0.tar.gz) = 687c2f9b8ee651c154de525ebe852c24ceb53299
Size (chicken-1.0.tar.gz) = 2518831 bytes
SHA1 (patch-aa) = 2bf71e9e3650f3bb35b6991e51143758cff75b37
SHA1 (patch-ab) = 5500fcac8fe9c0749b76fa2e3006a493faaf0850
SHA1 (chicken-1.12.tar.gz) = d9869c13d110829d89abf13c00e32e7ff6de75fa
Size (chicken-1.12.tar.gz) = 2557064 bytes
SHA1 (patch-aa) = 0d4fbc773a33f3a910f25eefd66bf4a7e4bfd68e
SHA1 (patch-ab) = 65937026074731a8a2f0d63b0d9b72cccbe2327b
SHA1 (patch-ac) = f666a50c992af1fbcff4da107a69c0a598cf8b58
SHA1 (patch-ad) = fb80d8782aa6310f9fa31b219ad65adf9034debb

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.3 2003/05/21 19:43:04 seb Exp $
$NetBSD: patch-aa,v 1.4 2003/08/27 08:52:59 itojun Exp $
--- Makefile.am.orig 2003-03-12 21:23:00.000000000 +0000
+++ Makefile.am
@@ -242,10 +242,10 @@ pkgdata_DATA = match.scm moremacros.scm
--- Makefile.am.orig 2003-06-14 02:35:08.000000000 +0900
+++ Makefile.am 2003-08-27 17:39:30.000000000 +0900
@@ -249,10 +249,10 @@
# Install docs and sources.
install-data-local : doc-html
@ -17,9 +17,9 @@ $NetBSD: patch-aa,v 1.3 2003/05/21 19:43:04 seb Exp $
$(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/src
-cp $(srcdir)/*.scm $(srcdir)/runtime.c $(DESTDIR)$(pkgdatadir)/src
$(mkinstalldirs) $(DESTDIR)$(pkglibdir)
@@ -466,4 +466,4 @@ doc-html :
@@ -479,4 +479,4 @@
.PHONY : test
test :
- cd testsuites; $(MAKE) CC="$(CC)" CHICKEN="$(CHICKEN)" LIBDIR=../.libs CFLAGS="$(CFLAGS)"; cd ..
+ cd testsuites; $(MAKE)
- cd testsuites; $(MAKE) CC="$(CC)" CHICKEN="../chicken" LIBDIR=../.libs CFLAGS="$(CFLAGS)"; cd ..
+ cd testsuites; $(MAKE) CHICKEN="../chicken" LIBDIR=../.libs; cd ..

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ab,v 1.1 2003/05/21 19:43:04 seb Exp $
$NetBSD: patch-ab,v 1.2 2003/08/27 08:52:59 itojun Exp $
--- Makefile.in.orig 2003-03-18 22:35:53.000000000 +0000
+++ Makefile.in
@@ -456,7 +456,7 @@ am__CONFIG_DISTCLEAN_FILES = config.stat
--- Makefile.in.orig 2003-04-24 04:30:07.000000000 +0900
+++ Makefile.in 2003-08-27 17:40:34.000000000 +0900
@@ -461,7 +461,7 @@
configure.lineno
$(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
cd $(top_srcdir) && \
@ -11,7 +11,7 @@ $NetBSD: patch-ab,v 1.1 2003/05/21 19:43:04 seb Exp $
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
cd $(top_builddir) && $(SHELL) ./config.status $@ $(am__depfiles_maybe)
@@ -1226,10 +1226,10 @@ formatprofile:
@@ -1233,10 +1233,10 @@
# Install docs and sources.
install-data-local : doc-html
@ -26,12 +26,12 @@ $NetBSD: patch-ab,v 1.1 2003/05/21 19:43:04 seb Exp $
$(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/src
-cp $(srcdir)/*.scm $(srcdir)/runtime.c $(DESTDIR)$(pkgdatadir)/src
$(mkinstalldirs) $(DESTDIR)$(pkglibdir)
@@ -1420,7 +1420,7 @@ doc-html :
@@ -1432,7 +1432,7 @@
.PHONY : test
test :
- cd testsuites; $(MAKE) CC="$(CC)" CHICKEN="$(CHICKEN)" LIBDIR=../.libs CFLAGS="$(CFLAGS)"; cd ..
+ cd testsuites; $(MAKE)
- cd testsuites; $(MAKE) CC="$(CC)" CHICKEN="../chicken" LIBDIR=../.libs CFLAGS="$(CFLAGS)"; cd ..
+ cd testsuites; $(MAKE) CHICKEN="../chicken" LIBDIR=../.libs; cd ..
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT: