make amanda-security.conf be treated as a config file

make sure amanda finds amanda-security.conf in PKG_SYSCONFDIR
This commit is contained in:
spz 2018-11-25 20:20:57 +00:00
parent 12a9b07c9e
commit 0157df37cd
5 changed files with 26 additions and 6 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.76 2018/11/23 22:33:13 spz Exp $
# $NetBSD: Makefile,v 1.77 2018/11/25 20:20:57 spz Exp $
PKGNAME= amanda-common-${AMANDA_VERSION}
#PKGREVISION= 1
PKGREVISION= 1
COMMENT= Common libraries and binaries for Amanda
@ -30,6 +30,9 @@ OWN_DIRS_PERMS+= ${VARBASE}/log/amanda ${AMANDA_USER} ${AMANDA_GROUP} 0750
CONF_FILES_PERMS= ${PREFIX}/share/doc/amanda/example/amanda-client.conf \
${PKG_SYSCONFDIR}/amanda/amanda-client.conf \
${AMANDA_USER} ${AMANDA_GROUP} 0600
CONF_FILES_PERMS= ${PREFIX}/share/doc/amanda/example/amanda-security.conf \
${PKG_SYSCONFDIR}/amanda/amanda-security.conf \
${AMANDA_USER} ${AMANDA_GROUP} 0600
REQD_FILES_PERMS+= /dev/null ${AMANDA_VAR}/amandates ${AMANDA_USER} ${AMANDA_GROUP} 0640

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.43 2018/07/04 13:40:36 jperkin Exp $
# $NetBSD: Makefile.common,v 1.44 2018/11/25 20:20:57 spz Exp $
# used by sysutils/amanda-common/Makefile
# used by sysutils/amanda-client/Makefile
@ -79,6 +79,7 @@ CONFIGURE_ARGS+= --with-bsdtcp-security
CONFIGURE_ARGS+= --with-bsdudp-security
CONFIGURE_ARGS+= --with-dump-honor-nodump
CONFIGURE_ARGS+= --disable-installperms
CONFIGURE_ARGS+= --with-security-file=${PKG_SYSCONFDIR:Q}/amanda/amanda-security.conf
LDFLAGS.SunOS+= -lsocket
LDFLAGS.NetBSD+= -lutil

View file

@ -1,5 +1,4 @@
@comment $NetBSD: PLIST,v 1.9 2018/11/23 22:33:13 spz Exp $
etc/amanda/amanda-security.conf
@comment $NetBSD: PLIST,v 1.10 2018/11/25 20:20:57 spz Exp $
lib/amanda/libamanda.la
lib/amanda/libamandad.la
lib/amanda/libamar.la
@ -75,6 +74,7 @@ share/doc/amanda/NEWS
share/doc/amanda/ReleaseNotes
share/doc/amanda/example/amanda-client-postgresql.conf
share/doc/amanda/example/amanda-client.conf
share/doc/amanda/example/amanda-security.conf
share/doc/amanda/example/amanda.conf
share/doc/amanda/example/amandaclient.xml
share/doc/amanda/example/amandaserver.xml

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.22 2018/11/23 22:33:13 spz Exp $
$NetBSD: distinfo,v 1.23 2018/11/25 20:20:57 spz Exp $
SHA1 (amanda-3.3.9.tar.gz) = aff8af309edace21985434c041e3c46052db0ee1
RMD160 (amanda-3.3.9.tar.gz) = 8f96be4318a86405b1d7045b899777d933f2abc4
@ -13,6 +13,7 @@ SHA1 (patch-client-src_Makefile.am) = 641ef76fd1ea413b416704e1e52e25a93a596442
SHA1 (patch-client-src_getfsent.c) = 903a921b8679ddcff1fdd838ffdce16a6d8da46f
SHA1 (patch-client-src_sendbackup-dump.c) = aea1aca0bbcdab0c393b012a592cbc5ca458acec
SHA1 (patch-client-src_sendsize.c) = 32a1627c250b6413e4695a610bba59796c6e7ed6
SHA1 (patch-common-src_Makefile.am) = 0dd6cbd5707e08d3d0eb219e4a1bb002f8053e82
SHA1 (patch-common-src_Makefile.in) = b4f3dee5a64806c3e8228af68ccbd94ecfd2d8cc
SHA1 (patch-common-src_conffile.c) = 764c2db25c16558dea4221d3e85e7cef3d52b6c5
SHA1 (patch-common-src_genversion.c) = a457850d9377e9d074baeaf3b7c4cb66a047c486

View file

@ -0,0 +1,15 @@
$NetBSD: patch-common-src_Makefile.am,v 1.1 2018/11/25 20:20:57 spz Exp $
pkgsrcify
--- common-src/Makefile.am.orig 2016-02-09 22:52:51.000000000 +0000
+++ common-src/Makefile.am
@@ -172,7 +172,7 @@ BUILT_SOURCES += genversion.h version.c
amanda-security.conf: make_security_file
./make_security_file
-etcamandadir = ${CONFIG_DIR}
+etcamandadir = ${docdir}/example
etcamanda_FILE = amanda-security.conf
etcamanda_DATA = ${etcamanda_FILE}