Don't install aliases "GET", "HEAD" and "POST" under Mac OS X.
At least "HEAD" causes problems on a case-insensitive filesystem because it will be confused with "/usr/bin/head". Bump package revision.
This commit is contained in:
parent
9b3751e63e
commit
0168d01108
3 changed files with 22 additions and 10 deletions
|
@ -1,9 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.53 2007/11/07 09:45:00 heinz Exp $
|
||||
# $NetBSD: Makefile,v 1.54 2007/11/23 08:46:32 tron Exp $
|
||||
|
||||
DISTNAME= libwww-perl-5.808
|
||||
PKGNAME= p5-${DISTNAME:S/-perl-/-/}
|
||||
SVR4_PKGNAME= p5lww
|
||||
PKGREVISION= 2
|
||||
PKGREVISION= 3
|
||||
CATEGORIES= www perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=WWW/}
|
||||
|
||||
|
@ -24,7 +24,16 @@ DEPENDS+= p5-URI>=1.10:../../www/p5-URI
|
|||
DEPENDS+= p5-Digest-MD5-[0-9]*:../../security/p5-Digest-MD5
|
||||
|
||||
PERL5_PACKLIST= auto/LWP/.packlist
|
||||
MAKE_ENV+= PERL_MM_USE_DEFAULT=1
|
||||
MAKE_ENV+= OPSYS=${OPSYS:Q} PERL_MM_USE_DEFAULT=1
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if ${OPSYS} == "Darwin"
|
||||
# Mac OS X uses an case-insensitive filesystem where "HEAD" can be
|
||||
# confused with "head".
|
||||
post-install:
|
||||
${RM} -f ${PREFIX}/bin/HEAD
|
||||
.endif
|
||||
|
||||
.include "../../lang/perl5/module.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.17 2007/11/07 09:45:00 heinz Exp $
|
||||
$NetBSD: distinfo,v 1.18 2007/11/23 08:46:32 tron Exp $
|
||||
|
||||
SHA1 (libwww-perl-5.808.tar.gz) = 9eeb0a88a4f08006ba4a798effd74b139867f3ab
|
||||
RMD160 (libwww-perl-5.808.tar.gz) = 4ccc1c06cde162cc2a43e14554c9d4ad7103e51a
|
||||
Size (libwww-perl-5.808.tar.gz) = 240305 bytes
|
||||
SHA1 (patch-aa) = 111a05ad721ee094aaf555535768e6b0e16cad0a
|
||||
SHA1 (patch-aa) = 2dddc75cecaea37ffed94ded0760289775c6ee80
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-aa,v 1.3 2007/11/07 09:45:01 heinz Exp $
|
||||
$NetBSD: patch-aa,v 1.4 2007/11/23 08:46:32 tron Exp $
|
||||
|
||||
--- Makefile.PL.orig 2007-07-19 22:45:32.000000000 +0200
|
||||
+++ Makefile.PL
|
||||
@@ -56,13 +56,16 @@ my $some_time_ago = sprintf "%04d-%02d-%
|
||||
--- Makefile.PL.orig 2007-07-19 21:45:32.000000000 +0100
|
||||
+++ Makefile.PL 2007-11-23 08:42:49.000000000 +0000
|
||||
@@ -56,13 +56,16 @@
|
||||
sub { ($_[5]+1900, $_[4]+1, $_[3])}->(localtime(time - 45 * 24*60*60));
|
||||
if ($some_time_ago lt $release_date) {
|
||||
# Check if we have internet connection
|
||||
|
@ -24,12 +24,15 @@ $NetBSD: patch-aa,v 1.3 2007/11/07 09:45:01 heinz Exp $
|
|||
|
||||
print <<EOT;
|
||||
|
||||
@@ -128,7 +131,7 @@ $Config{installscript}.
|
||||
@@ -128,7 +131,10 @@
|
||||
EOT
|
||||
my @tmp;
|
||||
for my $alias (@request_aliases) {
|
||||
- my $default = "n";
|
||||
+ my $default = "y";
|
||||
+ if ($ENV{"OPSYS"} eq "Darwin") {
|
||||
+ $default = "n";
|
||||
+ }
|
||||
if (prompt("Do you want to install the $alias alias?", $default) =~ /^y/) {
|
||||
push(@tmp, $alias);
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue