Always return a value from non-void functions.

This commit is contained in:
joerg 2012-10-26 20:13:41 +00:00
parent 25e60f9a7d
commit 0169d20c2a
2 changed files with 48 additions and 3 deletions

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.10 2011/05/21 17:23:10 wiz Exp $
$NetBSD: distinfo,v 1.11 2012/10/26 20:13:41 joerg Exp $
SHA1 (xvidcap-1.1.3.tar.gz) = e6d86a4184c8cc3e74738fb6e20d49c0d1640025
RMD160 (xvidcap-1.1.3.tar.gz) = cc7be360153f192b502ffedc6548cce163a9154c
Size (xvidcap-1.1.3.tar.gz) = 1627036 bytes
SHA1 (patch-aa) = 9196f59ec849a361821fd5cae800ec6aef2a1dfc
SHA1 (patch-ab) = cea05b76ffb2919e1fd4dcb5f489f641ca8e36bd
SHA1 (patch-ab) = a1b379bbca8ca8dcbad4363b8d37897d56cf16d5
SHA1 (patch-ac) = 0de9d748e3808a210ec68d140eb1dfd5e18d9e4f
SHA1 (patch-ad) = ac40095849f721cfd8aa1e0143dff3ac9b705be7
SHA1 (patch-ae) = 2ebab45421ab2782d48067f7b63e010190111397

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ab,v 1.2 2005/12/28 16:37:04 joerg Exp $
$NetBSD: patch-ab,v 1.3 2012/10/26 20:13:42 joerg Exp $
--- src/capture.c.orig 2004-02-14 20:14:20.000000000 +0000
+++ src/capture.c
@ -12,6 +12,42 @@ $NetBSD: patch-ab,v 1.2 2005/12/28 16:37:04 joerg Exp $
uint16_t mousePointerBlack[] = { 0, 49152, 40960, 36864, 34816, 33792, 33280, 33024, 32896, 32832,
33728, 37376, 43264, 51456, 1152, 1152, 576, 576, 448, 0 };
@@ -369,7 +372,7 @@ TCbCaptureX11(XtPointer xtp, XtIntervalI
if (!fp) {
perror(file);
job->state = VC_STOP;
- return;
+ return FALSE;
}
}
if (job->state & VC_START) {
@@ -503,7 +506,7 @@ TCbCaptureX11(XtPointer xtp, XtIntervalI
job->state |= VC_START;
job->state |= VC_REC;
XVC_StartCapture(job);
- return;
+ return FALSE;
}
if ( job->flags & FLG_NOGUI ) {
@@ -572,7 +575,7 @@ TCbCaptureSHM(XtPointer xtp, XtIntervalI
if (!fp) {
perror(file);
job->state = VC_STOP;
- return;
+ return FALSE;
}
}
if (job->state & VC_START) {
@@ -599,7 +602,7 @@ TCbCaptureSHM(XtPointer xtp, XtIntervalI
job->area->height, job->area->x, job->area->y);
job->state = VC_STOP;
// CbStop(NULL, NULL, NULL);
- return;
+ return FALSE;
}
shminfo.shmid = shmget(IPC_PRIVATE,
image->bytes_per_line * image->height, IPC_CREAT|0777);
@@ -643,7 +646,7 @@ TCbCaptureSHM(XtPointer xtp, XtIntervalI
(*job->close) (fp);
else if (job->flags & FLG_SYNC) {
@ -21,3 +57,12 @@ $NetBSD: patch-ab,v 1.2 2005/12/28 16:37:04 joerg Exp $
}
/* substract the time we needed for creating and saving
@@ -724,7 +727,7 @@ TCbCaptureSHM(XtPointer xtp, XtIntervalI
job->state |= VC_START;
job->state |= VC_REC;
XVC_StartCapture(job);
- return;
+ return FALSE;
}
if ( job->flags & FLG_NOGUI ) {