add libtcd version 2.2.7-r2:
libtcd provides a software API for reading and writing Tide Constituent Database (TCD) files. The TCD file format and schema are used by XTide to retrieve constituent definitions (speeds, equilibrium arguments, and node factors), harmonic constants, subordinate station offsets and associated metadata for use in generating tide predictions. The TCD file format and schema were originally designed by Jan Depner to improve the performance of XTide and to meet additional requirements of the U.S. Naval Oceanographic Office (NAVO). They are now maintained primarily by David Flater. The design goals for TCD included: Available without installing heavy external packages. Efficient for indexing and loading of stations. Compact file format. Translatable without loss from legacy XTide .txt and .xml files. Exportable to legacy .txt and .xml formats. Modifiable by end user using tideEditor. Able to detect tampering (usually, misguided attempts to edit the database in a word processor).
This commit is contained in:
parent
d8a6f19170
commit
01bd38da68
6 changed files with 178 additions and 0 deletions
23
databases/libtcd/DESCR
Normal file
23
databases/libtcd/DESCR
Normal file
|
@ -0,0 +1,23 @@
|
|||
libtcd provides a software API for reading and writing Tide Constituent
|
||||
Database (TCD) files.
|
||||
|
||||
The TCD file format and schema are used by XTide to retrieve constituent
|
||||
definitions (speeds, equilibrium arguments, and node factors), harmonic
|
||||
constants, subordinate station offsets and associated metadata for use
|
||||
in generating tide predictions.
|
||||
|
||||
The TCD file format and schema were originally designed by Jan Depner
|
||||
to improve the performance of XTide and to meet additional requirements
|
||||
of the U.S. Naval Oceanographic Office (NAVO). They are now maintained
|
||||
primarily by David Flater.
|
||||
|
||||
The design goals for TCD included:
|
||||
|
||||
Available without installing heavy external packages.
|
||||
Efficient for indexing and loading of stations.
|
||||
Compact file format.
|
||||
Translatable without loss from legacy XTide .txt and .xml files.
|
||||
Exportable to legacy .txt and .xml formats.
|
||||
Modifiable by end user using tideEditor.
|
||||
Able to detect tampering (usually, misguided attempts to edit the
|
||||
database in a word processor).
|
21
databases/libtcd/Makefile
Normal file
21
databases/libtcd/Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
# $NetBSD: Makefile,v 1.1 2020/01/10 16:57:24 plunky Exp $
|
||||
|
||||
DISTNAME= libtcd-2.2.7-r2
|
||||
PKGNAME= ${DISTNAME:S/-r/r/}
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= https://flaterco.com/files/xtide/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= https://flaterco.com/
|
||||
COMMENT= API for reading and writing Tide Constituent Database (TCD) files
|
||||
LICENSE= public-domain
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:C/-r.*//}
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_TOOLS= bash gmake gsed
|
||||
USE_LIBTOOL= yes
|
||||
USE_LANGUAGES= c c++
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
databases/libtcd/PLIST
Normal file
3
databases/libtcd/PLIST
Normal file
|
@ -0,0 +1,3 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2020/01/10 16:57:24 plunky Exp $
|
||||
include/tcd.h
|
||||
lib/libtcd.la
|
13
databases/libtcd/buildlink3.mk
Normal file
13
databases/libtcd/buildlink3.mk
Normal file
|
@ -0,0 +1,13 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1 2020/01/10 16:57:24 plunky Exp $
|
||||
|
||||
BUILDLINK_TREE+= libtcd
|
||||
|
||||
.if !defined(LIBTCD_BUILDLINK3_MK)
|
||||
LIBTCD_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.libtcd+= libtcd>=2.2.7
|
||||
BUILDLINK_PKGSRCDIR.libtcd?= ../../databases/libtcd
|
||||
|
||||
.endif # LIBTCD_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -libtcd
|
7
databases/libtcd/distinfo
Normal file
7
databases/libtcd/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1 2020/01/10 16:57:24 plunky Exp $
|
||||
|
||||
SHA1 (libtcd-2.2.7-r2.tar.bz2) = 800cec12db681f60670a060cc69a9f44f46be4cf
|
||||
RMD160 (libtcd-2.2.7-r2.tar.bz2) = 0160b9af26aa22e2cbf74fc5ae05493238cd2eb6
|
||||
SHA512 (libtcd-2.2.7-r2.tar.bz2) = b67e5b3d43cc51cf7405db5d71bec0a33f884d1a5654b01d7cddf54e7614d3b8d05fafec133e2299ca4687ee9a74295dbd0281c2ddff36906c77cc930bad9ed4
|
||||
Size (libtcd-2.2.7-r2.tar.bz2) = 308959 bytes
|
||||
SHA1 (patch-configure) = 2209673c29636fd83026cf33fd7afe9bfaeaa67d
|
111
databases/libtcd/patches/patch-configure
Normal file
111
databases/libtcd/patches/patch-configure
Normal file
|
@ -0,0 +1,111 @@
|
|||
$NetBSD: patch-configure,v 1.1 2020/01/10 16:57:25 plunky Exp $
|
||||
|
||||
fix non-portable tests
|
||||
|
||||
--- configure.orig 2016-01-25 17:29:39.000000000 +0000
|
||||
+++ configure
|
||||
@@ -2373,7 +2373,7 @@ ver_COMPAT114=""
|
||||
# Check whether --enable-COMPAT114 was given.
|
||||
if test "${enable_COMPAT114+set}" = set; then :
|
||||
enableval=$enable_COMPAT114;
|
||||
- if test "$enable_COMPAT114" == yes; then :
|
||||
+ if test "$enable_COMPAT114" = yes; then :
|
||||
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: COMPAT114 is enabled!" >&5
|
||||
$as_echo "$as_me: WARNING: COMPAT114 is enabled!" >&2;}
|
||||
@@ -2400,7 +2400,7 @@ fi
|
||||
# Check whether --enable-lm_hard was given.
|
||||
if test "${enable_lm_hard+set}" = set; then :
|
||||
enableval=$enable_lm_hard;
|
||||
- if test "$enable_lm_hard" == yes; then :
|
||||
+ if test "$enable_lm_hard" = yes; then :
|
||||
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: Linking with libm_hard instead of libm." >&5
|
||||
$as_echo "$as_me: Linking with libm_hard instead of libm." >&6;}
|
||||
@@ -11760,17 +11760,17 @@ _ACEOF
|
||||
# header file that will work outside of autoconf. Evil: relying on
|
||||
# internals of autoconf macro definitions.
|
||||
|
||||
-if test "$ac_cv_header_sys_types_h" == yes; then :
|
||||
+if test "$ac_cv_header_sys_types_h" = yes; then :
|
||||
sub_systypes="#include <sys/types.h>"
|
||||
|
||||
else
|
||||
sub_systypes=""
|
||||
|
||||
fi
|
||||
-if test "$ac_cv_header_inttypes_h" == yes; then :
|
||||
+if test "$ac_cv_header_inttypes_h" = yes; then :
|
||||
sub_inttypes="#include <inttypes.h>"
|
||||
|
||||
-elif test "$ac_cv_header_stdint_h" == yes; then :
|
||||
+elif test "$ac_cv_header_stdint_h" = yes; then :
|
||||
sub_inttypes="#include <stdint.h>"
|
||||
|
||||
else
|
||||
@@ -11778,28 +11778,28 @@ else
|
||||
|
||||
fi
|
||||
|
||||
-if test "$ac_cv_c_int8_t" == yes; then :
|
||||
+if test "$ac_cv_c_int8_t" = yes; then :
|
||||
sub_int8_t="int8_t"
|
||||
|
||||
else
|
||||
sub_int8_t="$ac_cv_c_int8_t"
|
||||
|
||||
fi
|
||||
-if test "$ac_cv_c_int16_t" == yes; then :
|
||||
+if test "$ac_cv_c_int16_t" = yes; then :
|
||||
sub_int16_t="int16_t"
|
||||
|
||||
else
|
||||
sub_int16_t="$ac_cv_c_int16_t"
|
||||
|
||||
fi
|
||||
-if test "$ac_cv_c_int32_t" == yes; then :
|
||||
+if test "$ac_cv_c_int32_t" = yes; then :
|
||||
sub_int32_t="int32_t"
|
||||
|
||||
else
|
||||
sub_int32_t="$ac_cv_c_int32_t"
|
||||
|
||||
fi
|
||||
-if test "$ac_cv_c_int64_t" == yes; then :
|
||||
+if test "$ac_cv_c_int64_t" = yes; then :
|
||||
sub_int64_t="int64_t"
|
||||
|
||||
else
|
||||
@@ -11807,28 +11807,28 @@ else
|
||||
|
||||
fi
|
||||
|
||||
-if test "$ac_cv_c_uint8_t" == yes; then :
|
||||
+if test "$ac_cv_c_uint8_t" = yes; then :
|
||||
sub_uint8_t="uint8_t"
|
||||
|
||||
else
|
||||
sub_uint8_t="$ac_cv_c_uint8_t"
|
||||
|
||||
fi
|
||||
-if test "$ac_cv_c_uint16_t" == yes; then :
|
||||
+if test "$ac_cv_c_uint16_t" = yes; then :
|
||||
sub_uint16_t="uint16_t"
|
||||
|
||||
else
|
||||
sub_uint16_t="$ac_cv_c_uint16_t"
|
||||
|
||||
fi
|
||||
-if test "$ac_cv_c_uint32_t" == yes; then :
|
||||
+if test "$ac_cv_c_uint32_t" = yes; then :
|
||||
sub_uint32_t="uint32_t"
|
||||
|
||||
else
|
||||
sub_uint32_t="$ac_cv_c_uint32_t"
|
||||
|
||||
fi
|
||||
-if test "$ac_cv_c_uint64_t" == yes; then :
|
||||
+if test "$ac_cv_c_uint64_t" = yes; then :
|
||||
sub_uint64_t="uint64_t"
|
||||
|
||||
else
|
Loading…
Reference in a new issue