Update to 1.7.1. IIUC, this is the unstable branch, but AFAIK it is far more

stable than the last 1.6.1 version, and connects to a lot more servers, so here
is the update.

Version 1.7.1
-------------
Un-Thesis' Contributions:
   * FIXED: A bug that would cause approx 5% download sources to be deleted
     unnecessarily.
   * FIXED: aMule 1.1.2 bug in their ZLib implementation (look for "FIXME" in
     their code heh).
   * FIXED: Removed the undefined VoidList warning in mfc.cpp.
   * Added ZLIB support to xMule, based on aMule 1.1.1, which is based on eMule
     0.30c.
   * Changed target minimum speed for each upload from 3000 bytes/sec to
     2KB/sec.
   * Implemented nearly 100% of aMule-1,1,2's network modifications that worked.
   * Client now masquerades as eMule v0.34 heh.
   * Download list now refreshes in *real* time.  No more seconds delay.
   * Less waiting for downloads!  Fixed a broken if statement that was tossing
     out some of the early download connections.
DongCheon Park's contributions:
   * Updated the Korean translation files for new features in 1.7.x.

Version 1.7.0
-------------
Highlights:
   * There are no known exploits in this version.
   * Lots of fixed memleaks and cpuleaks.
   * Extended support for more eMule v3x protocol changes.
   * Enhanced transfer controls.
   * Supports every eDonkey server.
malware's contributions:
   * FIXED: endless loop in sending UDP packets.
   * FIXED: a possibly exploitable bug as noticed by S. Esser from e-matters
     (#3 "Servername Format String Vulnerabilities").
   * FIXED: new downloads assigned to random category.
   * FIXED: Bug rehashing a part file.
   * FIXED: Various minor problems found by malloc debuggers.
   * FIXED: Bug using MFC CMap.
   * Speed up the initial sharing by making KnowFileList a hash map.
   * Remove the assign to category context menu entry only if it was
     already there.
   * Reimplemented hashing thread.
   * Removed unused locks. As the NetBSD team pointed out they are
     causing problems on their system because it does core dump on
     unlocking a mutex that was not locked.
   * Made the title for systray the same as for the main dialog.
   * Never share a file twice.
   * Check size of OP_SERVERSTATUS packet more strictly.
   * Do not display the unit for file size twice in shared file list web page.
   * Make xmule not to send the MOD_VERSION information. This does avoid a
     problem with the LSD mod and other xmules.
   * Added check for libm to configure.in.
   * Avoid accepting an unrequested hashset.
   * Removed memory leak from hashing thread.
   * Implemented rescaling of the graph of currently active connections.
   * Remove invalid gap information entries which might be caused by
     incomplete part.met files.
   * Removed all font specifications from the XML resources.
   * Do not start a search after adding an ED2K-Link.
   * Enable clipping in download list control.
   * Possible fix for some problems while ending the program.
   * Keep the requested file in sync with the part status in CUpDownClient.
   * Imported from eMule:
       - Source exchange v2
       - Do not swap a source to a stopped file.
       - Up-/download auto-priority
       - Request of shared files by directory.
       - "Obtained Parts" bar in the shared files list
Un-Thesis' contributions:
   * FIXED: Bug that kept auto-backtrace from occuring in Linux.
   * FIXED: Rare crash occuring in Preferences->Directories.
   * FIXED: Optimization and compilation warnings using -O2 with GCC 3.3.x.
   * FIXED: Two memleaks in ClientCreditList.cpp.
   * FIXED: Several GCC 3.4 problems.
   * FIXED: Several Intel C++ problems.
   * Added more support for Solaris, thanks to wimms.
   * Corrected various Linux-specific #ifdefs.
   * Now masquerades as eMule v0.31 in order to use hostile eMule servers.
   * Added initial support for GCC 3.2+ AthlonXP optimizations.
   * Added initial support for wxGTK 2.5.1.
   * Two tweaks to make SuSE builds less CPU-intensive.
   * New build system, easier to maintain and automake free. Yay!
   * Streamlined included images: now only necessary ones are there.
   * Added initial support for JusSx's ed2k+ daemon.
   * Added initial support for Hetfield's systray daemon.
   * Added initial support for my telnet/ssh/www daemon.
NetBSD team's contributions:
   * FIXED: bug with the mutex protecting calls to gethostbyname.
   * Try to increase some resource limitation to the permitted maximum.
sepahewe's contributions:
   * Fix images in transfer list web page.
Justinas' contributions:
   * Fixed the mfc.h warnings at lines 418, 423,
This commit is contained in:
jmmv 2003-12-03 13:04:30 +00:00
parent cd00eed9c8
commit 020f7b1ddf
3 changed files with 28 additions and 5 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.9 2003/10/18 11:16:36 jmmv Exp $
# $NetBSD: Makefile,v 1.10 2003/12/03 13:04:30 jmmv Exp $
#
DISTNAME= xmule-1.6.1
DISTNAME= xmule-1.7.1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=xmule/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,4 +1,5 @@
$NetBSD: distinfo,v 1.6 2003/10/18 11:16:36 jmmv Exp $
$NetBSD: distinfo,v 1.7 2003/12/03 13:04:30 jmmv Exp $
SHA1 (xmule-1.6.1.tar.bz2) = 15d9d97b276fba3018deaa47589e19586eb26ba6
Size (xmule-1.6.1.tar.bz2) = 1250111 bytes
SHA1 (xmule-1.7.1.tar.bz2) = fe83f7cb540c5aab0cdfe956c455b29a180e85ad
Size (xmule-1.7.1.tar.bz2) = 1479298 bytes
SHA1 (patch-aa) = f704fcd8f0e29a825f6f019dffec42da12e0b673

View file

@ -0,0 +1,22 @@
$NetBSD: patch-aa,v 1.3 2003/12/03 13:04:30 jmmv Exp $
--- Makefile.in.orig 2003-11-13 02:15:54.000000000 +0100
+++ Makefile.in
@@ -55,9 +55,12 @@ distclean: clean
@rm -rf Compilation.flags Makefile aclocal.m4 autom4te.cache config.* configure depcomp intl
install: all
- @mkdir -p @bindir@
- @mkdir -p @datadir@/{applications,locale,pixmaps}
- @cp -f src/{ed2k,xmule} @bindir@
+ ${BSD_INSTALL_PROGRAM_DIR} @bindir@
+ ${BSD_INSTALL_DATA_DIR} @datadir@/applications
+ ${BSD_INSTALL_DATA_DIR} @datadir@/locale
+ ${BSD_INSTALL_DATA_DIR} @datadir@/pixmaps
+ ${BSD_INSTALL_PROGRAM} src/ed2k @bindir@
+ ${BSD_INSTALL_PROGRAM} src/xmule @bindir@
@cd po && $(MAKE) install
- @cp -f xmule.desktop @datadir@/applications
- @cp -f xmule.xpm @datadir@/pixmaps
+ ${BSD_INSTALL_DATA} xmule.desktop @datadir@/applications
+ ${BSD_INSTALL_DATA} xmule.xpm @datadir@/pixmaps