Use RbConfig instead of legacy Config.

This commit is contained in:
taca 2013-07-21 02:49:58 +00:00
parent a812b05aba
commit 0221d538ff
2 changed files with 10 additions and 6 deletions

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.2 2010/09/10 13:04:25 taca Exp $
$NetBSD: distinfo,v 1.3 2013/07/21 02:49:58 taca Exp $
SHA1 (div-1.3.2.tar.gz) = 22b4517c5101f522b0b801be80220da42423a94a
RMD160 (div-1.3.2.tar.gz) = 60c8fcc6675feaf93546f091adc64c103a8ea006
Size (div-1.3.2.tar.gz) = 86749 bytes
SHA1 (patch-aa) = 3624e7da6230d231b2a876221cd11a3983f77d61
SHA1 (patch-aa) = 054b2e9ce1deadc54c28af6431481899619fa01c

View file

@ -1,17 +1,21 @@
$NetBSD: patch-aa,v 1.1 2010/09/10 13:04:25 taca Exp $
$NetBSD: patch-aa,v 1.2 2013/07/21 02:49:58 taca Exp $
Avoid to use "ftools" which has deprecated in ruby19.
* Avoid to use "ftools" which has deprecated in ruby19.
* Use RbConfig instead of Config.
--- install.rb.orig 2003-08-13 15:18:29.000000000 +0000
+++ install.rb
@@ -1,6 +1,6 @@
@@ -1,8 +1,8 @@
require 'rbconfig'
require 'find'
-require 'ftools'
+require 'fileutils'
include Config
-include Config
+include RbConfig
$srcdir = CONFIG["srcdir"]
$version = CONFIG["MAJOR"]+"."+CONFIG["MINOR"]
@@ -30,12 +30,12 @@ def install_rb(srcdir = nil, destdir = $
for f in dir
next if f == "."