Update to 2.65. From the changelog:

* Fixed warnings caused by Python v2.6 (using hashlib, removing
    mimify, etc.)
* Deprecated QP_REQUIRED option as this is more than likely no
    longer needed and part of what triggered Python warnings
* Fixed unicode errors in certain post headers
* Attempted to incorporate Debian/Ubuntu patches into the mainstream
    release
* Support img type enclosures
* No file locking for SunOS
* Gracefully handle missing charsets
* Friendlier and more useful message if sendmail isn't installed
This commit is contained in:
schmonz 2009-04-07 04:41:18 +00:00
parent 8008e8556b
commit 022ebb7bf4
3 changed files with 10 additions and 23 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.22 2009/02/09 22:56:25 joerg Exp $
# $NetBSD: Makefile,v 1.23 2009/04/07 04:41:18 schmonz Exp $
#
DISTNAME= rss2email-2.63
PKGREVISION= 1
DISTNAME= rss2email-2.65
CATEGORIES= mail
MASTER_SITES= ${HOMEPAGE}
EXTRACT_SUFX= .py

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.16 2008/07/18 20:28:34 schmonz Exp $
$NetBSD: distinfo,v 1.17 2009/04/07 04:41:18 schmonz Exp $
SHA1 (rss2email-2.63.py) = e2224516218187fb3661749040dbd6f104a1109c
RMD160 (rss2email-2.63.py) = ad795e1276fb97803352223f3775744429069742
Size (rss2email-2.63.py) = 24594 bytes
SHA1 (patch-ad) = ce953548c05c764b8dff1a7f9cc6fb7c52acf166
SHA1 (rss2email-2.65.py) = 8fe6c6c1bfe56164fba64378fc1f0b8295b1b8d9
RMD160 (rss2email-2.65.py) = fcc0df8e47d81c495f7c7aa045672bc0eaf898ab
Size (rss2email-2.65.py) = 25874 bytes
SHA1 (patch-ad) = 6b3c7908eadbebca34cde9431d1d85b3761f5aad

View file

@ -1,20 +1,8 @@
$NetBSD: patch-ad,v 1.5 2008/02/19 10:33:05 schmonz Exp $
$NetBSD: patch-ad,v 1.6 2009/04/07 04:41:19 schmonz Exp $
--- rss2email.py.orig 2008-02-13 16:47:25.000000000 -0500
--- rss2email.py.orig 2009-04-05 13:43:25.000000000 -0400
+++ rss2email.py
@@ -188,6 +188,11 @@ def send(sender, recipient, subject, bod
i, o = os.popen2(["/usr/sbin/sendmail", recipient])
i.write(msg_as_string)
i.close(); o.close()
+ pid, status = os.wait()
+ if status != 0:
+ print >>warn, ""
+ print >>warn, ('Fatal error: sendmail exited with code %s' % status)
+ sys.exit(1)
del i, o
return None
@@ -230,6 +235,7 @@ import mimify; from StringIO import Stri
@@ -270,6 +270,7 @@ for e in ['error', 'gaierror']:
import feedparser
feedparser.USER_AGENT = "rss2email/"+__version__+ " +http://www.aaronsw.com/2002/rss2email/"