Fix LP64 warning in the runtime (missing headers for alloca) and

bump PKGREVISION.
This commit is contained in:
dholland 2012-07-21 22:01:17 +00:00
parent b8af6acf43
commit 0233dd4749
3 changed files with 18 additions and 2 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.10 2012/05/08 02:59:57 sbd Exp $
# $NetBSD: Makefile,v 1.11 2012/07/21 22:01:17 dholland Exp $
DISTNAME= g95_source
VERSION= 0.92
PKGREVISION= 1
PKGNAME= g95-${VERSION}
CATEGORIES= lang
EXTRACT_SUFX.g95_source= .tgz

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.9 2012/05/08 02:59:16 sbd Exp $
$NetBSD: distinfo,v 1.10 2012/07/21 22:01:17 dholland Exp $
SHA1 (g95-0.92/g95_source.tgz) = e6320fc80d8e388aad1fdbde53b2414353692b76
RMD160 (g95-0.92/g95_source.tgz) = ac00c4cdd6dc0b90ef865040ff338b7f2d9296d1
@ -17,3 +17,4 @@ SHA1 (patch-.._gcc-4.0.3_gcc_ginclude_stddef.h) = 5e18b132d36ca02dcfed0569297e7a
SHA1 (patch-ab) = 7275d8df3ba1621f3d496c386df999295f36f974
SHA1 (patch-ac) = cc6811bb7ef29d9388a40851c403f8768b6f9e48
SHA1 (patch-libf95.a-0.92_configure) = d17fc9fa66228489cfa5e49c23d4cfd32a91bfae
SHA1 (patch-libf95.a-0.92_io_atof.c) = cd45d03e68573fdadb8c9a217e7dc1eab0db8314

View file

@ -0,0 +1,14 @@
$NetBSD: patch-libf95.a-0.92_io_atof.c,v 1.1 2012/07/21 22:01:18 dholland Exp $
Needs stdlib.h on netbsd to get alloca() declaration.
--- libf95.a-0.92/io/atof.c~ 2009-04-22 17:44:56.000000000 +0000
+++ libf95.a-0.92/io/atof.c
@@ -2,6 +2,7 @@
+#include <stdlib.h>
#include <string.h>
#include "runtime.h"