Fix missing termios.h. Explicitly use pointer as guard value.

This commit is contained in:
joerg 2013-07-19 12:58:20 +00:00
parent b4466a6462
commit 024f318eb6
4 changed files with 35 additions and 7 deletions

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.2 2006/04/21 11:36:54 joerg Exp $
$NetBSD: distinfo,v 1.3 2013/07/19 12:58:20 joerg Exp $
SHA1 (mxterm_129.tar.gz) = 863732aa1096aac58f42f8f6c94c95bfa189aaf7
RMD160 (mxterm_129.tar.gz) = 67e40886f25c60752d94cdb3bda831baf1863eb9
Size (mxterm_129.tar.gz) = 743816 bytes
SHA1 (patch-aa) = 89d8fe342f26401463a2746efa621ae284147e0e
SHA1 (patch-ab) = 123581ccc1c0cc1a930fd49f24119f2686091d65
SHA1 (patch-ac) = 7ea09555918a4273a08abf05c39fad56ae7f3064
SHA1 (patch-Tekproc.c) = 28a411a3fcd4a098a60d7406958c9fd629035636
SHA1 (patch-aa) = 468366b780812910781265a163c5cfca66b20536
SHA1 (patch-ac) = 1e6f07eee31667c4ed17fdc40ffa92990be60f57

View file

@ -0,0 +1,13 @@
$NetBSD: patch-Tekproc.c,v 1.1 2013/07/19 12:58:20 joerg Exp $
--- Tekproc.c.orig 2013-07-19 10:49:52.000000000 +0000
+++ Tekproc.c
@@ -354,7 +354,7 @@ int TekInit (void)
XtNright, XawChainRight,
XtNbottom, XawChainBottom,
#endif
- 0);
+ (void *)0);
}
return (!Tfailed);
}

View file

@ -1,8 +1,14 @@
$NetBSD: patch-aa,v 1.2 2006/04/21 11:36:54 joerg Exp $
$NetBSD: patch-aa,v 1.3 2013/07/19 12:58:20 joerg Exp $
--- main.c.orig 2005-05-09 01:14:32.000000000 +0000
+++ main.c
@@ -90,6 +90,11 @@ SOFTWARE.
@@ -85,11 +85,17 @@ SOFTWARE.
#include <pwd.h>
#include <ctype.h>
+#include <termios.h>
#include <data.h>
#include <error.h>
#include <menu.h>

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ac,v 1.1.1.1 2005/10/28 02:52:33 minskim Exp $
$NetBSD: patch-ac,v 1.2 2013/07/19 12:58:20 joerg Exp $
--- Makefile.in.orig 2004-11-05 18:53:48.000000000 -0700
+++ Makefile.in 2004-11-05 20:50:47.000000000 -0700
@ -14,3 +14,12 @@ $NetBSD: patch-ac,v 1.1.1.1 2005/10/28 02:52:33 minskim Exp $
IMAKE_CFLAGS = @IMAKE_CFLAGS@
EXTRA_CFLAGS = @EXTRA_CFLAGS@
@@ -30,7 +30,7 @@
manext = 1
bindir = $(exec_prefix)/bin
libdir = $(exec_prefix)/lib
-mandir = $(prefix)/share/man/man$(manext)
+mandir = $(prefix)/man/man$(manext)
appsdir = $(libdir)/X11/app-defaults
#### End of system configuration section. ####