Treat NetBSD, FreeBSD, and OpenBSD uniformly.

This fixes build on FreeBSD 10 (tested by Youri Mouton) and 9.1.
This commit is contained in:
asau 2014-03-24 20:42:11 +00:00
parent 8d4a4e92f9
commit 02945bc9a3
2 changed files with 27 additions and 16 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.56 2014/03/22 08:39:10 markd Exp $
$NetBSD: distinfo,v 1.57 2014/03/24 20:42:11 asau Exp $
SHA1 (cmake-2.8.12.2.tar.gz) = cca70b307aa32a6a32c72e01fdfcecc84c1c2690
RMD160 (cmake-2.8.12.2.tar.gz) = ee92327c3870f3ae2ea997d0258b0ef141e90525
@ -7,7 +7,7 @@ SHA1 (patch-CMakeLists.txt) = a37825ad9d1704b9cb716a52148c637d26733898
SHA1 (patch-Modules_FindFreetype.cmake) = 7868ab96cadc011ccb16205382a3cbfa3d159f32
SHA1 (patch-Modules_FindX11.cmake) = e5c9f5fd382effb85ae75fe603de00e5e58d788a
SHA1 (patch-Modules_Platform_SunOS.cmake) = 7a53ae3c902dd69ee22ef9fe0ae2a022d5284f16
SHA1 (patch-Source_kwsys_SystemInformation.cxx) = ee7f56c0f9c4c096e8b7488c7f34cb32ae02a047
SHA1 (patch-Source_kwsys_SystemInformation.cxx) = 93c66c53dbf91198223d8358cb2da6b8e4b5ece3
SHA1 (patch-Utilities_KWIML_CMakeLists.txt) = 4e8cef0eab2ad8cb27cd7076e077bb5e7425a95c
SHA1 (patch-aa) = 97bfad3d2c357e9af01677ba86057b78f0661b9b
SHA1 (patch-ab) = aee3fb2f908aed1ce6e92b7c7ccf5b06f0596502

View file

@ -1,22 +1,33 @@
$NetBSD: patch-Source_kwsys_SystemInformation.cxx,v 1.5 2013/10/25 10:49:23 obache Exp $
$NetBSD: patch-Source_kwsys_SystemInformation.cxx,v 1.6 2014/03/24 20:42:11 asau Exp $
* Add more conditional handling for NetBSD, same as others.
* Treat FreeBSD the same way as NetBSD and OpenBSD.
* Treat Solaris same as Linux.
* Use correct cmake define.
--- Source/kwsys/SystemInformation.cxx.orig 2013-10-07 15:31:00.000000000 +0000
--- Source/kwsys/SystemInformation.cxx.orig 2014-01-16 17:15:08.000000000 +0000
+++ Source/kwsys/SystemInformation.cxx
@@ -93,6 +93,22 @@ typedef int siginfo_t;
#if defined(__OpenBSD__) || defined(__NetBSD__)
# include <sys/param.h>
@@ -78,9 +78,9 @@ typedef int siginfo_t;
# include <errno.h> // extern int errno;
#endif
-#ifdef __FreeBSD__
+#if defined(__OpenBSD__) || defined(__NetBSD__) || defined(__FreeBSD__)
+# include <sys/param.h>
# include <sys/sysctl.h>
+# include <sys/socket.h>
+# include <netdb.h>
+# include <netinet/in.h>
+# if defined(KWSYS_SYS_HAS_IFADDRS_H)
+# include <ifaddrs.h>
+# define KWSYS_SYSTEMINFORMATION_IMPLEMENT_FQDN
+# endif
-# include <fenv.h>
# include <sys/socket.h>
# include <netdb.h>
# include <netinet/in.h>
@@ -88,11 +88,15 @@ typedef int siginfo_t;
# include <ifaddrs.h>
# define KWSYS_SYSTEMINFORMATION_IMPLEMENT_FQDN
# endif
-#endif
-
-#if defined(__OpenBSD__) || defined(__NetBSD__)
-# include <sys/param.h>
-# include <sys/sysctl.h>
+# if defined(KWSYS_SYSTEMINFORMATION_HAS_BACKTRACE)
+# include <execinfo.h>
+# if defined(KWSYS_SYSTEMINFORMATION_HAS_CPP_DEMANGLE)
@ -29,7 +40,7 @@ $NetBSD: patch-Source_kwsys_SystemInformation.cxx,v 1.5 2013/10/25 10:49:23 obac
#endif
#if defined(KWSYS_SYS_HAS_MACHINE_CPU_H)
@@ -130,7 +146,7 @@ typedef int siginfo_t;
@@ -130,7 +134,7 @@ typedef int siginfo_t;
# endif
#endif
@ -38,7 +49,7 @@ $NetBSD: patch-Source_kwsys_SystemInformation.cxx,v 1.5 2013/10/25 10:49:23 obac
# include <fenv.h>
# include <sys/socket.h>
# include <netdb.h>
@@ -4616,7 +4632,7 @@ bool SystemInformationImplementation::Qu
@@ -4616,7 +4620,7 @@ bool SystemInformationImplementation::Qu
// a 32 bit process on a 64 bit host the returned memory will be
// limited to 4GiB. So if this is a 32 bit process or if the sysconf
// method fails use the kstat interface.