Add audio/musescore.
MuseScore is an open source and free music notation software. Features: * WYSIWYG design, notes are entered on a "virtual notepaper" * TrueType font(s) for printing & display allows for high quality scaling to all sizes * Easy & fast note entry * Many editing functions * MusicXML import/export * MIDI (SMF) import/export * MuseData import * MIDI input for note entry * Integrated sequencer and software synthesizer to play the score * Print or create pdf files
This commit is contained in:
parent
ff1449e8df
commit
02ae861221
7 changed files with 282 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.571 2019/10/16 11:24:16 nia Exp $
|
||||
# $NetBSD: Makefile,v 1.572 2019/10/16 23:22:08 nia Exp $
|
||||
#
|
||||
|
||||
COMMENT= Audio tools
|
||||
|
@ -342,6 +342,7 @@ SUBDIR+= mstream
|
|||
SUBDIR+= mt-daapd
|
||||
SUBDIR+= muse
|
||||
SUBDIR+= musepack
|
||||
SUBDIR+= musescore
|
||||
SUBDIR+= musicbrainz
|
||||
SUBDIR+= musicpd
|
||||
SUBDIR+= nas
|
||||
|
|
15
audio/musescore/DESCR
Normal file
15
audio/musescore/DESCR
Normal file
|
@ -0,0 +1,15 @@
|
|||
MuseScore is an open source and free music notation software.
|
||||
|
||||
Features:
|
||||
|
||||
* WYSIWYG design, notes are entered on a "virtual notepaper"
|
||||
* TrueType font(s) for printing & display allows for high quality scaling
|
||||
to all sizes
|
||||
* Easy & fast note entry
|
||||
* Many editing functions
|
||||
* MusicXML import/export
|
||||
* MIDI (SMF) import/export
|
||||
* MuseData import
|
||||
* MIDI input for note entry
|
||||
* Integrated sequencer and software synthesizer to play the score
|
||||
* Print or create pdf files
|
46
audio/musescore/Makefile
Normal file
46
audio/musescore/Makefile
Normal file
|
@ -0,0 +1,46 @@
|
|||
# $NetBSD: Makefile,v 1.1 2019/10/16 23:22:08 nia Exp $
|
||||
|
||||
DISTNAME= musescore-3.2.3
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=musescore/}
|
||||
GITHUB_PROJECT= MuseScore
|
||||
GITHUB_TAG= v${PKGVERSION_NOREV}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= https://musescore.org/
|
||||
COMMENT= Music notation and composition software
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
USE_CMAKE= yes
|
||||
USE_TOOLS+= pkg-config
|
||||
USE_LANGUAGES= c c++11
|
||||
|
||||
# C++11
|
||||
GCC_REQD+= 4.7
|
||||
|
||||
CONFIGURE_DIRS= bindir
|
||||
CMAKE_ARG_PATH= ..
|
||||
|
||||
CMAKE_ARGS+= -Wno-dev
|
||||
CMAKE_ARGS+= -DCMAKE_BUILD_TYPE="Release"
|
||||
CMAKE_ARGS+= -DUSE_SYSTEM_FREETYPE=ON
|
||||
CMAKE_ARGS+= -DDOWNLOAD_SOUNDFONT=OFF
|
||||
CMAKE_ARGS+= -DBUILD_PCH=OFF
|
||||
CMAKE_ARGS+= -DBUILD_PORTMIDI=OFF
|
||||
CMAKE_ARGS+= -DBUILD_WEBENGINE=OFF
|
||||
|
||||
pre-configure:
|
||||
${MKDIR} ${WRKSRC}/bindir
|
||||
|
||||
.include "options.mk"
|
||||
.include "../../audio/lame/buildlink3.mk"
|
||||
.include "../../audio/libsndfile/buildlink3.mk"
|
||||
.include "../../audio/libvorbis/buildlink3.mk"
|
||||
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
|
||||
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
|
||||
.include "../../x11/qt5-qtbase/buildlink3.mk"
|
||||
.include "../../x11/qt5-qtdeclarative/buildlink3.mk"
|
||||
.include "../../x11/qt5-qtsvg/buildlink3.mk"
|
||||
.include "../../x11/qt5-qttools/buildlink3.mk"
|
||||
.include "../../x11/qt5-qtxmlpatterns/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
123
audio/musescore/PLIST
Normal file
123
audio/musescore/PLIST
Normal file
|
@ -0,0 +1,123 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2019/10/16 23:22:08 nia Exp $
|
||||
bin/mscore
|
||||
bin/musescore
|
||||
man/man1/mscore.1
|
||||
man/man1/musescore.1
|
||||
share/applications/mscore.desktop
|
||||
share/icons/hicolor/128x128/apps/mscore.png
|
||||
share/icons/hicolor/16x16/apps/mscore.png
|
||||
share/icons/hicolor/24x24/apps/mscore.png
|
||||
share/icons/hicolor/32x32/apps/mscore.png
|
||||
share/icons/hicolor/48x48/apps/mscore.png
|
||||
share/icons/hicolor/48x48/mimetypes/application-vnd.recordare.musicxml+xml.png
|
||||
share/icons/hicolor/48x48/mimetypes/application-vnd.recordare.musicxml.png
|
||||
share/icons/hicolor/48x48/mimetypes/application-x-musescore+xml.png
|
||||
share/icons/hicolor/48x48/mimetypes/application-x-musescore.png
|
||||
share/icons/hicolor/512x512/apps/mscore.png
|
||||
share/icons/hicolor/64x64/apps/mscore.png
|
||||
share/icons/hicolor/96x96/apps/mscore.png
|
||||
share/icons/hicolor/scalable/apps/mscore.svg
|
||||
share/icons/hicolor/scalable/mimetypes/application-vnd.recordare.musicxml+xml.svg
|
||||
share/icons/hicolor/scalable/mimetypes/application-vnd.recordare.musicxml.svg
|
||||
share/icons/hicolor/scalable/mimetypes/application-x-musescore+xml.svg
|
||||
share/icons/hicolor/scalable/mimetypes/application-x-musescore.svg
|
||||
share/metainfo/org.musescore.MuseScore.appdata.xml
|
||||
share/mime/packages/musescore.xml
|
||||
share/mscore-3.2/demos/Brassed_Up.mscx
|
||||
share/mscore-3.2/demos/Dynamic_Strings.mscx
|
||||
share/mscore-3.2/demos/Fugue_1.mscx
|
||||
share/mscore-3.2/demos/Reunion.mscz
|
||||
share/mscore-3.2/demos/Unclaimed_Gift.mscx
|
||||
share/mscore-3.2/instruments/instruments.xml
|
||||
share/mscore-3.2/locale/languages.xml
|
||||
share/mscore-3.2/manual/plugins/manual.css
|
||||
share/mscore-3.2/manual/plugins/plugins3.html
|
||||
share/mscore-3.2/plugins/abc_import.qml
|
||||
share/mscore-3.2/plugins/colornotes.qml
|
||||
share/mscore-3.2/plugins/createscore.qml
|
||||
share/mscore-3.2/plugins/helloqml/helloqml.qml
|
||||
share/mscore-3.2/plugins/helloqml/translations/locale_de.qm
|
||||
share/mscore-3.2/plugins/helloqml/translations/locale_de.ts
|
||||
share/mscore-3.2/plugins/notenames.qml
|
||||
share/mscore-3.2/plugins/panel.qml
|
||||
share/mscore-3.2/plugins/random.qml
|
||||
share/mscore-3.2/plugins/random2.qml
|
||||
share/mscore-3.2/plugins/run.qml
|
||||
share/mscore-3.2/plugins/scorelist.qml
|
||||
share/mscore-3.2/plugins/view.qml
|
||||
share/mscore-3.2/plugins/walk.qml
|
||||
share/mscore-3.2/sound/MuseScore_General.sf3
|
||||
share/mscore-3.2/sound/MuseScore_General_License.md
|
||||
share/mscore-3.2/styles/MuseJazz.mss
|
||||
share/mscore-3.2/styles/cchords_muse.xml
|
||||
share/mscore-3.2/styles/cchords_nrb.xml
|
||||
share/mscore-3.2/styles/cchords_rb.xml
|
||||
share/mscore-3.2/styles/cchords_sym.xml
|
||||
share/mscore-3.2/styles/chords.xml
|
||||
share/mscore-3.2/styles/chords_jazz.xml
|
||||
share/mscore-3.2/styles/chords_std.xml
|
||||
share/mscore-3.2/styles/jazzchords.xml
|
||||
share/mscore-3.2/styles/stdchords.xml
|
||||
share/mscore-3.2/templates/01-General/00-Blank.mscx
|
||||
share/mscore-3.2/templates/01-General/01-Treble_Clef.mscx
|
||||
share/mscore-3.2/templates/01-General/02-Bass_Clef.mscx
|
||||
share/mscore-3.2/templates/01-General/03-Grand_Staff.mscx
|
||||
share/mscore-3.2/templates/02-Choral/01-SATB.mscx
|
||||
share/mscore-3.2/templates/02-Choral/02-SATB_+_Organ.mscx
|
||||
share/mscore-3.2/templates/02-Choral/03-SATB_+_Piano.mscx
|
||||
share/mscore-3.2/templates/02-Choral/04-SATB_Closed_Score.mscx
|
||||
share/mscore-3.2/templates/02-Choral/05-SATB_Closed_Score_+_Organ.mscx
|
||||
share/mscore-3.2/templates/02-Choral/06-SATB_Closed_Score_+_Piano.mscx
|
||||
share/mscore-3.2/templates/02-Choral/07-Voice_+_Piano.mscx
|
||||
share/mscore-3.2/templates/02-Choral/08-Barbershop_Quartet.mscx
|
||||
share/mscore-3.2/templates/02-Choral/09-Liturgical_Unmetrical.mscx
|
||||
share/mscore-3.2/templates/02-Choral/10-Liturgical_Unmetrical_+_Organ.mscx
|
||||
share/mscore-3.2/templates/03-Chamber_Music/01-String_Quartet.mscx
|
||||
share/mscore-3.2/templates/03-Chamber_Music/02-Wind_Quartet.mscx
|
||||
share/mscore-3.2/templates/03-Chamber_Music/03-Wind_Quintet.mscx
|
||||
share/mscore-3.2/templates/03-Chamber_Music/04-Saxophone_Quartet.mscx
|
||||
share/mscore-3.2/templates/03-Chamber_Music/05-Brass_Quartet.mscx
|
||||
share/mscore-3.2/templates/03-Chamber_Music/06-Brass_Quintet.mscx
|
||||
share/mscore-3.2/templates/04-Solo/01-Guitar.mscx
|
||||
share/mscore-3.2/templates/04-Solo/02-Guitar_+_Tablature.mscx
|
||||
share/mscore-3.2/templates/04-Solo/03-Guitar_Tablature.mscx
|
||||
share/mscore-3.2/templates/04-Solo/04-Piano.mscx
|
||||
share/mscore-3.2/templates/05-Jazz/01-Jazz_Lead_Sheet.mscx
|
||||
share/mscore-3.2/templates/05-Jazz/02-Big_Band.mscx
|
||||
share/mscore-3.2/templates/05-Jazz/03-Jazz_Combo.mscx
|
||||
share/mscore-3.2/templates/06-Popular/01-Rock_Band.mscx
|
||||
share/mscore-3.2/templates/06-Popular/02-Bluegrass_Band.mscx
|
||||
share/mscore-3.2/templates/07-Band_and_Percussion/01-Concert_Band.mscx
|
||||
share/mscore-3.2/templates/07-Band_and_Percussion/02-Small_Concert_Band.mscx
|
||||
share/mscore-3.2/templates/07-Band_and_Percussion/03-Brass_Band.mscx
|
||||
share/mscore-3.2/templates/07-Band_and_Percussion/04-Marching_Band.mscx
|
||||
share/mscore-3.2/templates/07-Band_and_Percussion/05-Small_Marching_Band.mscx
|
||||
share/mscore-3.2/templates/07-Band_and_Percussion/06-Battery_Percussion.mscx
|
||||
share/mscore-3.2/templates/07-Band_and_Percussion/07-Large_Pit_Percussion.mscx
|
||||
share/mscore-3.2/templates/07-Band_and_Percussion/08-Small_Pit_Percussion.mscx
|
||||
share/mscore-3.2/templates/07-Band_and_Percussion/09-European_Concert_Band.mscx
|
||||
share/mscore-3.2/templates/08-Orchestral/01-Classical_Orchestra.mscx
|
||||
share/mscore-3.2/templates/08-Orchestral/02-Symphony_Orchestra.mscx
|
||||
share/mscore-3.2/templates/08-Orchestral/03-String_Orchestra.mscx
|
||||
share/mscore-3.2/templates/drumset_fr.drm
|
||||
share/mscore-3.2/templates/orchestral.drm
|
||||
share/mscore-3.2/tours/autoplace.tour
|
||||
share/mscore-3.2/tours/inspector.tour
|
||||
share/mscore-3.2/tours/mmrest.tour
|
||||
share/mscore-3.2/tours/navigate.tour
|
||||
share/mscore-3.2/tours/noteinput.tour
|
||||
share/mscore-3.2/tours/palette.tour
|
||||
share/mscore-3.2/tours/select.tour
|
||||
share/mscore-3.2/tours/spanner-drop-apply.tour
|
||||
share/mscore-3.2/tours/timeline.tour
|
||||
share/mscore-3.2/tours/welcome.tour
|
||||
share/mscore-3.2/wallpaper/background1.png
|
||||
share/mscore-3.2/wallpaper/paper1.png
|
||||
share/mscore-3.2/wallpaper/paper2.png
|
||||
share/mscore-3.2/wallpaper/paper3.png
|
||||
share/mscore-3.2/wallpaper/paper4.png
|
||||
share/mscore-3.2/wallpaper/paper5.png
|
||||
share/mscore-3.2/wallpaper/paper6.png
|
||||
share/mscore-3.2/wallpaper/paper7.png
|
||||
share/mscore-3.2/workspaces/Advanced.workspace
|
||||
share/mscore-3.2/workspaces/Basic.workspace
|
7
audio/musescore/distinfo
Normal file
7
audio/musescore/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1 2019/10/16 23:22:08 nia Exp $
|
||||
|
||||
SHA1 (musescore-3.2.3.tar.gz) = b802c9d78ea53277fddd22f033c284b90e6b037b
|
||||
RMD160 (musescore-3.2.3.tar.gz) = a447ed0929b43fbb66699e4889854b45b1cf61ba
|
||||
SHA512 (musescore-3.2.3.tar.gz) = 3245cb14b2230703e63689df0021813be9fb234aa03433defd0de22640468daa9b3c4f5c7e276faac993ebb80e4431e56cd915eab983ba7dd3e85c822b4573d2
|
||||
Size (musescore-3.2.3.tar.gz) = 63932000 bytes
|
||||
SHA1 (patch-CMakeLists.txt) = 220fa5d8b68fbead76d8bed41e03b9133f59f3cc
|
42
audio/musescore/options.mk
Normal file
42
audio/musescore/options.mk
Normal file
|
@ -0,0 +1,42 @@
|
|||
# $NetBSD: options.mk,v 1.1 2019/10/16 23:22:08 nia Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.musescore
|
||||
PKG_SUPPORTED_OPTIONS= alsa jack portaudio pulseaudio
|
||||
|
||||
.include "../../mk/bsd.fast.prefs.mk"
|
||||
|
||||
.if ${OPSYS} == "Linux"
|
||||
PKG_SUGGESTED_OPTIONS= alsa
|
||||
.else
|
||||
PKG_SUGGESTED_OPTIONS= portaudio
|
||||
.endif
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
.if !empty(PKG_OPTIONS:Malsa)
|
||||
CMAKE_ARGS+= -DBUILD_ALSA=ON
|
||||
.include "../../audio/alsa-lib/buildlink3.mk"
|
||||
.else
|
||||
CMAKE_ARGS+= -DBUILD_ALSA=OFF
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mjack)
|
||||
CMAKE_ARGS+= -DBUILD_JACK=ON
|
||||
.include "../../audio/jack/buildlink3.mk"
|
||||
.else
|
||||
CMAKE_ARGS+= -DBUILD_JACK=OFF
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mportaudio)
|
||||
CMAKE_ARGS+= -DBUILD_PORTAUDIO=ON
|
||||
.include "../../audio/portaudio-devel/buildlink3.mk"
|
||||
.else
|
||||
CMAKE_ARGS+= -DBUILD_PORTAUDIO=OFF
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mpulseaudio)
|
||||
CMAKE_ARGS+= -DBUILD_PULSEAUDIO=ON
|
||||
.include "../../audio/pulseaudio/buildlink3.mk"
|
||||
.else
|
||||
CMAKE_ARGS+= -DBUILD_PULSEAUDIO=OFF
|
||||
.endif
|
47
audio/musescore/patches/patch-CMakeLists.txt
Normal file
47
audio/musescore/patches/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,47 @@
|
|||
$NetBSD: patch-CMakeLists.txt,v 1.1 2019/10/16 23:22:08 nia Exp $
|
||||
|
||||
Never compress man pages.
|
||||
|
||||
Use CMAKE_INSTALL_MANDIR.
|
||||
|
||||
--- CMakeLists.txt.orig 2019-07-06 09:44:00.000000000 +0000
|
||||
+++ CMakeLists.txt
|
||||
@@ -663,7 +663,7 @@ if (NOT MINGW AND NOT MSVC AND NOT APPLE
|
||||
# Compress man pages if gzip is installed (don't on OpenBSD)
|
||||
# Note: Compressing man pages is normal on Linux but not OpenBSD
|
||||
find_program( GZIP_EXECUTABLE gzip DOC "A tool for compressing manpages (optional)." )
|
||||
- if (GZIP_EXECUTABLE AND NOT CMAKE_SYSTEM_NAME MATCHES "OpenBSD")
|
||||
+ if (FALSE)
|
||||
message(STATUS "Found 'gzip'. Man pages will be compressed.")
|
||||
set(MAN_TARGET ${MAN_BUILD})
|
||||
set(MAN_EXTENSION ${MAN_EXTENSION}.gz)
|
||||
@@ -680,7 +680,7 @@ if (NOT MINGW AND NOT MSVC AND NOT APPLE
|
||||
COMMAND echo "Man pages have been compressed ready for installation."
|
||||
VERBATIM
|
||||
)
|
||||
- else (GZIP_EXECUTABLE AND NOT CMAKE_SYSTEM_NAME MATCHES "OpenBSD")
|
||||
+ else (FALSE)
|
||||
if (CMAKE_SYSTEM_NAME MATCHES "OpenBSD")
|
||||
message(STATUS "System is OpenBSD: Man pages will not be compressed.")
|
||||
else (CMAKE_SYSTEM_NAME MATCHES "OpenBSD")
|
||||
@@ -690,9 +690,9 @@ if (NOT MINGW AND NOT MSVC AND NOT APPLE
|
||||
COMMAND echo "Man pages will be installed uncompressed."
|
||||
VERBATIM
|
||||
)
|
||||
- endif (GZIP_EXECUTABLE AND NOT CMAKE_SYSTEM_NAME MATCHES "OpenBSD")
|
||||
+ endif (FALSE)
|
||||
# Install man pages in either compressed or uncompressed form
|
||||
- install( FILES ${MAN_BUILD} DESTINATION share/man/man1 COMPONENT doc)
|
||||
+ install( FILES ${MAN_BUILD} DESTINATION ${CMAKE_INSTALL_MANDIR}/man1 COMPONENT doc)
|
||||
# Create symlink alias for man pages so `man musescore` = `man mscore`
|
||||
find_program( LN_EXECUTABLE ln DOC "A tool for creating symbolic link aliases (optional)." )
|
||||
if (LN_EXECUTABLE)
|
||||
@@ -703,7 +703,7 @@ if (NOT MINGW AND NOT MSVC AND NOT APPLE
|
||||
COMMAND ${LN_EXECUTABLE} -sf "${MAN_FULL_NAME}" "${MAN_FULL_ALIAS}"
|
||||
COMMAND echo 'Symlink alias: ${MAN_FULL_ALIAS} -> ${MAN_FULL_NAME}'
|
||||
)
|
||||
- install( FILES ${PROJECT_BINARY_DIR}/${MAN_FULL_ALIAS} DESTINATION share/man/man1 COMPONENT doc)
|
||||
+ install( FILES ${PROJECT_BINARY_DIR}/${MAN_FULL_ALIAS} DESTINATION ${CMAKE_INSTALL_MANDIR}/man1 COMPONENT doc)
|
||||
else (LN_EXECUTABLE)
|
||||
message(STATUS "'ln' not found (it is optional). No symlink aliases will be created.")
|
||||
endif (LN_EXECUTABLE)
|
Loading…
Reference in a new issue