Add support for __aarch64__
Bump PKGREVISION.
This commit is contained in:
parent
34c14a06e7
commit
02e0049ea6
3 changed files with 18 additions and 6 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.23 2016/09/04 21:33:53 dholland Exp $
|
||||
# $NetBSD: Makefile,v 1.24 2016/09/17 17:49:36 richard Exp $
|
||||
|
||||
DISTNAME= imake-1.0.7
|
||||
PKGREVISION= 2
|
||||
PKGREVISION= 3
|
||||
CATEGORIES= x11 devel
|
||||
MASTER_SITES= ${MASTER_SITE_XORG:=util/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.14 2016/09/04 21:33:53 dholland Exp $
|
||||
$NetBSD: distinfo,v 1.15 2016/09/17 17:49:36 richard Exp $
|
||||
|
||||
SHA1 (imake-1.0.7.tar.bz2) = 52e236776133f217d438622034b8603d201a6ec5
|
||||
RMD160 (imake-1.0.7.tar.bz2) = 7a8d7b830463c1c429a8ad8349324e607ea255fb
|
||||
SHA512 (imake-1.0.7.tar.bz2) = b3527c8fead25c6e093e1fe4a39e60ff210212dcd323e206505b9e872a3f36d9db85f85cab5a6f0fa914fa5c558ef54b499b2b13ccd66739223e4e72ef805d08
|
||||
Size (imake-1.0.7.tar.bz2) = 156543 bytes
|
||||
SHA1 (patch-imake.c) = b5a2b60288de82aab7db0ef6ab218c42490bc10f
|
||||
SHA1 (patch-imakemdep.h) = a8aa1adff501da7eb22d695ff93f0517ce146269
|
||||
SHA1 (patch-imakemdep.h) = c41c80360c5ea91a19d1b5e6c32dfebd5ec66ff6
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-imakemdep.h,v 1.5 2013/07/23 06:48:21 wiz Exp $
|
||||
$NetBSD: patch-imakemdep.h,v 1.6 2016/09/17 17:49:36 richard Exp $
|
||||
|
||||
- Configure for pkgsrc: never set FIXUP_CPP_WHITESPACE as pkgsrc now
|
||||
always uses a whitespace-preserving cpp and fixing it twice causes
|
||||
|
@ -12,7 +12,9 @@ via RAWCPP defined on the command line.
|
|||
- Do not pass -m32 to cpp; it is not portable, valid, or even a
|
||||
reasonable thing to do.
|
||||
|
||||
--- imakemdep.h.orig 2013-07-23 04:53:04.000000000 +0000
|
||||
- Add support for __aarch64__
|
||||
|
||||
--- imakemdep.h.orig 2013-08-17 10:11:06.000000000 +0000
|
||||
+++ imakemdep.h
|
||||
@@ -229,7 +229,7 @@ in this Software without prior written a
|
||||
* all colons). One way to tell if you need this is to see whether or not
|
||||
|
@ -123,3 +125,13 @@ reasonable thing to do.
|
|||
# endif
|
||||
# ifdef __i486__
|
||||
"-D__i486__",
|
||||
@@ -399,6 +324,9 @@ const char *cpp_argv[ARGUMENTS] = {
|
||||
# ifdef __arm__
|
||||
"-D__arm__",
|
||||
# endif
|
||||
+# ifdef __aarch64__
|
||||
+ "-D__aarch64__",
|
||||
+# endif
|
||||
# ifdef __s390x__
|
||||
"-D__s390x__",
|
||||
# endif
|
||||
|
|
Loading…
Reference in a new issue