Update to version 0.9.2.

Changes since last packaged version below.

Version 0.9.2 - 9 August 2003
-----------------------------
- Header includes additions, in order to build without warning/errors on
  systems that do not conform to IEEE Std 1003.1-2001 (POSIX.1).

Version 0.9.1 - 8 August 2003
-----------------------------
- Bug fixes related to compilation warnings/errors caused by missing header
  includes.
- Minor bug fix concerning an uninitialized variable.

Version 0.9 - 6 August 2003
---------------------------
- User authentication with the Challenge-Response Authentication Mechanism
  (CRAM), specifically CRAM-MD5.
- Connection encryption using the IMAP STARTTLS extension.
- X509 certificate checking while establishing SSL/TLS connections.
- I18n support in the configuration file, along with the capability to specify
  the character set of the search criteria.
- Date conversion specifiers in the name of the destination mailbox, based on
  either the system's local time or the message's envelope "Date:" header.
- Default variable in the name of the destination mailbox, which expands to the
  mailbox currently processed.
- In daemon mode, the SIGUSR1 signal wakes up the program from its sleep phase
  and causes rereading of the configuration file.

Version 0.8.9 - 26 May 2003
---------------------------
- Fix of a bug which caused problems during the encryption/decryption of the
  passwords file.

Version 0.8.8 - 25 May 2003
---------------------------
- Multiple bug fixes concerning the encrypted passwords editor, where in some
  cases the passwords file was badly written and the program did not accept the
  master passphrase.
This commit is contained in:
seb 2003-08-23 20:52:57 +00:00
parent 3cd772e1a3
commit 02e04465e4
3 changed files with 24 additions and 19 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.7 2003/07/17 21:46:17 grant Exp $
# $NetBSD: Makefile,v 1.8 2003/08/23 20:52:57 seb Exp $
DISTNAME= imapfilter-0.8.7
DISTNAME= imapfilter-0.9.2
CATEGORIES= mail
MASTER_SITES= http://imapfilter.hellug.gr/source/
@ -10,6 +10,9 @@ COMMENT= Mail filtering utility for the IMAP
USE_BUILDLINK2= # defined
CFLAGS+= -I${BUILDLINK_PREFIX.openssl}/include
LDFLAGS+= -L${BUILDLINK_PREFIX.openssl}/lib -Wl,${RPATH_FLAG}${BUILDLINK_PREFIX.openssl}/lib
post-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/imapfilter
${INSTALL_DATA} ${WRKSRC}/sample.imapfilterrc \

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.6 2003/04/08 23:15:50 seb Exp $
$NetBSD: distinfo,v 1.7 2003/08/23 20:52:57 seb Exp $
SHA1 (imapfilter-0.8.7.tar.gz) = 3ca7b927ee1fcc29f9c9df7931ed7a3255c315a6
Size (imapfilter-0.8.7.tar.gz) = 37769 bytes
SHA1 (patch-aa) = 399b33a3b64acddb3da4143466e3cd14b81d6c74
SHA1 (imapfilter-0.9.2.tar.gz) = 233b0c369e5ea2d4b2359484e8749b69def8b8a0
Size (imapfilter-0.9.2.tar.gz) = 44690 bytes
SHA1 (patch-aa) = d3c30e01d4490e7bb54efad1b8e941c17be322f3

View file

@ -1,10 +1,11 @@
$NetBSD: patch-aa,v 1.3 2002/12/01 15:38:34 seb Exp $
$NetBSD: patch-aa,v 1.4 2003/08/23 20:52:58 seb Exp $
--- Makefile.orig Sat Nov 9 14:36:30 2002
--- Makefile.orig 2003-08-08 12:55:55.000000000 +0000
+++ Makefile
@@ -1,9 +1,6 @@
@@ -1,10 +1,6 @@
-CC = cc
-CFLAGS = -O
-LDFLAGS =
-
-DESTDIR = /usr/local
-BINDIR = /usr/local/bin
@ -15,19 +16,17 @@ $NetBSD: patch-aa,v 1.3 2002/12/01 15:38:34 seb Exp $
MAN_BIN = imapfilter.1
MAN_RC = imapfilterrc.5
@@ -14,20 +11,19 @@ OBJ = data.o file.o imap.o imapfilter.o
@@ -19,7 +15,7 @@ LIBS = -lssl -lcrypto
all: imapfilter
LIBS = -lssl -lcrypto
+all: imapfilter
+
imapfilter: $(OBJ)
- $(CC) $(LIBS) $(CFLAGS) -o $(BIN) $(OBJ)
- $(CC) $(LIBS) $(LDFLAGS) -o $(BIN) $(OBJ)
+ $(CC) $(LDFLAGS) $(LIBS) $(CFLAGS) -o $(BIN) $(OBJ)
data.o file.o imap.o imapfilter.o lock.o log.o response.o request.o \
memory.o passwd.o socket.o tty.o: imapfilter.h config.h
data.o imapfilter.o imap.o file.o passwd.o request.o socket.o: data.h
account.o action.o auth.o buffer.o cert.o destroy.o file.o filter.o imap.o \
imapfilter.o lock.o log.o match.o memory.o parse.o passwd.o \
@@ -32,12 +28,12 @@ cert.o file.o lock.o parse.o: pathnames.
imapfilter.o: version.h
install: imapfilter
- if test ! -d $(BINDIR); then mkdir -p $(BINDIR); fi
@ -36,9 +35,12 @@ $NetBSD: patch-aa,v 1.3 2002/12/01 15:38:34 seb Exp $
- cp -f $(MAN_BIN) $(MANDIR)/man1 && chmod 0644 $(MANDIR)/man1/$(MAN_BIN)
- if test ! -d $(MANDIR)/man5; then mkdir -p $(MANDIR)/man5; fi
- cp -f $(MAN_RC) $(MANDIR)/man5 && chmod 0644 $(MANDIR)/man5/$(MAN_RC)
+ $(BSD_INSTALL_PROGRAM_DIR) $(BINDIR)
+ $(BSD_INSTALL_PROGRAM) $(BIN) $(BINDIR)
+ $(BSD_INSTALL_MAN_DIR) $(MANDIR)/man1
+ $(BSD_INSTALL_MAN) $(MAN_BIN) $(MANDIR)/man1
+ $(BSD_INSTALL_MAN_DIR) $(MANDIR)/man5
+ $(BSD_INSTALL_MAN) $(MAN_RC) $(MANDIR)/man5
uninstall:
deinstall:
rm -f $(BINDIR)/$(BIN) $(MANDIR)/man1/$(MAN_BIN) $(MANDIR)/man5/$(MAN_RC)