Acrobat Reader is part of the Adobe Acrobat family of software, which lets
you view, distribute, and print documents in Portable Document Format (PDF)--regardless of the computer, operating system, fonts, or application used to create the original file. PDF files retain all the formatting, fonts, and graphics of the original document, and virtually any PostScript(TM) document can be converted into a PDF file. This is version 3 of the Adobe Acrobat Reader. The reason for adding acroread3 to the package collection when we also have acroread4 is that acroread4 does not run in the current state (January 2000) of our SVR4 binary emulation. The missing system calls are non-trivial. Hence I wanted to make sure sparc users had a version of acroread. Note that acroread3 is available for sunos and this version does correctly run under our SunOS emulation.
This commit is contained in:
parent
86b3e96eb1
commit
02ff9b055e
13 changed files with 274 additions and 0 deletions
71
print/acroread3/Makefile
Normal file
71
print/acroread3/Makefile
Normal file
|
@ -0,0 +1,71 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2000/01/14 15:19:28 dmcmahill Exp $
|
||||
|
||||
PKGNAME= acroread-3.01
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= ftp://ftp-pac.adobe.com/pub/adobe/acrobatreader/unix/3.x/
|
||||
|
||||
MAINTAINER= packages@netbsd.org
|
||||
HOMEPAGE= http://www.adobe.com/prodindex/acrobat/readstep.html
|
||||
|
||||
IS_INTERACTIVE= YES
|
||||
RESTRICTED= "Original installer required to redistribute."
|
||||
NO_CDROM= ${RESTRICTED}
|
||||
|
||||
NO_BUILD= YES
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if ${OPSYS} == "NetBSD"
|
||||
.if (${MACHINE_ARCH} == "i386")
|
||||
DEPENDS= suse_linux-6.1p1:../../emulators/suse_linux
|
||||
DISTNAME= acroread_linux_301
|
||||
PLATFORM= intellinux
|
||||
#.elif (${MACHINE_ARCH} == "alpha")
|
||||
#.if !exists(/emul/osf1/sbin/loader)
|
||||
#IGNORE= requires Digital UNIX libraries - see compat_osf1(8)
|
||||
#.endif
|
||||
#DISTNAME= acroread_osf_301
|
||||
#PLATFORM= osf
|
||||
.elif (${MACHINE_ARCH} == "sparc")
|
||||
.if !exists(/emul/sunos/usr/lib/ld.so)
|
||||
IGNORE= requires SunOS libraries - see compat_sunos(8)
|
||||
.endif
|
||||
DISTNAME= acroread_sunos_301
|
||||
PLATFORM= sparcsun
|
||||
.else
|
||||
DISTNAME= ${PKGNAME}
|
||||
.endif
|
||||
ONLY_FOR_PLATFORM= *-*-i386 *-*-sparc
|
||||
# *-*-alpha
|
||||
.elif ${OPSYS} == "SunOS"
|
||||
DISTNAME= acroread_solaris_301
|
||||
PLATFORM= sparcsolaris
|
||||
post-patch:
|
||||
${CHMOD} -R o+rwx ${WRKSRC}
|
||||
.else
|
||||
DISTNAME= ${PKGNAME}
|
||||
.endif
|
||||
|
||||
WRKSRC= ${WRKDIR}
|
||||
PLIST_SRC= ${PKGDIR}/PLIST.pre \
|
||||
${PKGDIR}/PLIST.${LOWER_OPSYS}-${MACHINE_ARCH} \
|
||||
${PKGDIR}/PLIST.post
|
||||
PLIST_SUBST+= PLATFORM=${PLATFORM}
|
||||
|
||||
pre-install:
|
||||
# ${SED} -e 's|@PLATFORM@|${PLATFORM}|g' ${PKGDIR}/PLIST > ${PLIST_SRC}
|
||||
|
||||
do-install:
|
||||
@${MKDIR} ${PREFIX}/Acrobat3
|
||||
@ReadInstallDir=${PREFIX}/Acrobat3 ${WRKSRC}/INSTALL
|
||||
|
||||
post-install:
|
||||
@cd ${PREFIX}/Acrobat3/bin && \
|
||||
${PATCH} --quiet < ${FILESDIR}/acroread.diff && \
|
||||
${INSTALL_SCRIPT} ${PREFIX}/Acrobat3/bin/acroread \
|
||||
${PREFIX}/bin/acroread3 && ${RM} acroread.orig
|
||||
@chmod +x ${PREFIX}/bin/acroread3
|
||||
@${ECHO_MSG} "Be sure to read the license agreement in"
|
||||
@${ECHO_MSG} "${PREFIX}/Acrobat3/Reader/License.pdf"
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
34
print/acroread3/files/acroread.diff
Normal file
34
print/acroread3/files/acroread.diff
Normal file
|
@ -0,0 +1,34 @@
|
|||
$NetBSD: acroread.diff,v 1.1.1.1 2000/01/14 15:19:28 dmcmahill Exp $
|
||||
|
||||
--- acroread.orig Tue Jan 11 13:05:56 2000
|
||||
+++ acroread Tue Jan 11 13:12:42 2000
|
||||
@@ -210,4 +210,22 @@
|
||||
export ACRO_CONFIG
|
||||
;;
|
||||
+ NetBSD)
|
||||
+ machine_type=`uname -p`
|
||||
+ case "$machine_type" in
|
||||
+ alpha)
|
||||
+ ACRO_CONFIG=alphaosf
|
||||
+ export ACRO_CONFIG
|
||||
+ ;;
|
||||
+ i386)
|
||||
+ ACRO_CONFIG=intellinux
|
||||
+ export ACRO_CONFIG
|
||||
+ ;;
|
||||
+ sparc)
|
||||
+ ACRO_CONFIG=sparcsun
|
||||
+ export ACRO_CONFIG
|
||||
+ ;;
|
||||
+ esac
|
||||
+ ;;
|
||||
+
|
||||
esac
|
||||
|
||||
@@ -310,4 +328,6 @@
|
||||
LD_LIBRARY_PATH="`prepend "$ACRO_INSTALL_DIR/$ACRO_CONFIG/lib:$ACRO_INSTALL_DIR/$ACRO_CONFIG/lib" "$LD_LIBRARY_PATH"`"
|
||||
export LD_LIBRARY_PATH
|
||||
+ LC_CTYPE="C"
|
||||
+ export LC_CTYPE
|
||||
;;
|
||||
intelbsdi)
|
6
print/acroread3/files/md5
Normal file
6
print/acroread3/files/md5
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: md5,v 1.1.1.1 2000/01/14 15:19:28 dmcmahill Exp $
|
||||
|
||||
MD5 (acroread_linux_301.tar.gz) = 3c168eab471aef91f1436c57ba7963b2
|
||||
MD5 (acroread_osf_301.tar.gz) = 19ffa95382dcb04ef3efc686e3ba1a6c
|
||||
MD5 (acroread_solaris_301.tar.gz) = f09b76b76638d028f029636eab819699
|
||||
MD5 (acroread_sunos_301.tar.gz) = 68dfc97aadbedc77d956db29e5766f94
|
3
print/acroread3/files/patch-sum
Normal file
3
print/acroread3/files/patch-sum
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: patch-sum,v 1.1.1.1 2000/01/14 15:19:28 dmcmahill Exp $
|
||||
|
||||
MD5 (patch-aa) = 7545b809bc9106ac31fc3472b63db62e
|
49
print/acroread3/patches/patch-aa
Normal file
49
print/acroread3/patches/patch-aa
Normal file
|
@ -0,0 +1,49 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2000/01/14 15:19:28 dmcmahill Exp $
|
||||
|
||||
--- INSTALL.orig Thu Jun 19 13:29:29 1997
|
||||
+++ INSTALL Wed Jan 12 01:26:03 2000
|
||||
@@ -116,4 +116,6 @@
|
||||
if [ `uname -s` = "Linux" ] ; then
|
||||
size=`ls -lLn "$i" | ( read perm links owner group size date ; echo $size )`
|
||||
+ elif [ `uname -s|sed -e 's|.*\(...\)|\\1|'` = "BSD" ] ; then
|
||||
+ size=`ls -lL "$i" | ( read perm links owner group size date ; echo $size )`
|
||||
else
|
||||
size=`ls -lLon "$i" | ( read perm links owner size date ; echo $size )`
|
||||
@@ -558,5 +560,5 @@
|
||||
esac
|
||||
|
||||
-if [ "`type uname`" != "uname not found" ] ; then
|
||||
+if [ "`uname`" != "uname not found" ] ; then
|
||||
OSname=`uname -s`
|
||||
if [ "$OSname" = "AIX" ] ; then
|
||||
@@ -1042,4 +1044,30 @@
|
||||
DistDefaultNum="$DistIntelBSDINum"
|
||||
DefaultName="Intel/BSDI"
|
||||
+ ;;
|
||||
+ NetBSD)
|
||||
+ MachArch=`uname -p`
|
||||
+ case "$MachArch" in
|
||||
+ alpha)
|
||||
+ AcroDefaultNum="$AcroAlphaOSFNum"
|
||||
+ ExchDefaultNum="$ExchAlphaOSFNum"
|
||||
+ ReadDefaultNum="$ReadAlphaOSFNum"
|
||||
+ DistDefaultNum="$DistAlphaOSFNum"
|
||||
+ DefaultName="DEC Alpha/OSF1"
|
||||
+ ;;
|
||||
+ i386)
|
||||
+ AcroDefaultNum="$AcroIntelLinuxNum"
|
||||
+ ExchDefaultNum="$ExchIntelLinuxNum"
|
||||
+ ReadDefaultNum="$ReadIntelLinuxNum"
|
||||
+ DistDefaultNum="$DistIntelLinuxNum"
|
||||
+ DefaultName="Intel/Linux"
|
||||
+ ;;
|
||||
+ sparc)
|
||||
+ AcroDefaultNum="$AcroSparcSunNum"
|
||||
+ ExchDefaultNum="$ExchSparcSunNum"
|
||||
+ ReadDefaultNum="$ReadSparcSunNum"
|
||||
+ DistDefaultNum="$DistSparcSunNum"
|
||||
+ DefaultName="SPARC/SunOS 4.1.3 and later"
|
||||
+ ;;
|
||||
+ esac
|
||||
;;
|
||||
Linux)
|
1
print/acroread3/pkg/COMMENT
Normal file
1
print/acroread3/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
View, distribute and print PDF documents
|
6
print/acroread3/pkg/DESCR
Normal file
6
print/acroread3/pkg/DESCR
Normal file
|
@ -0,0 +1,6 @@
|
|||
Acrobat Reader is part of the Adobe Acrobat family of software, which lets
|
||||
you view, distribute, and print documents in Portable Document Format
|
||||
(PDF)--regardless of the computer, operating system, fonts, or application
|
||||
used to create the original file. PDF files retain all the formatting,
|
||||
fonts, and graphics of the original document, and virtually any
|
||||
PostScript(TM) document can be converted into a PDF file.
|
7
print/acroread3/pkg/PLIST.netbsd-alpha
Normal file
7
print/acroread3/pkg/PLIST.netbsd-alpha
Normal file
|
@ -0,0 +1,7 @@
|
|||
@comment $NetBSD: PLIST.netbsd-alpha,v 1.1.1.1 2000/01/14 15:19:28 dmcmahill Exp $
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libagm.so.2.0
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libagm.so
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libpfs.so.2.5
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libpfs.so
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libreadcore.so.3.0
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libreadcore.so
|
7
print/acroread3/pkg/PLIST.netbsd-i386
Normal file
7
print/acroread3/pkg/PLIST.netbsd-i386
Normal file
|
@ -0,0 +1,7 @@
|
|||
@comment $NetBSD: PLIST.netbsd-i386,v 1.1.1.1 2000/01/14 15:19:28 dmcmahill Exp $
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libagm.so.2.0
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libagm.so
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libpfs.so.2.5
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libpfs.so
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libreadcore.so.3.0
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libreadcore.so
|
20
print/acroread3/pkg/PLIST.netbsd-sparc
Normal file
20
print/acroread3/pkg/PLIST.netbsd-sparc
Normal file
|
@ -0,0 +1,20 @@
|
|||
@comment $NetBSD: PLIST.netbsd-sparc,v 1.1.1.1 2000/01/14 15:19:28 dmcmahill Exp $
|
||||
Acrobat3/Reader/desktop/olwm/acroread.cetable
|
||||
Acrobat3/Reader/desktop/olwm/acroread.deskinstall
|
||||
Acrobat3/Reader/desktop/olwm/acroread.prog.icon
|
||||
Acrobat3/Reader/desktop/olwm/pdf.icon
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libX11.so.4.10
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libXext.so.4.10
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libXt.sa.4.10
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libXt.so.4.10
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libagm.so.2.0
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libpfs.so.2.5
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libreadcore.so.3.0
|
||||
Acrobat3/Reader/${PLATFORM}/lib/nls/local_im_tbl/lt_LN.bit8
|
||||
Acrobat3/Reader/${PLATFORM}/lib/nls/lt_LN.bit8
|
||||
Acrobat3/Reader/${PLATFORM}/lib/nls/nls.alias
|
||||
Acrobat3/Reader/${PLATFORM}/lib/nls/nls.dir
|
||||
@dirrm Acrobat3/Reader/desktop/olwm
|
||||
@dirrm Acrobat3/Reader/desktop
|
||||
@dirrm Acrobat3/Reader/${PLATFORM}/lib/nls/local_im_tbl
|
||||
@dirrm Acrobat3/Reader/${PLATFORM}/lib/nls
|
18
print/acroread3/pkg/PLIST.post
Normal file
18
print/acroread3/pkg/PLIST.post
Normal file
|
@ -0,0 +1,18 @@
|
|||
@comment $NetBSD: PLIST.post,v 1.1.1.1 2000/01/14 15:19:28 dmcmahill Exp $
|
||||
@exec ln -sf %D/Acrobat3/Reader/Fonts %D/Acrobat3/Reader/${PLATFORM}/fonts
|
||||
@unexec rm -f %D/Acrobat3/Reader/${PLATFORM}/fonts
|
||||
@exec ln -sf %D/Acrobat3/Reader/res %D/Acrobat3/Reader/${PLATFORM}/res
|
||||
@unexec rm -f %D/Acrobat3/Reader/${PLATFORM}/res
|
||||
@dirrm Acrobat3/Browsers/${PLATFORM}
|
||||
@dirrm Acrobat3/Reader/${PLATFORM}/app-defaults
|
||||
@dirrm Acrobat3/Reader/${PLATFORM}/bin
|
||||
@dirrm Acrobat3/Reader/${PLATFORM}/lib
|
||||
@dirrm Acrobat3/Reader/${PLATFORM}/plug_ins
|
||||
@dirrm Acrobat3/Reader/${PLATFORM}
|
||||
@dirrm Acrobat3/bin
|
||||
@dirrm Acrobat3/Browsers
|
||||
@dirrm Acrobat3/Fonts
|
||||
@dirrm Acrobat3/Reader/help
|
||||
@dirrm Acrobat3/Reader/res
|
||||
@dirrm Acrobat3/Reader
|
||||
@dirrm Acrobat3
|
40
print/acroread3/pkg/PLIST.pre
Normal file
40
print/acroread3/pkg/PLIST.pre
Normal file
|
@ -0,0 +1,40 @@
|
|||
@comment $NetBSD: PLIST.pre,v 1.1.1.1 2000/01/14 15:19:28 dmcmahill Exp $
|
||||
Acrobat3/Browsers/netscape
|
||||
Acrobat3/Browsers/${PLATFORM}/nppdf.so
|
||||
Acrobat3/Fonts/AcroRead.upr
|
||||
Acrobat3/Fonts/AdobeSansMM
|
||||
Acrobat3/Fonts/AdobeSansMM.MMM
|
||||
Acrobat3/Fonts/AdobeSerifMM
|
||||
Acrobat3/Fonts/AdobeSerifMM.MMM
|
||||
Acrobat3/Fonts/Courier
|
||||
Acrobat3/Fonts/Courier-Bold
|
||||
Acrobat3/Fonts/Courier-BoldOblique
|
||||
Acrobat3/Fonts/Courier-Oblique
|
||||
Acrobat3/Fonts/Helvetica
|
||||
Acrobat3/Fonts/Helvetica-Bold
|
||||
Acrobat3/Fonts/Helvetica-BoldOblique
|
||||
Acrobat3/Fonts/Helvetica-Oblique
|
||||
Acrobat3/Fonts/Symbol
|
||||
Acrobat3/Fonts/Times-Bold
|
||||
Acrobat3/Fonts/Times-BoldItalic
|
||||
Acrobat3/Fonts/Times-Italic
|
||||
Acrobat3/Fonts/Times-Roman
|
||||
Acrobat3/Fonts/ZapfDingbats
|
||||
Acrobat3/Reader/AcroVersion
|
||||
Acrobat3/Reader/Acrobat.pdf
|
||||
Acrobat3/Reader/License.pdf
|
||||
Acrobat3/Reader/MapTypes.pdf
|
||||
Acrobat3/Reader/ReadMe
|
||||
Acrobat3/Reader/help/reader.pdf
|
||||
Acrobat3/Reader/res/splashScreen11R.xbm
|
||||
Acrobat3/Reader/res/splashScreen18R.xpm
|
||||
Acrobat3/Reader/res/splashScreen21.xbm
|
||||
Acrobat3/Reader/res/splashScreen28.xpm
|
||||
Acrobat3/Reader/${PLATFORM}/app-defaults/AcroRead
|
||||
Acrobat3/Reader/${PLATFORM}/bin/acroread
|
||||
Acrobat3/Reader/${PLATFORM}/lib/XKeysymDB
|
||||
Acrobat3/Reader/${PLATFORM}/plug_ins/Highlight.api
|
||||
Acrobat3/Reader/${PLATFORM}/plug_ins/ewh.api
|
||||
Acrobat3/Reader/${PLATFORM}/plug_ins/wwwlink.api
|
||||
Acrobat3/bin/acroread
|
||||
bin/acroread3
|
12
print/acroread3/pkg/PLIST.sunos-sparc
Normal file
12
print/acroread3/pkg/PLIST.sunos-sparc
Normal file
|
@ -0,0 +1,12 @@
|
|||
@comment $NetBSD: PLIST.sunos-sparc,v 1.1.1.1 2000/01/14 15:19:28 dmcmahill Exp $
|
||||
Acrobat3/Reader/desktop/olwm/acroread.cetable
|
||||
Acrobat3/Reader/desktop/olwm/acroread.deskinstall
|
||||
Acrobat3/Reader/desktop/olwm/acroread.prog.icon
|
||||
Acrobat3/Reader/desktop/olwm/pdf.icon
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libXm.so.3
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libXm.so
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libagm.so.2.0
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libpfs.so.2.5
|
||||
Acrobat3/Reader/${PLATFORM}/lib/libreadcore.so.3.0
|
||||
@dirrm Acrobat3/Reader/desktop/olwm
|
||||
@dirrm Acrobat3/Reader/desktop
|
Loading…
Reference in a new issue