Fix build on i386.
This commit is contained in:
parent
6027aa8227
commit
0308d3fe15
2 changed files with 5 additions and 4 deletions
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.10 2010/07/26 10:01:45 adam Exp $
|
||||
$NetBSD: distinfo,v 1.11 2010/10/12 17:20:10 joerg Exp $
|
||||
|
||||
SHA1 (wormux-0.9.2.1.tar.bz2) = 9fc39f61f2c1eb4ddd1d7ad5238e3728b9604e45
|
||||
RMD160 (wormux-0.9.2.1.tar.bz2) = 23b678092693c471dbc692471f5f7f56970e2175
|
||||
Size (wormux-0.9.2.1.tar.bz2) = 99679696 bytes
|
||||
SHA1 (patch-aa) = fcd6d01a9ff6f1c73e9ab66413fe372d4806b57f
|
||||
SHA1 (patch-aa) = 6a2c3d74e0183e55dae924a2f46fb8b2ef08c3b1
|
||||
|
|
|
@ -1,13 +1,14 @@
|
|||
$NetBSD: patch-aa,v 1.4 2010/07/26 10:01:45 adam Exp $
|
||||
$NetBSD: patch-aa,v 1.5 2010/10/12 17:20:11 joerg Exp $
|
||||
|
||||
--- lib/fixedpoint/fixed_class.h.orig 2010-07-25 16:18:30.000000000 +0000
|
||||
+++ lib/fixedpoint/fixed_class.h
|
||||
@@ -64,7 +64,7 @@ struct fixed_point {
|
||||
@@ -64,7 +64,8 @@ struct fixed_point {
|
||||
/*explicit*/ fixed_point(float f) : intValue(float2fix<p>(f)) {}
|
||||
/*explicit*/ fixed_point(double f) : intValue(float2fix<p>((float)f)) {}
|
||||
#if __WORDSIZE != 64
|
||||
- /*explicit*/ fixed_point(long int l) : intValue(((int64_t)l) << p) {}
|
||||
+ /*explicit*/ fixed_point(unsigned long l) : intValue(((int64_t)l) << p) {}
|
||||
+ /*explicit*/ fixed_point(long l) : intValue(((int64_t)l) << p) {}
|
||||
#endif
|
||||
/*explicit*/ fixed_point(unsigned int l) : intValue(((int64_t)l) << p) {}
|
||||
#ifdef SIZE_T_FIXEDPOINT_METHODS
|
||||
|
|
Loading…
Reference in a new issue