Sunpro sometimes defines __STDC__ to 1, and sometimes it only defines

__STDC__ to something else, depending on the command line options.
This commit is contained in:
rillig 2007-11-13 12:50:21 +00:00
parent 3c431479d2
commit 0359e48aa1
2 changed files with 15 additions and 6 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.2 2005/02/24 11:24:03 agc Exp $
$NetBSD: distinfo,v 1.3 2007/11/13 12:50:21 rillig Exp $
SHA1 (mpeg_lib-1.3.1.tar.gz) = 0ea4f8b31e4f316d99c2034d76619988f75147dc
RMD160 (mpeg_lib-1.3.1.tar.gz) = 27df1f6568c763df41beeed6382af88377da3e38
@ -17,5 +17,5 @@ SHA1 (patch-ak) = e6dd6f3e902ee774d06aa93cfa6ac5ead9df7aa9
SHA1 (patch-al) = f63df4035b3f33ac778e7bde1e478434826c34ba
SHA1 (patch-am) = b2f7afdd74c28bd6345f1ac291577103bf8196f3
SHA1 (patch-an) = 3b23f238fcdc1321d17d19be74c7e670b249c5fc
SHA1 (patch-ao) = 84caaa6c7b9cb5eb7f7455323767aa6753e92ff7
SHA1 (patch-ao) = 321560c282fe997f706aa4c03f04bcb0d3ac22f5
SHA1 (patch-ap) = 2d7536517bcf3e9ed52fdc09ab5a5f721aab6c5d

View file

@ -1,8 +1,17 @@
$NetBSD: patch-ao,v 1.1 2004/06/26 18:27:23 grant Exp $
$NetBSD: patch-ao,v 1.2 2007/11/13 12:50:22 rillig Exp $
--- mpeg.h.orig Sat Jul 24 00:32:06 1999
+++ mpeg.h
@@ -109,7 +109,7 @@
--- mpeg.h.orig 1999-07-24 06:32:06.000000000 +0200
+++ mpeg.h 2007-11-13 13:42:30.615567000 +0100
@@ -97,7 +97,7 @@ extern "C" {
* Mixing and matching compilers, BTW, is not a good idea...)
*/
#undef PROTO
-#if __STDC__ || __cplusplus
+#if __STDC__ || __cplusplus || defined(__STDC__)
#define PROTO(formal_parameters) formal_parameters
#else
#define const
@@ -109,7 +109,7 @@ extern "C" {
Boolean OpenMPEG PROTO((FILE *MPEGfile, ImageDesc *ImgInfo));
void CloseMPEG PROTO((void));
Boolean RewindMPEG PROTO((FILE *MPEGfile, ImageDesc *Image));