import partysip-2.2.1, a SIP proxy server

This commit is contained in:
drochner 2005-04-01 19:55:02 +00:00
parent f0b93e1019
commit 0386fb93a8
6 changed files with 153 additions and 0 deletions

8
net/partysip/DESCR Normal file
View file

@ -0,0 +1,8 @@
Partysip is an implementation of a SIP proxy server. SIP stands for the
Session Initiation Protocol and is described by the rfc2543 (soon to be
deprecated by latest revisions). SIP is a open standard replacement from
IETF for H323.
Partysip is a modular application where some capabilities are added and
removed through plugins. The program comes with several GPL plugins. At
this step, partysip and its plugins could be used as a 'SIP registrar',
a 'SIP redirect server' and a 'SIP statefull proxy server'.

21
net/partysip/Makefile Normal file
View file

@ -0,0 +1,21 @@
# $NetBSD: Makefile,v 1.1.1.1 2005/04/01 19:55:02 drochner Exp $
#
DISTNAME= partysip-2.2.1
CATEGORIES= net
MASTER_SITES= http://savannah.gnu.org/download/partysip/
MAINTAINER= tech-pkg@NetBSD.org
HOMEPAGE= http://www.nongnu.org/partysip/partysip.html
COMMENT= SIP proxy server
USE_BUILDLINK3= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-config-dir=/etc
USE_LIBTOOL= yes
post-install:
${INSTALL_DATA} ${WRKSRC}/conf/partysip.conf ${PREFIX}/share/examples
.include "../../devel/libosip/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

37
net/partysip/PLIST Normal file
View file

@ -0,0 +1,37 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2005/04/01 19:55:02 drochner Exp $
bin/partysip
bin/partysip-config
bin/psp_users
include/partysip/osip_msg.h
include/partysip/partysip.h
include/partysip/psp_config.h
include/partysip/psp_macros.h
include/partysip/psp_nat.h
include/partysip/psp_plug.h
include/partysip/psp_request.h
include/partysip/psp_utils.h
include/ppl/ppl.h
include/ppl/ppl_dbm.h
include/ppl/ppl_dns.h
include/ppl/ppl_dso.h
include/ppl/ppl_getopt.h
include/ppl/ppl_init.h
include/ppl/ppl_md5.h
include/ppl/ppl_pipe.h
include/ppl/ppl_socket.h
include/ppl/ppl_time.h
include/ppl/ppl_uinfo.h
lib/libppl.la
lib/partysip/libpsp_auth.la
lib/partysip/libpsp_filter.la
lib/partysip/libpsp_groups.la
lib/partysip/libpsp_ls_localdb.la
lib/partysip/libpsp_ls_sfull.la
lib/partysip/libpsp_ls_static.la
lib/partysip/libpsp_rgstrar.la
lib/partysip/libpsp_syntax.la
lib/partysip/libpsp_udp.la
share/examples/partysip.conf
@dirrm lib/partysip
@dirrm include/ppl
@dirrm include/partysip

7
net/partysip/distinfo Normal file
View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2005/04/01 19:55:02 drochner Exp $
SHA1 (partysip-2.2.1.tar.gz) = ff3b376cebde677bbbbd2257d682e39f805ed50b
RMD160 (partysip-2.2.1.tar.gz) = 93eb18456d63d1336d4ff84884b006dd7f4627a5
Size (partysip-2.2.1.tar.gz) = 567107 bytes
SHA1 (patch-aa) = 333762c23022dd65c7f7b2b38d907cd69e44d595
SHA1 (patch-ab) = d661caf4c229ba51ec98439ca089dc26e3cdb6e6

View file

@ -0,0 +1,67 @@
$NetBSD: patch-aa,v 1.1.1.1 2005/04/01 19:55:02 drochner Exp $
--- ppl/unix/ppldnsv6.c.orig 2005-04-01 19:42:57.000000000 +0200
+++ ppl/unix/ppldnsv6.c
@@ -314,7 +314,7 @@ ppl_dns_resolv (ppl_dns_ip_t ** dns_ips,
cp += n;
-#if defined(__NetBSD__) || defined(__OpenBSD__) ||\
+#if defined(__OpenBSD__) ||\
defined(OLD_NAMESER) || defined(__FreeBSD__)
type = _get_short (cp);
cp += sizeof (u_short);
@@ -324,7 +324,7 @@ ppl_dns_resolv (ppl_dns_ip_t ** dns_ips,
NS_GET16 (type, cp);
#endif
-#if defined(__NetBSD__) || defined(__OpenBSD__) ||\
+#if defined(__OpenBSD__) ||\
defined(OLD_NAMESER) || defined(__FreeBSD__)
aclass = _get_short (cp);
cp += sizeof (u_short);
@@ -334,7 +334,7 @@ ppl_dns_resolv (ppl_dns_ip_t ** dns_ips,
NS_GET16 (aclass, cp);
#endif
-#if defined(__NetBSD__) || defined(__OpenBSD__) ||\
+#if defined(__OpenBSD__) ||\
defined(OLD_NAMESER) || defined(__FreeBSD__)
ttl = _get_long (cp);
cp += sizeof (u_long);
@@ -344,7 +344,7 @@ ppl_dns_resolv (ppl_dns_ip_t ** dns_ips,
NS_GET32 (ttl, cp);
#endif
-#if defined(__NetBSD__) || defined(__OpenBSD__) ||\
+#if defined(__OpenBSD__) ||\
defined(OLD_NAMESER) || defined(__FreeBSD__)
dlen = _get_short (cp);
cp += sizeof (u_short);
@@ -359,7 +359,7 @@ ppl_dns_resolv (ppl_dns_ip_t ** dns_ips,
cp += dlen;
continue;
}
-#if defined(__NetBSD__) || defined(__OpenBSD__) ||\
+#if defined(__OpenBSD__) ||\
defined(OLD_NAMESER) || defined(__FreeBSD__)
pref = _get_short (cp);
cp += sizeof (u_short);
@@ -369,7 +369,7 @@ ppl_dns_resolv (ppl_dns_ip_t ** dns_ips,
NS_GET16 (pref, cp);
#endif
-#if defined(__NetBSD__) || defined(__OpenBSD__) ||\
+#if defined(__OpenBSD__) ||\
defined(OLD_NAMESER) || defined(__FreeBSD__)
weight = _get_short (cp);
cp += sizeof (u_short);
@@ -379,7 +379,7 @@ ppl_dns_resolv (ppl_dns_ip_t ** dns_ips,
NS_GET16 (weight, cp);
#endif
-#if defined(__NetBSD__) || defined(__OpenBSD__) ||\
+#if defined(__OpenBSD__) ||\
defined(OLD_NAMESER) || defined(__FreeBSD__)
port = _get_short (cp);
cp += sizeof (u_short);

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1.1.1 2005/04/01 19:55:02 drochner Exp $
--- Makefile.in.orig 2005-04-01 20:45:31.000000000 +0200
+++ Makefile.in
@@ -182,7 +182,7 @@ sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
EXTRA_DIST = README COPYING-2
-SUBDIRS = ppl src partysip plugin scripts windows doc conf tools debian
+SUBDIRS = ppl src partysip plugin scripts windows doc tools debian
all: config.h
$(MAKE) $(AM_MAKEFLAGS) all-recursive