buildlink1 -> buildlink2
Expand on the DESCR. Partially addresses pkg/18374
This commit is contained in:
parent
15a462cc85
commit
03894740ce
7 changed files with 74 additions and 17 deletions
|
@ -1,2 +1,24 @@
|
|||
The kdemultimedia module of KDE provides various sound and movie
|
||||
format players.
|
||||
format players:
|
||||
|
||||
* noatun: a multimedia player for sound and movies, very extensible due to
|
||||
it's plugin interface
|
||||
* aktion: a player specialized on movies, needs xanim
|
||||
* kaboodle: light media player
|
||||
* kmid: a standalone and embeddable midi player, includes a karaoke-mode
|
||||
* kmidi: midi player, can use sound patch files and create a WAV file
|
||||
* kmix: the audio mixer as a standalone program and Kicker applet
|
||||
* koncd: frontend for different cd burn programs
|
||||
* kscd: a CD player with an interface to the internet CDDB database
|
||||
|
||||
The following are libraries and plugins that are building the core
|
||||
infrastructure of above applications:
|
||||
|
||||
* arts: a versatily multimedia system the consists of various little
|
||||
building blocks that you (or an application) can combine in
|
||||
almost arbitrary ways to create sound and video processing pipes
|
||||
* kfile-plugins: provide meta information about sound files
|
||||
* mpeglib: a library for MPEG 1 (layer I, II and III) encoded files
|
||||
* mpeglib_artsplug: wrapped mpeglib to make it Arts-aware
|
||||
* mpg123_artsplugin: a trimmed down mpg123 made Arts-compatible
|
||||
* oggvorbis_artsplugin: support for ogg-vorbis (not included) in Arts
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.5 2002/09/04 14:47:35 agc Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2002/10/03 11:21:28 markd Exp $
|
||||
|
||||
DISTNAME= kdemultimedia-3.0.3
|
||||
CATEGORIES= audio
|
||||
|
@ -8,16 +8,15 @@ COMMENT= Audio tools for the KDE integrated X11 desktop
|
|||
|
||||
DEPENDS+= xanim>=2.80.0:../../graphics/xanim
|
||||
|
||||
USE_BUILDLINK_ONLY= YES
|
||||
USE_BUILDLINK2= YES
|
||||
|
||||
# Ensure we export symbols in the linked shared object.
|
||||
LDFLAGS+= ${EXPORT_SYMBOLS_LDFLAGS}
|
||||
|
||||
PTHREAD_OPT+= require
|
||||
|
||||
.include "../../audio/arts/buildlink.mk"
|
||||
.include "../../x11/kde3/buildlink.mk"
|
||||
.include "../../x11/kdebase3/buildlink.mk"
|
||||
.include "../../mk/pthread.buildlink.mk"
|
||||
.include "../../mk/x11.buildlink.mk"
|
||||
.include "../../audio/arts/buildlink2.mk"
|
||||
.include "../../x11/kde3/buildlink2.mk"
|
||||
.include "../../x11/kdebase3/buildlink2.mk"
|
||||
.include "../../mk/pthread.buildlink2.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.5 2002/08/28 07:15:26 skrll Exp $
|
||||
$NetBSD: distinfo,v 1.6 2002/10/03 11:21:28 markd Exp $
|
||||
|
||||
SHA1 (kdemultimedia-3.0.3.tar.bz2) = 72c046f2656c01c5ece06228154912382885b9b7
|
||||
Size (kdemultimedia-3.0.3.tar.bz2) = 5791102 bytes
|
||||
|
@ -28,8 +28,8 @@ SHA1 (patch-aw) = 87444988e9109f2d59dc7168c4f2337d0c1a7168
|
|||
SHA1 (patch-ax) = efd01de997033aa2cebd0ba5d875b4d547bfd624
|
||||
SHA1 (patch-ay) = 2ce3604aef6a9d79b58fda7e969f79d3e48b6ce8
|
||||
SHA1 (patch-az) = 3e0a89a16e9a21ed1aafffac84882506344d6f37
|
||||
SHA1 (patch-ba) = 1ae7ccac4caaf5fc3cd63a7f5a1da054ae1f0e6e
|
||||
SHA1 (patch-bb) = b27e1dde7793f1c08acc673915234e7324c8c1e5
|
||||
SHA1 (patch-ba) = 0ba40584fd1859bf809c1ecb8b2493a01b6328df
|
||||
SHA1 (patch-bb) = 6f0ce74db0de2f981692046978a765b2631a4d4a
|
||||
SHA1 (patch-bc) = 82424e524f316f55524c5367ce42fe4194f935c6
|
||||
SHA1 (patch-bd) = ace100c1effb71354c2e4ee1ea25ad8f0b0bdada
|
||||
SHA1 (patch-be) = 5cee048125a71eb5a1358966c0a61c4553eff24c
|
||||
|
@ -66,3 +66,5 @@ SHA1 (patch-ci) = 49d1caddd97ba8f00a78561f7fd3813c109b95ed
|
|||
SHA1 (patch-cj) = 163aad2ee9120a3754e4b94c8c775058b370d2ba
|
||||
SHA1 (patch-ck) = 4afe5b8ffca5a1989e5bf34f73b7b7ca8f64726c
|
||||
SHA1 (patch-cl) = 1c918a14435bde2d50c2de15d2db75534bde5591
|
||||
SHA1 (patch-cm) = 2d539df6011c977c0b984233f45b99eeb838e7b3
|
||||
SHA1 (patch-cn) = ef3a680a6e8d90f456edafa3d58fe8b802e2a5bb
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-ba,v 1.2 2002/06/25 06:34:34 skrll Exp $
|
||||
$NetBSD: patch-ba,v 1.3 2002/10/03 11:21:29 markd Exp $
|
||||
|
||||
--- noatun/library/Makefile.am.orig Wed May 8 19:29:25 2002
|
||||
+++ noatun/library/Makefile.am
|
||||
|
@ -14,7 +14,7 @@ $NetBSD: patch-ba,v 1.2 2002/06/25 06:34:34 skrll Exp $
|
|||
playlist.cpp pref.cpp \
|
||||
player.cpp playlistsaver.cpp app.cpp \
|
||||
pluginloader.cpp plugin.cpp \
|
||||
@@ -22,11 +22,11 @@
|
||||
@@ -22,14 +22,14 @@
|
||||
|
||||
include_HEADERS = cmodule.h plugin_deps.h equalizerview.h effectview.h mimetypetree.h ksaver.h
|
||||
|
||||
|
@ -27,4 +27,8 @@ $NetBSD: patch-ba,v 1.2 2002/06/25 06:34:34 skrll Exp $
|
|||
+libnoatun_core_la_LIBADD = $(top_builddir)/arts/gui/common/libartsgui.la \
|
||||
$(top_builddir)/arts/gui/kde/libartsgui_kde.la \
|
||||
$(top_builddir)/arts/modules/libartsmodules.la \
|
||||
-lkio -lqtmcop -lkmedia2_idl -lnoatunarts \
|
||||
- -lkio -lqtmcop -lkmedia2_idl -lnoatunarts \
|
||||
+ -lkio -lqtmcop -lkmedia2_idl $(top_builddir)/noatun/library/noatunarts/libnoatunarts.la \
|
||||
-lartsflow -lsoundserver_idl -lartskde $(LIBDL)
|
||||
|
||||
libnoatuncontrols_la_SOURCES = controls.cpp scrollinglabel.cpp
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-bb,v 1.2 2002/06/25 06:34:34 skrll Exp $
|
||||
$NetBSD: patch-bb,v 1.3 2002/10/03 11:21:29 markd Exp $
|
||||
|
||||
--- noatun/library/Makefile.in.orig Sun Jun 9 10:13:00 2002
|
||||
+++ noatun/library/Makefile.in
|
||||
|
@ -14,7 +14,7 @@ $NetBSD: patch-bb,v 1.2 2002/06/25 06:34:34 skrll Exp $
|
|||
playlist.cpp pref.cpp \
|
||||
player.cpp playlistsaver.cpp app.cpp \
|
||||
pluginloader.cpp plugin.cpp \
|
||||
@@ -315,12 +315,12 @@
|
||||
@@ -315,15 +315,15 @@
|
||||
|
||||
include_HEADERS = cmodule.h plugin_deps.h equalizerview.h effectview.h mimetypetree.h ksaver.h
|
||||
|
||||
|
@ -28,7 +28,11 @@ $NetBSD: patch-bb,v 1.2 2002/06/25 06:34:34 skrll Exp $
|
|||
+libnoatun_core_la_LIBADD = $(top_builddir)/arts/gui/common/libartsgui.la \
|
||||
$(top_builddir)/arts/gui/kde/libartsgui_kde.la \
|
||||
$(top_builddir)/arts/modules/libartsmodules.la \
|
||||
-lkio -lqtmcop -lkmedia2_idl -lnoatunarts \
|
||||
- -lkio -lqtmcop -lkmedia2_idl -lnoatunarts \
|
||||
+ -lkio -lqtmcop -lkmedia2_idl $(top_builddir)/noatun/library/noatunarts/libnoatunarts.la \
|
||||
-lartsflow -lsoundserver_idl -lartskde $(LIBDL)
|
||||
|
||||
|
||||
@@ -345,27 +345,27 @@
|
||||
CONFIG_CLEAN_FILES =
|
||||
LTLIBRARIES = $(lib_LTLIBRARIES)
|
||||
|
|
13
audio/kdemultimedia3/patches/patch-cm
Normal file
13
audio/kdemultimedia3/patches/patch-cm
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-cm,v 1.1 2002/10/03 11:21:29 markd Exp $
|
||||
|
||||
--- noatun/modules/artseffects/Makefile.am.orig Fri Mar 22 14:05:57 2002
|
||||
+++ noatun/modules/artseffects/Makefile.am
|
||||
@@ -5,7 +5,7 @@
|
||||
libartseffects_la_SOURCES = artseffects.cc extrastereo_impl.cc
|
||||
libartseffects_la_LDFLAGS = -L$(top_builddir)/arts/gui/common $(all_libraries) \
|
||||
-module -avoid-version -no-undefined
|
||||
-libartseffects_la_LIBADD = -lartsgui_idl -lkmedia2_idl -lsoundserver_idl -lartsflow
|
||||
+libartseffects_la_LIBADD = $(top_builddir)/arts/gui/common/libartsgui_idl.la -lkmedia2_idl -lsoundserver_idl -lartsflow
|
||||
|
||||
#libartseffectsui_la_SOURCES = artseffects.cc
|
||||
#libartseffectsui_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
|
13
audio/kdemultimedia3/patches/patch-cn
Normal file
13
audio/kdemultimedia3/patches/patch-cn
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-cn,v 1.1 2002/10/03 11:21:29 markd Exp $
|
||||
|
||||
--- noatun/modules/artseffects/Makefile.in.orig Thu Aug 8 06:02:32 2002
|
||||
+++ noatun/modules/artseffects/Makefile.in
|
||||
@@ -297,7 +297,7 @@
|
||||
libartseffects_la_LDFLAGS = -L$(top_builddir)/arts/gui/common $(all_libraries) \
|
||||
-module -avoid-version -no-undefined
|
||||
|
||||
-libartseffects_la_LIBADD = -lartsgui_idl -lkmedia2_idl -lsoundserver_idl -lartsflow
|
||||
+libartseffects_la_LIBADD = $(top_builddir)/arts/gui/common/libartsgui_idl.la -lkmedia2_idl -lsoundserver_idl -lartsflow
|
||||
|
||||
|
||||
#libartseffectsui_la_SOURCES = artseffects.cc
|
Loading…
Reference in a new issue