Update to 0.10.0:
Release 0.10.0 core: * Fix crashes on PDF using Stitching or Axial Shading painting * Fix rendering of PDF with Type1 fonts that have more than one encoding definition per line * Do not try to save documents that have Encryption as we do not support that and the user ended with a broken file * Fix crash on files with OptionalContentGroup but no Name Qt4: * Fix the area of the links to be correctly reported on rotated documents misc: * Mingw+Msys should work Release 0.9.3 (0.10 RC 2) core: * Fix rendering regression on some embedded fonts * Fix rendering regression of some special fonts * Fix crash on documents with bogus jpeg data Qt4: * The printing flag defaults to true on PSConverter * Documentation improvement utils: * Fix regression that made HmtlOutputDev ignore jpeg images misc: * Improve compilation on mingw Release 0.9.2 (0.10 RC 1) core: * Fix conversion to PS some files (bug #17645) * Small Form fixes * Small JS fixes * Improve memory usage of the cairo renderer utils: * Fix mismatched free/delete in pdftohtml * Fix memory leak in pdftohtml * Fix crash in pdftohtml glib: * Fix a crash in forms demo misc: * Compile with -pedantic Release 0.9.1 (0.10 Beta 2) Core: * Fix crash on some AESv2 encrypted files (bugs #13972, #16092, #17523) * Improve parsing of broken files (bug #17568) glib frontend: * Minor improvements to the demo application utils: * pdftohtml: Generate the outline file in the same place of the other generated files (bug #17504) Release 0.9.0 (0.10 Beta 1) Core: * Initial JavaScript support * Annotation improvements * Improvements in the Arthur based renderer * Improvements in the Cairo based renderer * Added a JPEG2000 decoder based on OpenJPEG * Small fixes in ActualText implementation * Fix jpeg rendering when not using the libjpeg based decoder * Movie fixes * Do not get out of memory on documents that specify huge fonts * Emulate Adobe Reader behaviour on documents with duplicate keys in Dictionaries * Forms improvements Qt4 frontend: * Annotation improvements * Forms improvements * Add the possibility of extracting embedded fonts * Initial Movie support * Documentation improvements * Small improvements in the PS exporter glib frontend: * Annotation improvements * Attachment fixes utils: * updated man pages * Added -listenc to pdfinfo and pdftotext
This commit is contained in:
parent
a5f9f89569
commit
03927847e8
7 changed files with 31 additions and 41 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.15 2007/11/28 20:51:33 drochner Exp $
|
||||
# $NetBSD: Makefile,v 1.16 2008/10/24 23:28:53 wiz Exp $
|
||||
#
|
||||
|
||||
.include "../../print/poppler/Makefile.common"
|
||||
|
@ -24,9 +24,8 @@ CONFIGURE_ARGS+= --disable-poppler-qt
|
|||
CONFIGURE_ARGS+= --disable-gtk-test
|
||||
CONFIGURE_ARGS+= --disable-utils
|
||||
|
||||
BUILD_DIRS= ${WRKSRC}/goo ${WRKSRC}/fofi ${WRKSRC}/poppler \
|
||||
${WRKSRC}/glib
|
||||
INSTALL_DIRS= ${WRKSRC}/glib
|
||||
BUILD_DIRS= goo fofi poppler glib
|
||||
INSTALL_DIRS= glib
|
||||
|
||||
INSTALLATION_DIRS+= lib/pkgconfig
|
||||
|
||||
|
|
|
@ -1,9 +1,10 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2008/04/15 19:57:00 drochner Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2008/10/24 23:28:53 wiz Exp $
|
||||
include/poppler/qt4/poppler-annotation.h
|
||||
include/poppler/qt4/poppler-export.h
|
||||
include/poppler/qt4/poppler-form.h
|
||||
include/poppler/qt4/poppler-link.h
|
||||
include/poppler/qt4/poppler-optcontent.h
|
||||
include/poppler/qt4/poppler-page-transition-private.h
|
||||
include/poppler/qt4/poppler-page-transition.h
|
||||
include/poppler/qt4/poppler-qt4.h
|
||||
lib/libpoppler-qt4.la
|
||||
|
|
|
@ -1,8 +1,11 @@
|
|||
# $NetBSD: Makefile.common,v 1.20 2008/09/14 14:17:58 drochner Exp $
|
||||
# $NetBSD: Makefile.common,v 1.21 2008/10/24 23:28:53 wiz Exp $
|
||||
# used by print/poppler/Makefile
|
||||
# used by print/poppler-glib/Makefile
|
||||
# used by print/poppler-qt/Makefile
|
||||
# used by print/poppler-qt4/Makefile
|
||||
# used by print/poppler-utils/Makefile
|
||||
|
||||
POPPLER_VERS= 0.8.7
|
||||
POPPLER_VERS= 0.10.0
|
||||
DISTNAME= poppler-${POPPLER_VERS}
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= http://poppler.freedesktop.org/
|
||||
|
|
|
@ -1,10 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.34 2008/09/14 14:17:58 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.35 2008/10/24 23:28:53 wiz Exp $
|
||||
|
||||
SHA1 (poppler-0.8.7.tar.gz) = 01247676ee74b78b86b76169503910f30d6c86c1
|
||||
RMD160 (poppler-0.8.7.tar.gz) = ea03cdf88a432e5748988e3576110a2989aa79ec
|
||||
Size (poppler-0.8.7.tar.gz) = 1469587 bytes
|
||||
SHA1 (poppler-0.10.0.tar.gz) = 811b73557b68f7dd64cec4fec0bdd8a3e741d558
|
||||
RMD160 (poppler-0.10.0.tar.gz) = 068a4f895e39635b628f0a21f4420bbf162ebeca
|
||||
Size (poppler-0.10.0.tar.gz) = 1525340 bytes
|
||||
SHA1 (patch-aa) = 43c63c16d3a845e394a8eb0c3a321944fcf17615
|
||||
SHA1 (patch-ab) = e3d413ec50a098af06cb2efc2fac2042064498dd
|
||||
SHA1 (patch-ag) = 258b8bff3d167914539e40c3263d36ce55e2ea01
|
||||
SHA1 (patch-ab) = 5a2785bccd71990e20cd81a3cd2697804e31788d
|
||||
SHA1 (patch-ag) = 0bf1bc080cad55792fe6cc761bf22ecccba7d13a
|
||||
SHA1 (patch-ai) = d3d4411092b5c6dd61d3f197c01c3bcdad88cc0e
|
||||
SHA1 (patch-ak) = e64693fc247a634fc58885738e975c8dfc4014b8
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ab,v 1.8 2008/04/15 19:57:00 drochner Exp $
|
||||
$NetBSD: patch-ab,v 1.9 2008/10/24 23:28:53 wiz Exp $
|
||||
|
||||
--- utils/Makefile.in.orig 2008-03-26 19:40:20.000000000 +0100
|
||||
--- utils/Makefile.in.orig 2008-10-09 19:13:22.000000000 +0000
|
||||
+++ utils/Makefile.in
|
||||
@@ -48,7 +48,7 @@ mkinstalldirs = $(install_sh) -d
|
||||
@@ -49,7 +49,7 @@ mkinstalldirs = $(install_sh) -d
|
||||
CONFIG_HEADER = $(top_builddir)/config.h \
|
||||
$(top_builddir)/poppler/poppler-config.h
|
||||
CONFIG_CLEAN_FILES =
|
||||
|
@ -11,7 +11,7 @@ $NetBSD: patch-ab,v 1.8 2008/04/15 19:57:00 drochner Exp $
|
|||
@BUILD_ABIWORD_OUTPUT_TRUE@am__EXEEXT_2 = pdftoabw$(EXEEXT)
|
||||
am__installdirs = "$(DESTDIR)$(bindir)" "$(DESTDIR)$(man1dir)"
|
||||
binPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
|
||||
@@ -58,18 +58,18 @@ am_pdffonts_OBJECTS = pdffonts.$(OBJEXT)
|
||||
@@ -59,19 +59,19 @@ am_pdffonts_OBJECTS = pdffonts.$(OBJEXT)
|
||||
pdffonts_OBJECTS = $(am_pdffonts_OBJECTS)
|
||||
pdffonts_LDADD = $(LDADD)
|
||||
am__DEPENDENCIES_1 =
|
||||
|
@ -25,7 +25,8 @@ $NetBSD: patch-ab,v 1.8 2008/04/15 19:57:00 drochner Exp $
|
|||
-pdfimages_DEPENDENCIES = $(top_builddir)/poppler/libpoppler.la \
|
||||
+pdfimages_DEPENDENCIES = $(prefix)/lib/libpoppler.la \
|
||||
$(am__DEPENDENCIES_1)
|
||||
am_pdfinfo_OBJECTS = pdfinfo.$(OBJEXT) $(am__objects_1)
|
||||
am_pdfinfo_OBJECTS = pdfinfo.$(OBJEXT) printencodings.$(OBJEXT) \
|
||||
$(am__objects_1)
|
||||
pdfinfo_OBJECTS = $(am_pdfinfo_OBJECTS)
|
||||
pdfinfo_LDADD = $(LDADD)
|
||||
-pdfinfo_DEPENDENCIES = $(top_builddir)/poppler/libpoppler.la \
|
||||
|
@ -33,7 +34,7 @@ $NetBSD: patch-ab,v 1.8 2008/04/15 19:57:00 drochner Exp $
|
|||
$(am__DEPENDENCIES_1)
|
||||
am__pdftoabw_SOURCES_DIST = pdftoabw.cc parseargs.c parseargs.h
|
||||
@BUILD_ABIWORD_OUTPUT_TRUE@am_pdftoabw_OBJECTS = pdftoabw.$(OBJEXT) \
|
||||
@@ -82,24 +82,24 @@ am_pdftohtml_OBJECTS = pdftohtml.$(OBJEX
|
||||
@@ -84,25 +84,25 @@ am_pdftohtml_OBJECTS = pdftohtml.$(OBJEX
|
||||
HtmlLinks.$(OBJEXT) HtmlOutputDev.$(OBJEXT) $(am__objects_1)
|
||||
pdftohtml_OBJECTS = $(am_pdftohtml_OBJECTS)
|
||||
pdftohtml_LDADD = $(LDADD)
|
||||
|
@ -56,7 +57,8 @@ $NetBSD: patch-ab,v 1.8 2008/04/15 19:57:00 drochner Exp $
|
|||
-pdftops_DEPENDENCIES = $(top_builddir)/poppler/libpoppler.la \
|
||||
+pdftops_DEPENDENCIES = $(prefix)/lib/libpoppler.la \
|
||||
$(am__DEPENDENCIES_1)
|
||||
am_pdftotext_OBJECTS = pdftotext.$(OBJEXT) $(am__objects_1)
|
||||
am_pdftotext_OBJECTS = pdftotext.$(OBJEXT) printencodings.$(OBJEXT) \
|
||||
$(am__objects_1)
|
||||
pdftotext_OBJECTS = $(am_pdftotext_OBJECTS)
|
||||
pdftotext_LDADD = $(LDADD)
|
||||
-pdftotext_DEPENDENCIES = $(top_builddir)/poppler/libpoppler.la \
|
||||
|
@ -64,7 +66,7 @@ $NetBSD: patch-ab,v 1.8 2008/04/15 19:57:00 drochner Exp $
|
|||
$(am__DEPENDENCIES_1)
|
||||
DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir) -I$(top_builddir)/poppler
|
||||
depcomp = $(SHELL) $(top_srcdir)/depcomp
|
||||
@@ -282,12 +282,12 @@ target_alias = @target_alias@
|
||||
@@ -293,12 +293,12 @@ target_alias = @target_alias@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
win32_libs = @win32_libs@
|
||||
|
@ -82,7 +84,7 @@ $NetBSD: patch-ab,v 1.8 2008/04/15 19:57:00 drochner Exp $
|
|||
@BUILD_ABIWORD_OUTPUT_TRUE@pdftoabw_SOURCES = \
|
||||
@BUILD_ABIWORD_OUTPUT_TRUE@ pdftoabw.cc \
|
||||
@BUILD_ABIWORD_OUTPUT_TRUE@ $(common)
|
||||
@@ -302,9 +302,10 @@ INCLUDES = \
|
||||
@@ -313,9 +313,10 @@ INCLUDES = \
|
||||
$(ABIWORD_CFLAGS)
|
||||
|
||||
LDADD = \
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-ag,v 1.3 2008/07/15 10:34:21 drochner Exp $
|
||||
$NetBSD: patch-ag,v 1.4 2008/10/24 23:28:53 wiz Exp $
|
||||
|
||||
--- qt4/src/Makefile.in.orig 2008-06-28 17:18:39.000000000 +0200
|
||||
--- qt4/src/Makefile.in.orig 2008-10-09 19:13:21.000000000 +0000
|
||||
+++ qt4/src/Makefile.in
|
||||
@@ -62,7 +62,7 @@ libLTLIBRARIES_INSTALL = $(INSTALL)
|
||||
LTLIBRARIES = $(lib_LTLIBRARIES)
|
||||
|
@ -11,12 +11,12 @@ $NetBSD: patch-ag,v 1.3 2008/07/15 10:34:21 drochner Exp $
|
|||
$(am__DEPENDENCIES_1) $(am__append_1)
|
||||
am_libpoppler_qt4_la_OBJECTS = poppler-document.lo poppler-page.lo \
|
||||
poppler-fontinfo.lo poppler-embeddedfile.lo poppler-textbox.lo \
|
||||
@@ -303,7 +303,7 @@ libpoppler_qt4_la_SOURCES = \
|
||||
@@ -308,7 +308,7 @@ libpoppler_qt4_la_SOURCES = \
|
||||
poppler-export.h \
|
||||
poppler-private.h
|
||||
|
||||
-libpoppler_qt4_la_LIBADD = $(top_builddir)/poppler/libpoppler.la \
|
||||
+libpoppler_qt4_la_LIBADD = $(prefix)/lib/libpoppler.la \
|
||||
$(FONTCONFIG_LIBS) $(POPPLER_QT4_LIBS) $(am__append_1)
|
||||
libpoppler_qt4_la_LDFLAGS = -version-info 3:0:0
|
||||
libpoppler_qt4_la_LDFLAGS = -version-info 4:0:1
|
||||
all: all-am
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-ak,v 1.3 2008/09/14 14:17:58 drochner Exp $
|
||||
|
||||
--- poppler/Annot.cc.orig 2008-09-12 13:49:37.000000000 +0200
|
||||
+++ poppler/Annot.cc
|
||||
@@ -1732,7 +1732,8 @@ void AnnotWidget::initialize(XRef *xrefA
|
||||
Object obj1;
|
||||
|
||||
form = catalog->getForm ();
|
||||
- widget = form->findWidgetByRef (ref);
|
||||
+ if (form) widget = form->findWidgetByRef (ref);
|
||||
+ else widget = NULL;
|
||||
|
||||
// check if field apperances need to be regenerated
|
||||
// Only text or choice fields needs to have appearance regenerated
|
Loading…
Reference in a new issue