Import duo_unix 1.10.1 as security/duo_unix.

Duo two-factor authentication for Unix systems.
This commit is contained in:
fhajny 2018-02-16 07:20:56 +00:00
parent ab784b2c6d
commit 03baf2ce65
7 changed files with 102 additions and 1 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.669 2018/01/31 11:37:16 markd Exp $
# $NetBSD: Makefile,v 1.670 2018/02/16 07:20:56 fhajny Exp $
#
COMMENT= Security tools
@ -70,6 +70,7 @@ SUBDIR+= dnssec-tools
SUBDIR+= dropbear
SUBDIR+= dsniff
SUBDIR+= dsniff-nox11
SUBDIR+= duo-unix
SUBDIR+= easy-rsa
SUBDIR+= ecap_clamav_adapter
SUBDIR+= egd

1
security/duo-unix/DESCR Normal file
View file

@ -0,0 +1 @@
Duo two-factor authentication for Unix systems.

View file

@ -0,0 +1,41 @@
# $NetBSD: Makefile,v 1.1 2018/02/16 07:20:56 fhajny Exp $
#
DISTNAME= duo_unix-1.10.1
PKGNAME= ${DISTNAME:S/_/-/}
CATEGORIES= security
MASTER_SITES= https://dl.duosecurity.com/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://www.duosecurity.com/
COMMENT= Duo two-factor authentication for Unix systems
LICENSE= gnu-gpl-v2
USE_LIBTOOL= yes
USE_TOOLS+= gmake pkg-config
GNU_CONFIGURE= yes
PKGCONFIG_OVERRIDE+= lib/libduo.pc.in
.include "options.mk"
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
INSTALL_MAKE_FLAGS+= sysconfdir=${PREFIX}/share/examples/duo-unix
INSTALLATION_DIRS= share/examples/duo-unix
CONF_FILES_PERMS+= share/examples/duo-unix/login_duo.conf \
${PKG_SYSCONFDIR}/login_duo.conf \
${REAL_ROOT_USER} ${REAL_ROOT_GROUP} 0400
SPECIAL_PERMS+= sbin/login_duo ${SETUID_ROOT_PERMS}
SUBST_CLASSES+= man
SUBST_STAGE.man= post-patch
SUBST_MESSAGE.man= Fixing sysconfdir references
SUBST_FILES.man= login_duo/login_duo.8 pam_duo/pam_duo.8
SUBST_SED.man= -e 's,/etc/duo,${PKG_SYSCONFDIR},g'
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

16
security/duo-unix/PLIST Normal file
View file

@ -0,0 +1,16 @@
@comment $NetBSD: PLIST,v 1.1 2018/02/16 07:20:56 fhajny Exp $
include/duo.h
include/shell.h
include/util.h
lib/pkgconfig/libduo.pc
${PLIST.pam}lib/security/pam_duo.la
man/man3/duo.3
man/man8/login_duo.8
${PLIST.pam}man/man8/pam_duo.8
sbin/login_duo
share/doc/duo_unix/AUTHORS
share/doc/duo_unix/CHANGES
share/doc/duo_unix/LICENSE
share/doc/duo_unix/README
share/examples/duo-unix/login_duo.conf
${PLIST.pam}share/examples/duo-unix/pam_duo.conf

View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1 2018/02/16 07:20:56 fhajny Exp $
SHA1 (duo_unix-1.10.1.tar.gz) = 66d08f2286c7f7877ec4bb6770b939e01f7dfb96
RMD160 (duo_unix-1.10.1.tar.gz) = d22f3ffa6ac2578e5ebcc50945270d5f903c8cde
SHA512 (duo_unix-1.10.1.tar.gz) = 45e246e7665e8d9c70ce43eed632371b079e9aec20f6c5d771a7d1de80a0f75d987fb88002de719358511d92d05b27824e539af53836af75a0939e59aae37359
Size (duo_unix-1.10.1.tar.gz) = 472431 bytes
SHA1 (patch-login__duo_Makefile.in) = 8b9079d8ea6a9a1f2a23c5c9146a045789517378

View file

@ -0,0 +1,20 @@
# $NetBSD: options.mk,v 1.1 2018/02/16 07:20:56 fhajny Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.duo-unix
PKG_SUPPORTED_OPTIONS+= pam
PKG_SUGGESTED_OPTIONS= pam
.include "../../mk/bsd.options.mk"
PLIST_VARS+= pam
.if !empty(PKG_OPTIONS:Mpam)
PLIST.pam= yes
CONFIGURE_ARGS+= --with-pam=${PREFIX}/lib/security
CONF_FILES_PERMS+= share/examples/duo-unix/pam_duo.conf \
${PKG_SYSCONFDIR}/pam_duo.conf \
${REAL_ROOT_USER} ${REAL_ROOT_GROUP} 0400
. include "../../mk/pam.buildlink3.mk"
.else
CONFIGURE_ARGS+= --without-pam
.endif

View file

@ -0,0 +1,15 @@
$NetBSD: patch-login__duo_Makefile.in,v 1.1 2018/02/16 07:20:56 fhajny Exp $
Secure a setuid binary.
--- login_duo/Makefile.in.orig 2017-08-15 19:31:47.000000000 +0000
+++ login_duo/Makefile.in
@@ -712,7 +712,7 @@ uninstall-man: uninstall-man8
install-exec-hook:
-chown root $(DESTDIR)$(sbindir)/login_duo && \
- chmod 4755 $(DESTDIR)$(sbindir)/login_duo
+ chmod 4555 $(DESTDIR)$(sbindir)/login_duo
install-data-local:
$(MKDIR_P) $(DESTDIR)$(sysconfdir)