rdesktop: update to 1.9.0.

Provided by Matthias Petermann in PR 54857.

Additionally, remove ssl option per 1.9.0 changelog.

rdesktop (1.9.0)
  * Use GnuTLS and nettle instead of OpenSSL
  * Improved certificate handling
  * Add support for dynamic resize of sessions
  * Add support for alpha cursors
  * Add PulseAudio support
  * Add Kerberos support on macOS
  * Kerberos support no longer requires libgssglue
  * Remove support for rdesktop's custom microphone extension
  * Several fixes to improve compatibility with modern desktops
  * macOS compatibility fixes
  * Improved handling of redirections
  * Many smart card bug fixes
  * Many disk redirection bug fixes
  * Improved logging
  * Lots of other small bug fixes

  -- Pierre Ossman <ossman@cendio.se> 2019-09-18

rdesktop (1.8.6)
  * Fix protocol code handling new licenses

  -- Pierre Ossman <ossman@cendio.se> 2019-05-16

rdesktop (1.8.5)
  * Add bounds checking to protocol handling in order to fix many
    security problems when communicating with a malicious server.

  -- Pierre Ossman <ossman@cendio.se> 2019-05-08
This commit is contained in:
wiz 2020-01-15 15:31:28 +00:00
parent 73a8d88409
commit 03bfc1bfcc
5 changed files with 33 additions and 73 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.49 2019/03/25 19:56:08 markd Exp $
# $NetBSD: Makefile,v 1.50 2020/01/15 15:31:28 wiz Exp $
DISTNAME= rdesktop-1.8.4
PKGREVISION= 1
DISTNAME= rdesktop-1.9.0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GITHUB:=rdesktop/}
GITHUB_RELEASE= v${PKGVERSION_NOREV}
@ -36,6 +35,9 @@ CONFIGURE_ARGS+= --with-sound=alsa
.endif
.include "../../audio/libsamplerate/buildlink3.mk"
.include "../../security/libtasn1/buildlink3.mk"
.include "../../security/nettle/buildlink3.mk"
.include "../../security/gnutls/buildlink3.mk"
.include "../../mk/oss.buildlink3.mk"
.include "../../converters/libiconv/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.26 2019/03/25 19:56:08 markd Exp $
$NetBSD: distinfo,v 1.27 2020/01/15 15:31:28 wiz Exp $
SHA1 (rdesktop-1.8.4.tar.gz) = b937573e3f76a494a2b9092a440c9ea3e862d1f3
RMD160 (rdesktop-1.8.4.tar.gz) = 5ad95433c369a9cff11b765e181d97ac41bf8582
SHA512 (rdesktop-1.8.4.tar.gz) = 9e4f6723eb0baab31ad11f1c5c29a4753c655386c2381d01646b7834c959ffc2ec1e0c2f3f73626255aa018889709758d97387c7563da98bb1b7f269610929ae
Size (rdesktop-1.8.4.tar.gz) = 321448 bytes
SHA1 (patch-aa) = a56f15d51e32b3e53fd1e42736944a6805cbe9e0
SHA1 (patch-ssl.c) = 491b8d8dc8b39d013469fc803177d8163dd42fa3
SHA1 (rdesktop-1.9.0.tar.gz) = cbd6a4dab1f0638fe30354c0d081133562d2ca62
RMD160 (rdesktop-1.9.0.tar.gz) = a403d660585dc4f8433ea885359e4452148a2c98
SHA512 (rdesktop-1.9.0.tar.gz) = e101147b496ae70118c2756bf120007d4748aad9d9917d9ebc0878ffaf35764500861c548ef0528722777555c78e1d3d146b6f3691daa2b8657b0d3a541094f5
Size (rdesktop-1.9.0.tar.gz) = 368980 bytes
SHA1 (patch-Makefile.in) = 46cec50c90b5e7aff2ae0f3f02df7b7a5b709f0a
SHA1 (patch-xwin.c) = 1910b5e237c66961061ef5a2e7404ad22444cee8

View file

@ -1,10 +1,10 @@
$NetBSD: patch-aa,v 1.12 2012/04/26 14:54:29 abs Exp $
$NetBSD: patch-Makefile.in,v 1.1 2020/01/15 15:31:28 wiz Exp $
Use BSD_INSTALL_foo
--- Makefile.in.orig 2006-04-09 20:27:50.000000000 +0200
--- Makefile.in.orig 2019-06-13 12:10:15.000000000 +0000
+++ Makefile.in
@@ -55,25 +55,21 @@ install: installbin installkeymaps insta
@@ -39,25 +39,21 @@ install: installbin installkeymaps insta
.PHONY: installbin
installbin: rdesktop
@ -28,7 +28,7 @@ Use BSD_INSTALL_foo
- mkdir -p $(DESTDIR)$(KEYMAP_PATH)
+ $(BSD_INSTALL_DATA_DIR) $(DESTDIR)$(KEYMAP_PATH)
# Prevent copying the CVS directory
- cp keymaps/?? keymaps/??-?? $(DESTDIR)$(KEYMAP_PATH)
- cp keymaps/?? keymaps/??-?? keymaps/??-??-???? $(DESTDIR)$(KEYMAP_PATH)
- cp keymaps/common $(DESTDIR)$(KEYMAP_PATH)
- cp keymaps/modifiers $(DESTDIR)$(KEYMAP_PATH)
- chmod 644 $(DESTDIR)$(KEYMAP_PATH)/*
@ -36,5 +36,5 @@ Use BSD_INSTALL_foo
+ $(BSD_INSTALL_DATA) keymaps/common $(DESTDIR)$(KEYMAP_PATH)
+ $(BSD_INSTALL_DATA) keymaps/modifiers $(DESTDIR)$(KEYMAP_PATH)
.PHONY: proto
proto:
.PHONY: clean
clean:

View file

@ -1,57 +0,0 @@
$NetBSD: patch-ssl.c,v 1.1 2019/03/25 19:56:08 markd Exp $
Workaround for key caching in OpenSSL > 1.1.0 ( fixes #118)
commit bba4cd2cf0269ec933cb2ccf92743bbcebf3c2da
--- ssl.c.orig 2019-01-02 13:50:34.000000000 +0000
+++ ssl.c
@@ -143,6 +143,11 @@ rdssl_cert_to_rkey(RDSSL_CERT * cert, ui
int nid;
int ret;
+ const unsigned char *p;
+ int pklen;
+
+ RSA *rsa = NULL;
+
/* By some reason, Microsoft sets the OID of the Public RSA key to
the oid for "MD5 with RSA Encryption" instead of "RSA Encryption"
@@ -170,9 +175,28 @@ rdssl_cert_to_rkey(RDSSL_CERT * cert, ui
if ((nid == NID_md5WithRSAEncryption) || (nid == NID_shaWithRSAEncryption))
{
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
DEBUG_RDP5(("Re-setting algorithm type to RSA in server certificate\n"));
X509_PUBKEY_set0_param(key, OBJ_nid2obj(NID_rsaEncryption),
0, NULL, NULL, 0);
+#else
+ if (!X509_PUBKEY_get0_param(NULL, &p, &pklen, NULL, key)) {
+ error("failed to get algorithm used for public key");
+
+ return NULL;
+ }
+
+ if (!(rsa = d2i_RSAPublicKey(NULL, &p, pklen))) {
+ error("failed to extract public key from certificate");
+
+ return NULL;
+ }
+
+ lkey = RSAPublicKey_dup(rsa);
+ *key_len = RSA_size(lkey);
+ return lkey;
+#endif
+
}
epk = X509_get_pubkey(cert);
if (NULL == epk)
@@ -229,7 +255,7 @@ rdssl_rkey_get_exp_mod(RDSSL_RKEY * rkey
e = rkey->e;
n = rkey->n;
#else
- RSA_get0_key(rkey, &e, &n, NULL);
+ RSA_get0_key(rkey, &n, &e, NULL);
#endif
if ((BN_num_bytes(e) > (int) max_exp_len) ||

View file

@ -0,0 +1,15 @@
$NetBSD: patch-xwin.c,v 1.1 2020/01/15 15:31:28 wiz Exp $
Workaround for undefined HOST_NAME_MAX on BSD systems
--- xwin.c.orig 2019-06-13 12:10:15.000000000 +0000
+++ xwin.c
@@ -1887,7 +1887,7 @@ static void
set_wm_client_machine(Display * dpy, Window win)
{
XTextProperty tp;
- char hostname[HOST_NAME_MAX];
+ char hostname[sysconf(_SC_HOST_NAME_MAX)];
if (gethostname(hostname, sizeof(hostname)) != 0)
return;