Fix type references to be consistent between class definition and

out-of-line methods. Bump revision.
This commit is contained in:
joerg 2012-11-23 12:26:56 +00:00
parent 2c879bc7ca
commit 03cfa80f52
3 changed files with 38 additions and 3 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.3 2012/10/31 11:19:26 asau Exp $
# $NetBSD: Makefile,v 1.4 2012/11/23 12:26:56 joerg Exp $
#
DISTNAME= pstreams-0.7.0
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=pstreams/}

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2011/10/29 10:39:31 ryoon Exp $
$NetBSD: distinfo,v 1.2 2012/11/23 12:26:56 joerg Exp $
SHA1 (pstreams-0.7.0.tar.gz) = 8300886c0c1783c7b8b1363596d77683cd213e7e
RMD160 (pstreams-0.7.0.tar.gz) = c0841579b88c23793a1ab9f94316a528fc9f98f5
Size (pstreams-0.7.0.tar.gz) = 55536 bytes
SHA1 (patch-Makefile) = eb56361bb436b7609216640728e3a53f5a12875b
SHA1 (patch-pstream.h) = 831f83a56f7dc5cb95772e02da585ffd62a69882

View file

@ -0,0 +1,34 @@
$NetBSD: patch-pstream.h,v 1.1 2012/11/23 12:26:56 joerg Exp $
The fd_type type is not defined in basic_streambuf, so be consistent
with the definition of wpipe() and friends.
--- pstream.h.orig 2010-03-20 14:50:47.000000000 +0000
+++ pstream.h
@@ -1816,7 +1816,7 @@ namespace redi
/** @return a reference to the output file descriptor */
template <typename C, typename T>
- inline typename basic_pstreambuf<C,T>::fd_type&
+ inline typename pstreambuf::fd_type&
basic_pstreambuf<C,T>::wpipe()
{
return wpipe_;
@@ -1824,7 +1824,7 @@ namespace redi
/** @return a reference to the active input file descriptor */
template <typename C, typename T>
- inline typename basic_pstreambuf<C,T>::fd_type&
+ inline typename pstream::fd_type&
basic_pstreambuf<C,T>::rpipe()
{
return rpipe_[rsrc_];
@@ -1832,7 +1832,7 @@ namespace redi
/** @return a reference to the specified input file descriptor */
template <typename C, typename T>
- inline typename basic_pstreambuf<C,T>::fd_type&
+ inline typename pstream::fd_type&
basic_pstreambuf<C,T>::rpipe(buf_read_src which)
{
return rpipe_[which];