Removed devel/py-ipython013 successor devel/py-ipython

This commit is contained in:
adam 2017-09-17 12:24:31 +00:00
parent b346047865
commit 03dcf110c4
9 changed files with 3 additions and 1603 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.2512 2017/09/17 09:30:09 wiz Exp $
# $NetBSD: Makefile,v 1.2513 2017/09/17 12:24:31 adam Exp $
#
COMMENT= Development utilities
@ -1940,7 +1940,6 @@ SUBDIR+= py-ipaddr
SUBDIR+= py-ipykernel
SUBDIR+= py-ipython
SUBDIR+= py-ipython010
SUBDIR+= py-ipython013
SUBDIR+= py-ipython1
SUBDIR+= py-ipython_genutils
SUBDIR+= py-iso-639

View file

@ -1,5 +0,0 @@
The goal of IPython is to create a comprehensive environment for interactive and
exploratory computing. To support this goal, IPython has two main components:
* An enhanced interactive Python shell.
* An architecture for interactive parallel computing.

View file

@ -1,21 +0,0 @@
# $NetBSD: Makefile,v 1.11 2017/01/01 14:43:33 wiz Exp $
DISTNAME= ipython-0.13.2
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= devel lang
MASTER_SITES= http://archive.ipython.org/release/0.13.2/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://ipython.org/
COMMENT= Interactive computing environment for Python
LICENSE= modified-bsd
DEPENDS+= ${PYPKGPREFIX}-readline-[0-9]*:../../devel/py-readline
PYTHON_VERSIONS_INCOMPATIBLE= 34 35 36 # not yet ported as of 0.13.2 (see py-ipython1 package for a compatible version)
USE_LANGUAGES= # none
USE_TOOLS+= gunzip
.include "../../lang/python/distutils.mk"
.include "../../mk/bsd.pkg.mk"

File diff suppressed because it is too large Load diff

View file

@ -1,9 +0,0 @@
$NetBSD: distinfo,v 1.3 2015/11/03 03:29:09 agc Exp $
SHA1 (ipython-0.13.2.tar.gz) = aedffe0cd55dda578f26fabe2a27870ef1b0bb9d
RMD160 (ipython-0.13.2.tar.gz) = afdd4e7fed6b3d23d5577b66671c9b868ef1f847
SHA512 (ipython-0.13.2.tar.gz) = 9ce36c77b8796fb6b990e32fe63ba1f3f2d78eb0440ff5b62597a1c033fd7c6d04ba9d3d4a4171c38c5623b6deeee87b48297f816a9d053f2c3096fc075e28a9
Size (ipython-0.13.2.tar.gz) = 5982733 bytes
SHA1 (patch-ba) = e4fef4a3f58bb773deb3be3894e738807b327ae1
SHA1 (patch-bb) = daaaddd2636ad1608beb0a904320826178d35b45
SHA1 (patch-setupbase.py) = 6e08afb144065c44fc01da35f935291764bb0cab

View file

@ -1,42 +0,0 @@
$NetBSD: patch-ba,v 1.1 2012/12/17 11:57:44 drochner Exp $
--- IPython/utils/tests/test_process.py.orig 2011-12-19 01:25:33.000000000 +0000
+++ IPython/utils/tests/test_process.py
@@ -102,30 +102,30 @@ class SubProcessTestCase(TestCase, tt.Te
self.mktmp('\n'.join(lines))
def test_system(self):
- status = system('python "%s"' % self.fname)
+ status = system('"%s" "%s"' % (sys.executable, self.fname))
self.assertEquals(status, 0)
def test_system_quotes(self):
- status = system('python -c "import sys"')
+ status = system('"%s" -c "import sys"' % sys.executable)
self.assertEquals(status, 0)
def test_getoutput(self):
- out = getoutput('python "%s"' % self.fname)
+ out = getoutput('"%s" "%s"' % (sys.executable, self.fname))
self.assertEquals(out, 'on stdout')
def test_getoutput_quoted(self):
- out = getoutput('python -c "print (1)"')
+ out = getoutput('"%s" -c "print (1)"' % sys.executable)
self.assertEquals(out.strip(), '1')
#Invalid quoting on windows
@dec.skip_win32
def test_getoutput_quoted2(self):
- out = getoutput("python -c 'print (1)'")
+ out = getoutput("'%s' -c 'print (1)'" % sys.executable)
self.assertEquals(out.strip(), '1')
- out = getoutput("python -c 'print (\"1\")'")
+ out = getoutput("'%s' -c 'print (\"1\")'" % sys.executable)
self.assertEquals(out.strip(), '1')
def test_getoutput(self):
- out, err = getoutputerror('python "%s"' % self.fname)
+ out, err = getoutputerror('"%s" "%s"' % (sys.executable, self.fname))
self.assertEquals(out, 'on stdout')
self.assertEquals(err, 'on stderr')

View file

@ -1,13 +0,0 @@
$NetBSD: patch-bb,v 1.2 2013/10/29 18:18:46 drochner Exp $
--- IPython/core/tests/test_interactiveshell.py.orig 2013-04-05 19:21:31.000000000 +0000
+++ IPython/core/tests/test_interactiveshell.py
@@ -399,7 +399,7 @@ class TestSystemRaw(unittest.TestCase):
def test_1(self):
"""Test system_raw with non-ascii cmd
"""
- cmd = ur'''python -c "'åäö'" '''
+ cmd = ur'''"%s" -c "'åäö'" ''' % sys.executable
ip.system_raw(cmd)
def test_exit_code(self):

View file

@ -1,13 +0,0 @@
$NetBSD: patch-setupbase.py,v 1.1 2012/12/17 11:57:44 drochner Exp $
--- setupbase.py.orig 2012-10-21 00:30:54.000000000 +0000
+++ setupbase.py
@@ -201,7 +201,7 @@ def find_data_files():
"""
docdirbase = pjoin('share', 'doc', 'ipython')
- manpagebase = pjoin('share', 'man', 'man1')
+ manpagebase = pjoin(os.environ.get('PKGMANDIR'), 'man1')
# Simple file lists can be made by hand
manpages = [f for f in glob(pjoin('docs','man','*.1.gz')) if isfile(f)]

View file

@ -1,4 +1,4 @@
$NetBSD: CHANGES-2017,v 1.3889 2017/09/17 12:03:44 adam Exp $
$NetBSD: CHANGES-2017,v 1.3890 2017/09/17 12:25:29 adam Exp $
Changes to the packages collection and infrastructure in 2017:
@ -5451,3 +5451,4 @@ Changes to the packages collection and infrastructure in 2017:
Updated devel/p5-Parse-ErrorString-Perl to 0.27 [wiz 2017-09-17]
Updated math/py-sympy to 1.1.1 [adam 2017-09-17]
Updated multimedia/mkvtoolnix to 15.0.0 [adam 2017-09-17]
Removed devel/py-ipython013 successor devel/py-ipython [adam 2017-09-17]