Update to 2.1.1:
2.1.1 - 2014-04-29 ------------------ BUG FIXES * 446: [Windows] fix encoding error when using net_io_counters() on Python 3. (patch by Szigeti Gabor Niif) * 460: [Windows] net_io_counters() wraps after 4G. * 491: [Linux] psutil.net_connections() exceptions. (patch by Alexander Grothe)
This commit is contained in:
parent
53fe0dc8e3
commit
04076b4f64
3 changed files with 6 additions and 39 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.5 2014/04/18 19:58:46 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2014/05/04 17:15:39 wiz Exp $
|
||||
|
||||
DISTNAME= psutil-2.1.0
|
||||
DISTNAME= psutil-2.1.1
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= https://pypi.python.org/packages/source/p/psutil/
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.4 2014/04/18 19:58:46 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.5 2014/05/04 17:15:39 wiz Exp $
|
||||
|
||||
SHA1 (psutil-2.1.0.tar.gz) = 71d17148cfddfd620a93815f3a7e5195c24ea22a
|
||||
RMD160 (psutil-2.1.0.tar.gz) = 435b356e85e20daa8e84fe2e42485bd8b53d92d1
|
||||
Size (psutil-2.1.0.tar.gz) = 211640 bytes
|
||||
SHA1 (psutil-2.1.1.tar.gz) = 0c20a20ed316e69f2b0881530439213988229916
|
||||
RMD160 (psutil-2.1.1.tar.gz) = ea18be7a29190b9753c3e7833a0f7c9c775c9acd
|
||||
Size (psutil-2.1.1.tar.gz) = 216796 bytes
|
||||
SHA1 (patch-psutil_____init____.py) = aa75a84992250e28db01d5fe13a68ed0cdcea883
|
||||
SHA1 (patch-psutil___psnetbsd.py) = 20089b57640a5eb30aeb1f5460624a570f1d3236
|
||||
SHA1 (patch-psutil___psutil__netbsd.c) = c251e097ce5c919537176f16406ad6892db955fc
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
$NetBSD: patch-psutil___psutil__sunos.c,v 1.1 2013/12/07 21:25:24 richard Exp $
|
||||
|
||||
--- psutil/_psutil_sunos.c.orig 2013-11-20 19:29:05.000000000 +0000
|
||||
+++ psutil/_psutil_sunos.c
|
||||
@@ -772,8 +772,9 @@ error:
|
||||
return NULL;
|
||||
}
|
||||
|
||||
-
|
||||
+#ifndef EXPER_IP_AND_ALL_IRES
|
||||
#define EXPER_IP_AND_ALL_IRES (1024+4)
|
||||
+#endif
|
||||
|
||||
// a signaler for connections without an actual status
|
||||
static int PSUTIL_CONN_NONE = 128;
|
||||
@@ -790,7 +791,7 @@ static PyObject*
|
||||
get_process_connections(PyObject* self, PyObject* args)
|
||||
{
|
||||
long pid;
|
||||
- int sd = NULL;
|
||||
+ int sd = 0;
|
||||
mib2_tcpConnEntry_t *tp = NULL;
|
||||
mib2_udpEntry_t *ude;
|
||||
#if defined(AF_INET6)
|
||||
@@ -1059,7 +1060,7 @@ error:
|
||||
Py_XDECREF(py_raddr);
|
||||
Py_DECREF(py_retlist);
|
||||
// TODO : free databuf
|
||||
- if (sd != NULL)
|
||||
+ if (sd > 0)
|
||||
close(sd);
|
||||
return NULL;
|
||||
}
|
Loading…
Reference in a new issue