Fix build on Solaris.
Solaris has no SOL_TCP, but TCP_CORK.
This commit is contained in:
parent
7e4c4d009a
commit
040dba8686
2 changed files with 15 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.18 2009/01/17 13:27:48 adam Exp $
|
||||
$NetBSD: distinfo,v 1.19 2012/12/24 13:45:02 ryoon Exp $
|
||||
|
||||
SHA1 (distcc-3.1.tar.bz2) = 30663e8ff94f13c0553fbfb928adba91814e1b3a
|
||||
RMD160 (distcc-3.1.tar.bz2) = 82229c230e6917b0df7db275460579b02dbf6b60
|
||||
|
@ -8,3 +8,4 @@ SHA1 (patch-ab) = c3a306be0a3576b33f506bd6516d8242ceec07ca
|
|||
SHA1 (patch-ac) = 618015e2954dc54c6db3712381749feb17106647
|
||||
SHA1 (patch-ad) = 79ce3ea1b7dd75dce1654dd31eaa372174f8f5d1
|
||||
SHA1 (patch-ae) = d4e5eba767f08a1c346c0223ddf88e98a5ed7c59
|
||||
SHA1 (patch-src_io.c) = 5c662a4f9af20b5cffbd6285a3b0d6d6c4066571
|
||||
|
|
13
devel/distcc/patches/patch-src_io.c
Normal file
13
devel/distcc/patches/patch-src_io.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-src_io.c,v 1.1 2012/12/24 13:45:02 ryoon Exp $
|
||||
|
||||
--- src/io.c.orig 2008-12-02 21:50:25.000000000 +0000
|
||||
+++ src/io.c
|
||||
@@ -242,7 +242,7 @@ int dcc_writex(int fd, const void *buf,
|
||||
**/
|
||||
int tcp_cork_sock(int POSSIBLY_UNUSED(fd), int POSSIBLY_UNUSED(corked))
|
||||
{
|
||||
-#ifdef TCP_CORK
|
||||
+#if defined(TCP_CORK) && defined(SOL_TCP)
|
||||
if (!dcc_getenv_bool("DISTCC_TCP_CORK", 1))
|
||||
return 0;
|
||||
|
Loading…
Reference in a new issue