Initial import of avahi-0.6.23, packaged for pkgsrc-wip by Adrian Portelli,

then majorly reworked by myself. You can blame us both now ;)

Avahi is an Implementation the DNS Service Discovery and Multicast DNS
specifications for Zeroconf Computing. It uses D-BUS for communication
between user applications and a system daemon. The daemon is used to
coordinate application efforts in caching replies, necessary to minimize
the traffic imposed on networks.
This commit is contained in:
wiz 2008-12-20 17:36:14 +00:00
parent c262953d55
commit 0458939a92
17 changed files with 503 additions and 0 deletions

5
net/avahi/DESCR Normal file
View file

@ -0,0 +1,5 @@
Avahi is an Implementation the DNS Service Discovery and Multicast DNS
specifications for Zeroconf Computing. It uses D-BUS for communication
between user applications and a system daemon. The daemon is used to
coordinate application efforts in caching replies, necessary to minimize
the traffic imposed on networks.

106
net/avahi/Makefile Normal file
View file

@ -0,0 +1,106 @@
# $NetBSD: Makefile,v 1.1.1.1 2008/12/20 17:36:14 wiz Exp $
DISTNAME= avahi-0.6.23
CATEGORIES= net
MASTER_SITES= http://avahi.org/download/
MAINTAINER= adrianp@NetBSD.org
HOMEPAGE= http://avahi.org/
COMMENT= Facilitate service discovery on a local network
GNU_CONFIGURE= YES
USE_DIRS+= xdg-1.4
USE_LIBTOOL= YES
USE_PKGINSTALL= YES
USE_PKGLOCALEDIR= YES
USE_TOOLS+= pkg-config gmake intltool
MAKE_JOBS_SAFE= no
PKGCONFIG_OVERRIDE+= avahi-client.pc.in
PKGCONFIG_OVERRIDE+= avahi-compat-howl.pc.in
PKGCONFIG_OVERRIDE+= avahi-compat-libdns_sd.pc.in
PKGCONFIG_OVERRIDE+= avahi-core.pc.in
PKGCONFIG_OVERRIDE+= avahi-glib.pc.in
PKGCONFIG_OVERRIDE+= avahi-gobject.pc.in
PKGCONFIG_OVERRIDE+= avahi-qt3.pc.in
PKGCONFIG_OVERRIDE+= avahi-qt4.pc.in
PKGCONFIG_OVERRIDE+= avahi-sharp.pc.in
PKGCONFIG_OVERRIDE+= avahi-ui-sharp.pc.in
PKGCONFIG_OVERRIDE+= avahi-ui.pc.in
AVAHI_USER= avahi
AVAHI_GROUP= avahi
RCD_SCRIPTS= avahidaemon
BUILD_DEFS= VARBASE PKG_SYSCONFBASE
PLIST_SRC= ${PKGDIR}/PLIST
PKG_SYSCONFSUBDIR= avahi
USE_LANGUAGES= c c++
MAKE_DIRS= ${PKG_SYSCONFDIR}/services
PKG_USERS= ${AVAHI_USER}:${AVAHI_GROUP}::Avahi\ user:/nonexistent
PKG_GROUPS= ${AVAHI_GROUP}
.include "options.mk"
.if ${OPSYS} == "NetBSD"
CFLAGS+= -D_NETBSD_SOURCE
.endif
PLIST_SRC+= ${PKGDIR}/PLIST.shared
CONF_FILES+= ${PREFIX}/share/examples/avahi/avahi-daemon.conf \
${PKG_SYSCONFDIR}/avahi-daemon.conf
CONF_FILES+= ${PREFIX}/share/examples/avahi/hosts \
${PKG_SYSCONFDIR}/hosts
CONF_FILES+= ${PREFIX}/share/examples/avahi/avahi-dnsconfd.action \
${PKG_SYSCONFDIR}/avahi-dnsconfd.action
CONF_FILES+= ${PREFIX}/share/examples/avahi/ssh.service \
${PKG_SYSCONFDIR}/services/ssh.service
CONF_FILES+= ${PREFIX}/share/examples/avahi/avahi-dbus.conf \
${PREFIX}/etc/dbus-1/system.d/avahi-dbus.conf
CONFIGURE_ARGS+= --with-avahi-user=${AVAHI_USER:Q}
CONFIGURE_ARGS+= --with-avahi-group=${AVAHI_GROUP:Q}
CONFIGURE_ARGS+= --localstatedir=${VARBASE:Q}
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFBASE}
CONFIGURE_ARGS+= --disable-qt3
CONFIGURE_ARGS+= --disable-qt4
CONFIGURE_ARGS+= --disable-mono
CONFIGURE_ARGS+= --disable-monodoc
CONFIGURE_ARGS+= --disable-doxygen-doc
CONFIGURE_ARGS+= --disable-doxygen-dot
CONFIGURE_ARGS+= --disable-doxygen-html
CONFIGURE_ARGS+= --disable-xmltoman
CONFIGURE_ARGS+= --disable-autoipd
post-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/avahi
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/avahi
${MKDIR} ${PKG_SYSCONFDIR}/services
${INSTALL_DATA} ${WRKSRC}/avahi-daemon/avahi-daemon.conf \
${PREFIX}/share/examples/avahi
${INSTALL_DATA} ${WRKSRC}/avahi-daemon/hosts \
${PREFIX}/share/examples/avahi
${INSTALL_DATA} ${WRKSRC}/avahi-dnsconfd/avahi-dnsconfd.action \
${PREFIX}/share/examples/avahi
${INSTALL_DATA} ${WRKSRC}/avahi-daemon/ssh.service \
${PREFIX}/share/examples/avahi
${INSTALL_DATA} ${WRKSRC}/avahi-daemon/avahi-dbus.conf \
${PREFIX}/share/examples/avahi/avahi-dbus.conf
${INSTALL_DATA} ${WRKSRC}/docs/HACKING ${PREFIX}/share/doc/avahi
${INSTALL_DATA} ${WRKSRC}/docs/INSTALL ${PREFIX}/share/doc/avahi
${INSTALL_DATA} ${WRKSRC}/docs/NEWS ${PREFIX}/share/doc/avahi
${INSTALL_DATA} ${WRKSRC}/docs/README ${PREFIX}/share/doc/avahi
${INSTALL_DATA} ${WRKSRC}/docs/TODO ${PREFIX}/share/doc/avahi
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../devel/glib2/buildlink3.mk"
.include "../../devel/libdaemon/buildlink3.mk"
.include "../../devel/libglade/buildlink3.mk"
.include "../../sysutils/dbus/buildlink3.mk"
.include "../../textproc/expat/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

125
net/avahi/PLIST Normal file
View file

@ -0,0 +1,125 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2008/12/20 17:36:14 wiz Exp $
bin/avahi-browse
bin/avahi-browse-domains
bin/avahi-discover-standalone
bin/avahi-publish
bin/avahi-publish-address
bin/avahi-publish-service
bin/avahi-resolve
bin/avahi-resolve-address
bin/avahi-resolve-host-name
bin/avahi-set-host-name
bin/bshell
bin/bssh
bin/bvnc
include/avahi-client/client.h
include/avahi-client/lookup.h
include/avahi-client/publish.h
include/avahi-common/address.h
include/avahi-common/alternative.h
include/avahi-common/cdecl.h
include/avahi-common/defs.h
include/avahi-common/domain.h
include/avahi-common/error.h
include/avahi-common/gccmacro.h
include/avahi-common/llist.h
include/avahi-common/malloc.h
include/avahi-common/rlist.h
include/avahi-common/simple-watch.h
include/avahi-common/strlst.h
include/avahi-common/thread-watch.h
include/avahi-common/timeval.h
include/avahi-common/watch.h
include/avahi-core/core.h
include/avahi-core/log.h
include/avahi-core/lookup.h
include/avahi-core/publish.h
include/avahi-core/rr.h
include/avahi-glib/glib-malloc.h
include/avahi-glib/glib-watch.h
include/avahi-gobject/ga-client.h
include/avahi-gobject/ga-entry-group.h
include/avahi-gobject/ga-enums.h
include/avahi-gobject/ga-error.h
include/avahi-gobject/ga-record-browser.h
include/avahi-gobject/ga-service-browser.h
include/avahi-gobject/ga-service-resolver.h
include/avahi-ui/avahi-ui.h
lib/libavahi-client.la
lib/libavahi-common.la
lib/libavahi-core.la
lib/libavahi-glib.la
lib/libavahi-gobject.la
lib/libavahi-ui.la
lib/pkgconfig/avahi-client.pc
lib/pkgconfig/avahi-core.pc
lib/pkgconfig/avahi-glib.pc
lib/pkgconfig/avahi-gobject.pc
lib/pkgconfig/avahi-ui.pc
man/man1/avahi-browse-domains.1
man/man1/avahi-browse.1
man/man1/avahi-publish-address.1
man/man1/avahi-publish-service.1
man/man1/avahi-publish.1
man/man1/avahi-resolve-address.1
man/man1/avahi-resolve-host-name.1
man/man1/avahi-resolve.1
man/man1/avahi-set-host-name.1
man/man1/bssh.1
man/man1/bvnc.1
man/man5/avahi-daemon.conf.5
man/man5/avahi.hosts.5
man/man5/avahi.service.5
man/man8/avahi-daemon.8
man/man8/avahi-dnsconfd.8
man/man8/avahi-dnsconfd.action.8
sbin/avahi-daemon
sbin/avahi-dnsconfd
share/applications/bssh.desktop
share/applications/bvnc.desktop
share/avahi/avahi-service.dtd
share/avahi/interfaces/avahi-discover.glade
share/avahi/introspection/AddressResolver.introspect
share/avahi/introspection/DomainBrowser.introspect
share/avahi/introspection/EntryGroup.introspect
share/avahi/introspection/HostNameResolver.introspect
share/avahi/introspection/RecordBrowser.introspect
share/avahi/introspection/Server.introspect
share/avahi/introspection/ServiceBrowser.introspect
share/avahi/introspection/ServiceResolver.introspect
share/avahi/introspection/ServiceTypeBrowser.introspect
share/avahi/service-types
share/doc/avahi/HACKING
share/doc/avahi/INSTALL
share/doc/avahi/NEWS
share/doc/avahi/README
share/doc/avahi/TODO
share/examples/avahi/avahi-daemon.conf
share/examples/avahi/avahi-dbus.conf
share/examples/avahi/avahi-dnsconfd.action
share/examples/avahi/hosts
share/examples/avahi/ssh.service
share/examples/rc.d/avahidaemon
share/locale/de/LC_MESSAGES/avahi.mo
share/locale/en_AU/LC_MESSAGES/avahi.mo
share/locale/en_CA/LC_MESSAGES/avahi.mo
share/locale/en_GB/LC_MESSAGES/avahi.mo
share/locale/en_NZ/LC_MESSAGES/avahi.mo
share/locale/fr/LC_MESSAGES/avahi.mo
share/locale/it/LC_MESSAGES/avahi.mo
share/locale/pl/LC_MESSAGES/avahi.mo
share/locale/pt_BR/LC_MESSAGES/avahi.mo
share/locale/ru/LC_MESSAGES/avahi.mo
share/locale/sr/LC_MESSAGES/avahi.mo
share/locale/sr@latin/LC_MESSAGES/avahi.mo
share/locale/zh_CN/LC_MESSAGES/avahi.mo
@dirrm share/doc/avahi
@dirrm share/avahi/introspection
@comment in xdg-dirs: @dirrm share/applications
@dirrm include/avahi-ui
@dirrm include/avahi-gobject
@dirrm include/avahi-glib
@dirrm include/avahi-core
@dirrm include/avahi-common
@dirrm include/avahi-client
@comment in dbus: @dirrm etc/dbus-1/system.d

27
net/avahi/PLIST.howl Normal file
View file

@ -0,0 +1,27 @@
@comment $NetBSD: PLIST.howl,v 1.1.1.1 2008/12/20 17:36:14 wiz Exp $
include/avahi-compat-howl/corby/buffer.h
include/avahi-compat-howl/corby/channel.h
include/avahi-compat-howl/corby/corby.h
include/avahi-compat-howl/corby/message.h
include/avahi-compat-howl/corby/object.h
include/avahi-compat-howl/corby/orb.h
include/avahi-compat-howl/discovery/discovery.h
include/avahi-compat-howl/discovery/text_record.h
include/avahi-compat-howl/howl.h
include/avahi-compat-howl/rendezvous/rendezvous.h
include/avahi-compat-howl/rendezvous/text_record.h
include/avahi-compat-howl/salt/address.h
include/avahi-compat-howl/salt/debug.h
include/avahi-compat-howl/salt/interface.h
include/avahi-compat-howl/salt/platform.h
include/avahi-compat-howl/salt/salt.h
include/avahi-compat-howl/salt/signal.h
include/avahi-compat-howl/salt/socket.h
include/avahi-compat-howl/salt/time.h
lib/libhowl.la
lib/pkgconfig/avahi-compat-howl.pc
@dirrm include/avahi-compat-howl/salt
@dirrm include/avahi-compat-howl/rendezvous
@dirrm include/avahi-compat-howl/discovery
@dirrm include/avahi-compat-howl/corby
@dirrm include/avahi-compat-howl

3
net/avahi/PLIST.pygdbm Normal file
View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST.pygdbm,v 1.1.1.1 2008/12/20 17:36:14 wiz Exp $
lib/avahi/service-types.db
${PYSITELIB}/avahi/ServiceTypeDatabase.py

20
net/avahi/PLIST.python Normal file
View file

@ -0,0 +1,20 @@
@comment $NetBSD: PLIST.python,v 1.1.1.1 2008/12/20 17:36:14 wiz Exp $
${PYSITELIB}/avahi/__init__.py
${PYSITELIB}/avahi/__init__.pyc
${PYSITELIB}/avahi/__init__.pyo
${PYSITELIB}/avahi_discover/__init__.py
${PYSITELIB}/avahi_discover/__init__.pyc
${PYSITELIB}/avahi_discover/__init__.pyo
${PYSITELIB}/avahi_discover/SimpleGladeApp.py
${PYSITELIB}/avahi_discover/SimpleGladeApp.pyc
${PYSITELIB}/avahi_discover/SimpleGladeApp.pyo
bin/avahi-bookmarks
bin/avahi-discover
bin/avahi-set-host-name
man/man1/avahi-bookmarks.1
man/man1/avahi-discover.1
man/man1/avahi-set-host-name.1
share/applications/avahi-discover.desktop
share/avahi/interfaces/avahi-discover.glade
@dirrm ${PYSITELIB}/avahi_discover
@dirrm ${PYSITELIB}/avahi

9
net/avahi/PLIST.shared Normal file
View file

@ -0,0 +1,9 @@
@comment $NetBSD: PLIST.shared,v 1.1.1.1 2008/12/20 17:36:14 wiz Exp $
@unexec ${RMDIR} %D/share/examples/avahi 2>/dev/null || ${TRUE}
@unexec ${RMDIR} %D/share/avahi/introspection 2>/dev/null || ${TRUE}
@unexec ${RMDIR} %D/share/avahi/interfaces 2>/dev/null || ${TRUE}
@unexec ${RMDIR} %D/share/avahi 2>/dev/null || ${TRUE}
@unexec ${RMDIR} %D/lib/avahi 2>/dev/null || ${TRUE}
@unexec ${RMDIR} %D/etc/avahi/services 2>/dev/null || ${TRUE}
@unexec ${RMDIR} %D/etc/avahi 2>/dev/null || ${TRUE}
@comment in xdg-dirs: @dirrm share/applications

29
net/avahi/buildlink3.mk Normal file
View file

@ -0,0 +1,29 @@
# $NetBSD: buildlink3.mk,v 1.1.1.1 2008/12/20 17:36:14 wiz Exp $
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
AVAHI_BUILDLINK3_MK:= ${AVAHI_BUILDLINK3_MK}+
.if ${BUILDLINK_DEPTH} == "+"
BUILDLINK_DEPENDS+= avahi
.endif
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Navahi}
BUILDLINK_PACKAGES+= avahi
BUILDLINK_ORDER:= ${BUILDLINK_ORDER} ${BUILDLINK_DEPTH}avahi
.if ${AVAHI_BUILDLINK3_MK} == "+"
BUILDLINK_API_DEPENDS.avahi+= avahi>=0.6.23
BUILDLINK_PKGSRCDIR.avahi?= ../../net/avahi
.endif # AVAHI_BUILDLINK3_MK
pkgbase := avahi
.include "../../mk/pkg-build-options.mk"
.if !empty(PKG_BUILD_OPTIONS.avahi:Mgdbm)
. include "../../databases/gdbm/buildlink3.mk"
.endif
.include "../../devel/glib2/buildlink3.mk"
.include "../../sysutils/dbus/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}

11
net/avahi/distinfo Normal file
View file

@ -0,0 +1,11 @@
$NetBSD: distinfo,v 1.1.1.1 2008/12/20 17:36:14 wiz Exp $
SHA1 (avahi-0.6.23.tar.gz) = 54a0d1944e43805886aafccaf5cc3ec567f5cc9e
RMD160 (avahi-0.6.23.tar.gz) = cdb24199bb9d48eba0a98097b4fe5aee94b8367c
Size (avahi-0.6.23.tar.gz) = 1104410 bytes
SHA1 (patch-aa) = a7ef1cd3ad4ecdbb0668b544f7ea1fc4497c4dce
SHA1 (patch-ab) = 8e29c8b2b9a1d52fba97360c30bb3ba26f657198
SHA1 (patch-ac) = 0484dc5e663fd299f46d15c283fb6fde4aab3537
SHA1 (patch-ad) = 9966ae9fd0d715fa735efc3b92b2cabe6de53b48
SHA1 (patch-ae) = ec99b721253b0181ae12ab392d98e79ede30ddba
SHA1 (patch-af) = 57a788ca492f15c0e05870ea5eb6c4048b30b9c5

View file

@ -0,0 +1,22 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: avahidaemon.sh,v 1.1.1.1 2008/12/20 17:36:14 wiz Exp $
#
# PROVIDE: avahidaemon
# REQUIRE: DAEMON
# KEYWORD: shutdown
#
if [ -f /etc/rc.subr ]
then
. /etc/rc.subr
fi
name="avahidaemon"
rcvar=${name}
command="@PREFIX@/sbin/avahi-daemon"
required_files="@PREFIX@/etc/avahi/avahi-daemon.conf"
avahidaemon_flags="-D"
load_rc_config $name
run_rc_command "$1"

48
net/avahi/options.mk Normal file
View file

@ -0,0 +1,48 @@
# $NetBSD: options.mk,v 1.1.1.1 2008/12/20 17:36:14 wiz Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.avahi
PKG_SUPPORTED_OPTIONS= avahi-howl gdbm python
.include "../../mk/bsd.options.mk"
###
### Enable compatibility layer for HOWL
###
.if !empty(PKG_OPTIONS:Mavahi-howl)
CONFIGURE_ARGS+= --enable-compat-howl
PLIST_SRC+= ${PKGDIR}/PLIST.howl
.endif
###
### Enable gdbm support
###
.if !empty(PKG_OPTIONS:Mgdbm)
. include "../../databases/gdbm/buildlink3.mk"
.else
CONFIGURE_ARGS+= --disable-gdbm
.endif
###
### Enable python support
###
.if !empty(PKG_OPTIONS:Mpython)
. include "../../lang/python/application.mk"
. include "../../lang/python/extension.mk"
PYTHON_VERSIONS_ACCEPTED= 25 24
PLIST_SUBST+= PYSITELIB=${PYSITELIB}
. include "../../sysutils/py-dbus/buildlink3.mk"
. include "../../x11/py-gtk2/buildlink3.mk"
DEPENDS+= ${PYPKGPREFIX}-libxml2-[0-9]*:../../textproc/py-libxml2
DEPENDS+= ${PYPKGPREFIX}-expat-[0-9]*:../../textproc/py-expat
### If python and gdbm are enabled we need py-gdbm as well
. if !empty(PKG_OPTIONS:Mgdbm)
DEPENDS+= ${PYPKGPREFIX}-gdbm-[0-9]*:../../databases/py-gdbm
PLIST_SRC+= ${PKGDIR}/PLIST.pygdbm
. endif
PLIST_SRC+= ${PKGDIR}/PLIST.python
.else
CONFIGURE_ARGS+= --disable-python
CONFIGURE_ARGS+= --disable-python-dbus
CONFIGURE_ARGS+= --disable-pygtk
.endif

View file

@ -0,0 +1,18 @@
$NetBSD: patch-aa,v 1.1.1.1 2008/12/20 17:36:14 wiz Exp $
--- avahi-core/iface-pfroute.c.orig 2006-06-21 22:35:00.000000000 +0100
+++ avahi-core/iface-pfroute.c
@@ -48,6 +48,13 @@
#include "iface-pfroute.h"
#include "util.h"
+#ifdef __NetBSD__
+#define lifreq if_laddrreq
+#define lifr_addr iflr_addr
+#define lifr_flags iflr_flags
+#define SIOCGLIFFLAGS SIOCGIFFLAGS
+#endif
+
static int bitcount (unsigned int n)
{
int count=0 ;

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1.1.1 2008/12/20 17:36:14 wiz Exp $
--- avahi-common/Makefile.in.orig 2008-12-04 12:00:32.000000000 +0000
+++ avahi-common/Makefile.in
@@ -601,7 +601,7 @@ clean-libLTLIBRARIES:
rm -f "$${dir}/so_locations"; \
done
libavahi-common.la: $(libavahi_common_la_OBJECTS) $(libavahi_common_la_DEPENDENCIES)
- $(libavahi_common_la_LINK) -rpath $(libdir) $(libavahi_common_la_OBJECTS) $(libavahi_common_la_LIBADD) $(LIBS)
+ $(libavahi_common_la_LINK) -rpath $(libdir) $(libavahi_common_la_OBJECTS) $(libavahi_common_la_LIBADD) $(LIBS) $(INTLLIBS)
clean-noinstPROGRAMS:
@list='$(noinst_PROGRAMS)'; for p in $$list; do \

View file

@ -0,0 +1,28 @@
$NetBSD: patch-ac,v 1.1.1.1 2008/12/20 17:36:14 wiz Exp $
--- avahi-daemon/Makefile.in.orig 2008-06-24 00:20:31.000000000 +0100
+++ avahi-daemon/Makefile.in
@@ -505,19 +505,15 @@ AM_CFLAGS = -I$(top_srcdir) '-DDEBUG_TRA
@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@ini_file_parser_test_CFLAGS = $(AM_CFLAGS)
@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@ini_file_parser_test_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la ../avahi-core/libavahi-core.la
-@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@pkgsysconf_DATA = \
-@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@ avahi-daemon.conf \
-@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@ hosts
-
-@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@service_DATA = \
-@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@ ssh.service \
-@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@ sftp-ssh.service
+@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@pkgsysconf_DATA =
+
+@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@service_DATA =
@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@pkgdata_DATA = \
@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@ avahi-service.dtd
@HAVE_DBUS_TRUE@@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@dbusservicedir = $(DBUS_SYS_DIR)
-@HAVE_DBUS_TRUE@@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@dbusservice_DATA = avahi-dbus.conf
+@HAVE_DBUS_TRUE@@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@dbusservice_DATA =
@HAVE_DBUS_TRUE@@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@introspection_DATA = \
@HAVE_DBUS_TRUE@@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@ Server.introspect \
@HAVE_DBUS_TRUE@@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@ EntryGroup.introspect \

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ad,v 1.1.1.1 2008/12/20 17:36:14 wiz Exp $
--- avahi-dnsconfd/Makefile.in.orig 2008-06-24 00:20:31.000000000 +0100
+++ avahi-dnsconfd/Makefile.in
@@ -367,7 +367,7 @@ top_srcdir = @top_srcdir@
@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@avahi_dnsconfd_SOURCES = main.c
@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@avahi_dnsconfd_CFLAGS = $(AM_CFLAGS) $(LIBDAEMON_CFLAGS)
@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@avahi_dnsconfd_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la $(LIBDAEMON_LIBS)
-@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@pkgsysconf_SCRIPTS = avahi-dnsconfd.action
+@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@pkgsysconf_SCRIPTS =
EXTRA_DIST = avahi-dnsconfd.action
all: all-am

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ae,v 1.1.1.1 2008/12/20 17:36:14 wiz Exp $
--- initscript/fedora/avahi-dnsconfd.in.orig 2008-06-18 00:13:44.000000000 +0100
+++ initscript/fedora/avahi-dnsconfd.in
@@ -12,7 +12,7 @@
AVAHI_BIN=@sbindir@/avahi-dnsconfd
-if [ "$1" == 'status' ]; then
+if [ "$1" = 'status' ]; then
test -x $AVAHI_BIN || exit 4
else
test -x $AVAHI_BIN || exit 5

View file

@ -0,0 +1,13 @@
$NetBSD: patch-af,v 1.1.1.1 2008/12/20 17:36:14 wiz Exp $
--- initscript/fedora/avahi-daemon.in.orig 2008-06-18 00:13:44.000000000 +0100
+++ initscript/fedora/avahi-daemon.in
@@ -12,7 +12,7 @@
AVAHI_BIN=@sbindir@/avahi-daemon
-if [ "$1" == 'status' ]; then
+if [ "$1" = 'status' ]; then
test -x $AVAHI_BIN || exit 4
else
test -x $AVAHI_BIN || exit 5