py-ipython: updated to 7.7.0
IPython 7.7.0 contain multiple bug fixes and documentation updates; Here are a few of the outstanding issue fixed: - Fix a bug introduced in 7.6 where the ``%matplotlib`` magic would fail on previously acceptable arguments - Fix the manage location on freebsd - Fix error message about aliases after ``%reset`` call in ipykernel - Fix Duplication completions in emacs We are planning to adopt `NEP29 <https://github.com/numpy/numpy/pull/14086>`_ (still currently in draft) which may make this minor version of IPython the last one to support Python 3.5 and will make the code base more aggressive toward removing compatibility with older versions of Python. GitHub now support to give only "Triage" permissions to users; if you'd like to help close stale issues and labels issues please reach to us with your GitHub Username and we'll add you to the triage team. It is a great way to start contributing and a path toward getting commit rights.
This commit is contained in:
parent
d7dded3c49
commit
047d25e8a3
3 changed files with 15 additions and 12 deletions
|
@ -1,6 +1,6 @@
|
||||||
# $NetBSD: Makefile,v 1.38 2019/07/06 22:47:18 adam Exp $
|
# $NetBSD: Makefile,v 1.39 2019/08/03 12:31:47 adam Exp $
|
||||||
|
|
||||||
DISTNAME= ipython-7.6.1
|
DISTNAME= ipython-7.7.0
|
||||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||||
CATEGORIES= devel python
|
CATEGORIES= devel python
|
||||||
MASTER_SITES= ${MASTER_SITE_PYPI:=i/ipython/}
|
MASTER_SITES= ${MASTER_SITE_PYPI:=i/ipython/}
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
$NetBSD: distinfo,v 1.18 2019/07/06 22:47:18 adam Exp $
|
$NetBSD: distinfo,v 1.19 2019/08/03 12:31:47 adam Exp $
|
||||||
|
|
||||||
SHA1 (ipython-7.6.1.tar.gz) = 4ab064e9e6f07c4a8613c685877d99d7eb4dcfe1
|
SHA1 (ipython-7.7.0.tar.gz) = bd792eb96caaa5ebd9b62c9cd857c605b7133d20
|
||||||
RMD160 (ipython-7.6.1.tar.gz) = c1ebdd962f6632dd2783ea44688f6967f707ea5d
|
RMD160 (ipython-7.7.0.tar.gz) = c24a892618a61f7ab8d61527acbc0d5061d7dc89
|
||||||
SHA512 (ipython-7.6.1.tar.gz) = e45a83c98587ae8f809a2f917b40d8274ffa56e469b13ebf993211034c5a4d302c8a6a531b54137e71aa2985f617b7408a69323720157d9cd58fbcc38f49b6ae
|
SHA512 (ipython-7.7.0.tar.gz) = fda35fc5df9611030a43b7ec85c3fe28d36bb0f231470def4293add69b595ca2109f5e46d274b3e08059091a5b6786c2f19463d4942ada3038e5737f26facaf7
|
||||||
Size (ipython-7.6.1.tar.gz) = 5197256 bytes
|
Size (ipython-7.7.0.tar.gz) = 5157086 bytes
|
||||||
SHA1 (patch-setupbase.py) = 8cd647afb3f26f19f5b8d872af7835b73615b324
|
SHA1 (patch-setupbase.py) = 241463d5368a4c80c8194244f5c3895196b44da5
|
||||||
|
|
|
@ -1,14 +1,17 @@
|
||||||
$NetBSD: patch-setupbase.py,v 1.2 2014/04/20 10:06:22 imil Exp $
|
$NetBSD: patch-setupbase.py,v 1.3 2019/08/03 12:31:47 adam Exp $
|
||||||
|
|
||||||
Honor PKGMANDIR
|
Honor PKGMANDIR
|
||||||
|
|
||||||
--- setupbase.py.orig 2014-04-02 05:31:02.000000000 +0000
|
--- setupbase.py.orig 2019-07-26 21:57:01.000000000 +0000
|
||||||
+++ setupbase.py
|
+++ setupbase.py
|
||||||
@@ -272,7 +272,7 @@ def find_data_files():
|
@@ -162,10 +162,7 @@ def find_data_files():
|
||||||
Just man pages at this point.
|
Just man pages at this point.
|
||||||
"""
|
"""
|
||||||
|
|
||||||
- manpagebase = pjoin('share', 'man', 'man1')
|
- if "freebsd" in sys.platform:
|
||||||
|
- manpagebase = pjoin('man', 'man1')
|
||||||
|
- else:
|
||||||
|
- manpagebase = pjoin('share', 'man', 'man1')
|
||||||
+ manpagebase = pjoin(os.environ.get('PKGMANDIR'), 'man1')
|
+ manpagebase = pjoin(os.environ.get('PKGMANDIR'), 'man1')
|
||||||
|
|
||||||
# Simple file lists can be made by hand
|
# Simple file lists can be made by hand
|
||||||
|
|
Loading…
Reference in a new issue