Initial import of linc-0.1.21, a network client/server library.
This commit is contained in:
parent
8c6bb35592
commit
0485c0bce5
6 changed files with 129 additions and 0 deletions
12
net/linc/DESCR
Normal file
12
net/linc/DESCR
Normal file
|
@ -0,0 +1,12 @@
|
|||
Linc is a library that eases the task of writing networked servers &
|
||||
clients. It takes care of connection initiation and maintainance,
|
||||
and the details of various transports. It is used by the new ORBit
|
||||
to handle message transmission/receipt.
|
||||
|
||||
Currently supported transports:
|
||||
IPv4 (tested)
|
||||
UNIX domain sockets (tested)
|
||||
IPv6
|
||||
IrDA
|
||||
|
||||
The connections can optionally be encrypted using OpenSSL.
|
20
net/linc/Makefile
Normal file
20
net/linc/Makefile
Normal file
|
@ -0,0 +1,20 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2002/04/23 12:17:22 rh Exp $
|
||||
#
|
||||
|
||||
DISTNAME= linc-0.1.21
|
||||
CATEGORIES= net gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=pre-gnome2/sources/linc/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= rh@netbsd.org
|
||||
HOMEPAGE= http://www.gnome.org/
|
||||
COMMENT= network client/server library
|
||||
|
||||
BUILD_DEPENDS+= gtk-doc-[0-9]*:../../textproc/gtk-doc
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_LIBTOOL= YES
|
||||
|
||||
.include "../../devel/pkgconfig/buildlink.mk"
|
||||
.include "../../devel/glib2/buildlink.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
28
net/linc/PLIST
Normal file
28
net/linc/PLIST
Normal file
|
@ -0,0 +1,28 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2002/04/23 12:17:22 rh Exp $
|
||||
bin/linc-config
|
||||
include/linc-1.0/linc/linc-config.h
|
||||
include/linc-1.0/linc/linc-connection.h
|
||||
include/linc-1.0/linc/linc-protocol.h
|
||||
include/linc-1.0/linc/linc-server.h
|
||||
include/linc-1.0/linc/linc-types.h
|
||||
include/linc-1.0/linc/linc.h
|
||||
lib/liblinc.a
|
||||
lib/liblinc.la
|
||||
lib/liblinc.so
|
||||
lib/liblinc.so.1
|
||||
lib/liblinc.so.1.0
|
||||
lib/pkgconfig/linc.pc
|
||||
share/aclocal/linc.m4
|
||||
share/gtk-doc/html/linc/c4.html
|
||||
share/gtk-doc/html/linc/index.html
|
||||
share/gtk-doc/html/linc/linc-config.html
|
||||
share/gtk-doc/html/linc/linc-linc-config.html
|
||||
share/gtk-doc/html/linc/linc-linc-private.html
|
||||
share/gtk-doc/html/linc/linc-linc-protocol.html
|
||||
share/gtk-doc/html/linc/linc-linc-types.html
|
||||
share/gtk-doc/html/linc/linc-linc.html
|
||||
share/gtk-doc/html/linc/linc-lincconnection.html
|
||||
share/gtk-doc/html/linc/linc-lincserver.html
|
||||
@dirrm share/gtk-doc/html/linc
|
||||
@dirrm include/linc-1.0/linc
|
||||
@dirrm include/linc-1.0
|
51
net/linc/buildlink.mk
Normal file
51
net/linc/buildlink.mk
Normal file
|
@ -0,0 +1,51 @@
|
|||
# $NetBSD: buildlink.mk,v 1.1.1.1 2002/04/23 12:17:22 rh Exp $
|
||||
#
|
||||
# This Makefile fragment is included by packages that use linc.
|
||||
#
|
||||
# To use this Makefile fragment, simply:
|
||||
#
|
||||
# (1) Optionally define BUILDLINK_DEPENDS.linc to the dependency pattern
|
||||
# for the version of linc desired.
|
||||
# (2) Include this Makefile fragment in the package Makefile,
|
||||
# (3) Add ${BUILDLINK_DIR}/include to the front of the C preprocessor's header
|
||||
# search path, and
|
||||
# (4) Add ${BUILDLINK_DIR}/lib to the front of the linker's library search
|
||||
# path.
|
||||
|
||||
.if !defined(LINC_BUILDLINK_MK)
|
||||
LINC_BUILDLINK_MK= # defined
|
||||
|
||||
.include "../../mk/bsd.buildlink.mk"
|
||||
|
||||
BUILDLINK_DEPENDS.linc?= linc>=0.1.21
|
||||
DEPENDS+= ${BUILDLINK_DEPENDS.linc}:../../net/linc
|
||||
|
||||
EVAL_PREFIX+= BUILDLINK_PREFIX.linc=linc
|
||||
BUILDLINK_PREFIX.linc_DEFAULT= ${LOCALBASE}
|
||||
BUILDLINK_FILES.linc= include/linc-1.0/linc/*
|
||||
BUILDLINK_FILES.linc+= lib/liblinc.*
|
||||
|
||||
.include "../../devel/pkgconfig/buildlink.mk"
|
||||
.include "../../devel/glib2/buildlink.mk"
|
||||
|
||||
BUILDLINK_TARGETS.linc= linc-buildlink
|
||||
BUILDLINK_TARGETS.linc+=linc-buildlink-config-wrapper
|
||||
BUILDLINK_TARGETS+= ${BUILDLINK_TARGETS.linc}
|
||||
BUILDLINK_TARGETS+= ${BUILDLINK_PKG_CONFIG}
|
||||
|
||||
BUILDLINK_CONFIG.linc=${BUILDLINK_PREFIX.linc}/bin/linc-config
|
||||
BUILDLINK_CONFIG_WRAPPER.linc=${BUILDLINK_DIR}/bin/linc-config
|
||||
REPLACE_BUILDLINK_SED+= \
|
||||
-e "s|${BUILDLINK_CONFIG_WRAPPER.linc}|${BUILDLINK_CONFIG.linc}|g"
|
||||
|
||||
.if defined(USE_CONFIG_WRAPPER)
|
||||
LINC_CONFIG?= ${BUILDLINK_CONFIG_WRAPPER.linc}
|
||||
CONFIGURE_ENV+= LINC_CONFIG="${LINC_CONFIG}"
|
||||
MAKE_ENV+= LINC_CONFIG="${LINC_CONFIG}"
|
||||
.endif
|
||||
|
||||
pre-configure: ${BUILDLINK_TARGETS}
|
||||
linc-buildlink: _BUILDLINK_USE
|
||||
linc-buildlink-config-wrapper: _BUILDLINK_CONFIG_WRAPPER_USE
|
||||
|
||||
.endif # LINC_BUILDLINK_MK
|
5
net/linc/distinfo
Normal file
5
net/linc/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2002/04/23 12:17:22 rh Exp $
|
||||
|
||||
SHA1 (linc-0.1.21.tar.bz2) = 19243478581e2e400d2ea4912c90a3a9f1fe093e
|
||||
Size (linc-0.1.21.tar.bz2) = 175550 bytes
|
||||
SHA1 (patch-aa) = 1643b8decf11568a2aaaf8cbe8c0e0989a897196
|
13
net/linc/patches/patch-aa
Normal file
13
net/linc/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2002/04/23 12:17:22 rh Exp $
|
||||
|
||||
--- docs/Makefile.in.orig Tue Apr 23 20:27:20 2002
|
||||
+++ docs/Makefile.in
|
||||
@@ -327,8 +327,6 @@
|
||||
echo '-- Installing '$$i ; \
|
||||
$(INSTALL_DATA) $$i $(DESTDIR)$(TARGET_DIR); \
|
||||
done; \
|
||||
- echo '-- Installing $(srcdir)/html/index.sgml' ; \
|
||||
- $(INSTALL_DATA) $(srcdir)/html/index.sgml $(DESTDIR)$(TARGET_DIR); \
|
||||
fi)
|
||||
|
||||
#
|
Loading…
Reference in a new issue