Add a patch to fix reading header lines from 511 to 1023 chars.
This commit is contained in:
parent
a6b6c86c77
commit
04a7dcd391
3 changed files with 24 additions and 3 deletions
|
@ -1,9 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.45 2012/10/03 00:20:18 asau Exp $
|
||||
# $NetBSD: Makefile,v 1.46 2019/11/16 22:22:45 rhialto Exp $
|
||||
#
|
||||
|
||||
DISTNAME= uudeview-0.5.20
|
||||
PKGNAME= uulib-0.5.20
|
||||
PKGREVISION= 5
|
||||
PKGREVISION= 6
|
||||
CATEGORIES= converters
|
||||
MASTER_SITES= http://www.fpx.de/fp/Software/UUDeview/download/
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.14 2017/07/07 11:19:44 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.15 2019/11/16 22:22:45 rhialto Exp $
|
||||
|
||||
SHA1 (uudeview-0.5.20.tar.gz) = 2c6ab7d355b545218bd0877d598bd5327d9fd125
|
||||
RMD160 (uudeview-0.5.20.tar.gz) = 9bb52fa3ad4979383ff16d1e8d8a302c5c794c66
|
||||
|
@ -7,3 +7,4 @@ Size (uudeview-0.5.20.tar.gz) = 261574 bytes
|
|||
SHA1 (patch-aa) = 2f495c982bb8a96ffd60f1bcd4ce65e6c226083c
|
||||
SHA1 (patch-ab) = f23ca7945a0697dc8e49ba9c7765bfa655ed8566
|
||||
SHA1 (patch-ac) = e167fedf6ca5933d027407715c4275d60d1ee795
|
||||
SHA1 (patch-uulib_uulib.c) = fcfc3b3450f49a58b827553c8588abf09dfb2310
|
||||
|
|
20
converters/uulib/patches/patch-uulib_uulib.c
Normal file
20
converters/uulib/patches/patch-uulib_uulib.c
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-uulib_uulib.c,v 1.1 2019/11/16 22:22:45 rhialto Exp $
|
||||
|
||||
Use the full length of the buffer to read (potentially long)
|
||||
header lines. Patch taken from "nget+uulib v0.27.1 tarball"
|
||||
at http://nget.sourceforge.net/.
|
||||
|
||||
--- uulib/uulib.c.orig 2003-09-29 23:27:47.000000000 +0000
|
||||
+++ uulib/uulib.c
|
||||
@@ -1103,9 +1103,9 @@ UUInfoFile (uulist *thefile, void *opaqu
|
||||
|
||||
while (!feof (inpfile) &&
|
||||
(uu_fast_scanning || ftell(inpfile) < maxpos)) {
|
||||
- if (_FP_fgets (uugen_inbuffer, 511, inpfile) == NULL)
|
||||
+ if (_FP_fgets (uugen_inbuffer, 1023, inpfile) == NULL)
|
||||
break;
|
||||
- uugen_inbuffer[511] = '\0';
|
||||
+ uugen_inbuffer[1023] = '\0';
|
||||
|
||||
if (ferror (inpfile))
|
||||
break;
|
Loading…
Reference in a new issue