Update to 0.5.6. Changes since 0.3.8:
-f flag first col lock file erasure on error exit external program input into a field send data field to external program Jason Felice autoconf additions - long options Bug fixes from changes Ayers Bug fix for padchar Popup pick boxes Ayers 'back tab' modifications. Documentation updates. Ayers format field modification. Jason Felice: macro package and #!/usr/bin/sci -t syntax Parm passing with evironment variable Page Up Page Down in pick boxes. Error fix of 0.5.2 Error fix of 0.5.4 -D switch fix
This commit is contained in:
parent
de332ebfb6
commit
04e105e609
5 changed files with 54 additions and 56 deletions
|
@ -1,28 +1,22 @@
|
|||
# $NetBSD: Makefile,v 1.5 2000/09/24 03:53:43 hubertf Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2000/12/15 14:45:34 mjl Exp $
|
||||
#
|
||||
|
||||
DISTNAME= sci.0.3.8
|
||||
PKGNAME= sci-0.3.8
|
||||
DISTNAME= sci-0.5.6
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://linuxparts.com/
|
||||
|
||||
MAINTAINER= packages@netbsd.org
|
||||
HOMEPAGE= http://linuxparts.com/software.html
|
||||
|
||||
WRKSRC= ${WRKDIR}/sci
|
||||
GNU_CONFIGURE= # Yupp
|
||||
|
||||
pre-build:
|
||||
-@${LN} -s ${WRKSRC}/makefile ${WRKSRC}/Makefile >/dev/null
|
||||
|
||||
pre-install:
|
||||
-@${GUNZIP_CMD} ${WRKSRC}/sci.1.gz
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/sci
|
||||
for i in app APP.README COPYING README allbut.awk edit.awk \
|
||||
maillist.awk template.sci template.sci.num sortd \
|
||||
whch scidata.out ; \
|
||||
do \
|
||||
${INSTALL_DATA} ${WRKSRC}/$$i ${PREFIX}/share/doc/sci ; \
|
||||
done
|
||||
${MKDIR} ${PREFIX}/share/doc/sci ${PREFIX}/share/examples/sci
|
||||
for i in COPYING README INSTALL NEWS ; do \
|
||||
${INSTALL_DATA} ${WRKSRC}/$$i ${PREFIX}/share/doc/sci ; \
|
||||
done
|
||||
for i in samples/* ; do \
|
||||
${INSTALL_DATA} ${WRKSRC}/$$i ${PREFIX}/share/examples/sci ; \
|
||||
done
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 1999/06/16 21:37:16 mjl Exp $
|
||||
$NetBSD: md5,v 1.2 2000/12/15 14:45:35 mjl Exp $
|
||||
|
||||
MD5 (sci.0.3.8.tar.gz) = 3a7b1d10ad6fca3e2fdbe416dd683941
|
||||
MD5 (sci-0.5.6.tar.gz) = 5394bd56294fa2b8200d539bf34aff7c
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: patch-sum,v 1.2 2000/09/24 03:53:43 hubertf Exp $
|
||||
$NetBSD: patch-sum,v 1.3 2000/12/15 14:45:35 mjl Exp $
|
||||
|
||||
MD5 (patch-aa) = 461815912a5b5a8a4c1d25d6beaf62c7
|
||||
MD5 (patch-aa) = 0ea3e135e220a55861b825ed80246f6a
|
||||
|
|
|
@ -1,27 +1,24 @@
|
|||
$NetBSD: patch-aa,v 1.2 2000/09/24 03:53:44 hubertf Exp $
|
||||
# $NetBSD: patch-aa,v 1.3 2000/12/15 14:45:35 mjl Exp $
|
||||
#
|
||||
# Avoid picking up ncurses if installed
|
||||
|
||||
--- makefile.orig Wed Jun 16 23:07:37 1999
|
||||
+++ makefile Wed Jun 16 23:20:05 1999
|
||||
@@ -1,10 +1,10 @@
|
||||
all : bin
|
||||
--- configure.orig Fri Dec 15 15:14:00 2000
|
||||
+++ configure Fri Dec 15 15:14:11 2000
|
||||
@@ -1022,7 +1022,7 @@
|
||||
EOF
|
||||
if { (eval echo configure:1024: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
rm -rf conftest*
|
||||
- eval "ac_cv_lib_$ac_lib_var=yes"
|
||||
+ eval "ac_cv_lib_$ac_lib_var=no"
|
||||
else
|
||||
echo "configure: failed program was:" >&5
|
||||
cat conftest.$ac_ext >&5
|
||||
@@ -1284,7 +1284,7 @@
|
||||
|
||||
PROG=sci
|
||||
-INSTALL=/usr/local/bin
|
||||
-MAN=/usr/man/man1
|
||||
-COPT=-DUSLEEP
|
||||
-CURSES=-lncurses
|
||||
+INSTALL=${PREFIX}/bin
|
||||
+MAN=${PREFIX}/man/man1
|
||||
+COPT=-DUSLEEP
|
||||
+CURSES= -lcurses
|
||||
fi
|
||||
|
||||
$(PROG).o : $(PROG).c
|
||||
gcc -O3 $(COPT) -Wall -pedantic -c $(PROG).c
|
||||
@@ -27,6 +27,6 @@
|
||||
rm -f *.bak
|
||||
install :
|
||||
cp sci $(INSTALL)
|
||||
- cp sci.1.gz $(MAN)
|
||||
+ cp sci.1 $(MAN)
|
||||
|
||||
bin : $(PROG)
|
||||
-for ac_hdr in fcntl.h unistd.h ncurses.h curses.h
|
||||
+for ac_hdr in fcntl.h unistd.h curses.h
|
||||
do
|
||||
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
|
||||
echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
|
||||
|
|
|
@ -1,16 +1,23 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2000/09/24 03:53:44 hubertf Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2000/12/15 14:45:35 mjl Exp $
|
||||
bin/sci
|
||||
man/man1/sci.1
|
||||
share/doc/sci/APP.README
|
||||
share/doc/sci/COPYING
|
||||
share/doc/sci/README
|
||||
share/doc/sci/allbut.awk
|
||||
share/doc/sci/app
|
||||
share/doc/sci/edit.awk
|
||||
share/doc/sci/maillist.awk
|
||||
share/doc/sci/scidata.out
|
||||
share/doc/sci/sortd
|
||||
share/doc/sci/template.sci
|
||||
share/doc/sci/template.sci.num
|
||||
share/doc/sci/whch
|
||||
@dirrm share/doc/sci
|
||||
share/doc/sci/INSTALL
|
||||
share/doc/sci/NEWS
|
||||
@comment @dirrm share/doc/sci
|
||||
share/examples/sci/APP.README
|
||||
share/examples/sci/Makefile
|
||||
share/examples/sci/Makefile.am
|
||||
share/examples/sci/Makefile.in
|
||||
share/examples/sci/allbut.awk
|
||||
share/examples/sci/app
|
||||
share/examples/sci/edit.awk
|
||||
share/examples/sci/maillist.awk
|
||||
share/examples/sci/merge
|
||||
share/examples/sci/scidata.out
|
||||
share/examples/sci/sortd
|
||||
share/examples/sci/template.sci
|
||||
share/examples/sci/template.sci.num
|
||||
share/examples/sci/whch
|
||||
@dirrm share/examples/sci
|
||||
|
|
Loading…
Reference in a new issue