Use -[ogm] instead of -[OGM] when passing permissions options to the

install script.  The latter are special install-sh script options that
check whether the invoking user is the root user or not, which is
completely unnecessary.
This commit is contained in:
jlam 2007-06-26 15:05:50 +00:00
parent f24be610fc
commit 04e13269d6
2 changed files with 36 additions and 5 deletions

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.35 2007/06/25 09:53:42 tls Exp $
$NetBSD: distinfo,v 1.36 2007/06/26 15:05:50 jlam Exp $
SHA1 (sudo-1.6.8p12.tar.gz) = a79631e9e1c0d0d3f2aa88ae685628e5fde61982
RMD160 (sudo-1.6.8p12.tar.gz) = d7ff9f18ca0973615258c2e975300b94567451d5
Size (sudo-1.6.8p12.tar.gz) = 585643 bytes
SHA1 (patch-aa) = a4f29f2c228eb3b4af0872cf04a00ffdf41c603c
SHA1 (patch-aa) = 02837d457786a4966c3a683918e0d592aaa32d2d
SHA1 (patch-af) = 245761812dc600b3d2752fa135ba367bb0223370
SHA1 (patch-ag) = 87c3263674ec98ccc9cc33f2108a2456eddaecc5
SHA1 (patch-ah) = 142a8884aebdc1cffc256c3ca0ee9addc34f8054

View file

@ -1,6 +1,6 @@
$NetBSD: patch-aa,v 1.12 2004/08/24 17:31:48 cube Exp $
$NetBSD: patch-aa,v 1.13 2007/06/26 15:05:50 jlam Exp $
--- Makefile.in.orig 2004-05-28 22:27:59.000000000 +0200
--- Makefile.in.orig 2005-11-08 13:21:58.000000000 -0500
+++ Makefile.in
@@ -181,7 +181,7 @@ testsudoers: $(TESTOBJS) $(LIBOBJS)
$(CC) -o $@ $(TESTOBJS) $(LIBOBJS) $(LDFLAGS) $(LIBS) $(NET_LIBS)
@ -11,7 +11,7 @@ $NetBSD: patch-aa,v 1.12 2004/08/24 17:31:48 cube Exp $
# Uncomment the following if you want "make distclean" to clean the parser
@DEV@PARSESRCS = sudo.tab.h sudo.tab.c lex.yy.c def_data.c def_data.h
@@ -292,11 +292,11 @@ sudoers.man:: sudoers.man.in
@@ -292,20 +292,20 @@ sudoers.man:: sudoers.man.in
sudoers.cat: sudoers.man
@ -25,3 +25,34 @@ $NetBSD: patch-aa,v 1.12 2004/08/24 17:31:48 cube Exp $
$(DESTDIR)$(mandirsu) $(DESTDIR)$(mandirform) \
$(DESTDIR)$(noexecdir)
install-binaries: $(PROGS)
- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 4111 -s sudo $(DESTDIR)$(sudodir)/sudo
+ $(INSTALL) -o $(install_uid) -g $(install_gid) -m 4111 -s sudo $(DESTDIR)$(sudodir)/sudo
rm -f $(DESTDIR)$(sudodir)/sudoedit
ln $(DESTDIR)$(sudodir)/sudo $(DESTDIR)$(sudodir)/sudoedit
- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0111 -s visudo $(DESTDIR)$(visudodir)/visudo
+ $(INSTALL) -o $(install_uid) -g $(install_gid) -m 0111 -s visudo $(DESTDIR)$(visudodir)/visudo
install-noexec: sudo_noexec.la
$(LIBTOOL) --mode=install $(INSTALL) sudo_noexec.la $(DESTDIR)$(noexecdir)
@@ -315,15 +315,15 @@ bininst-noexec: sudo_noexec.la
install-sudoers:
test -f $(DESTDIR)$(sudoersdir)/sudoers || \
- $(INSTALL) -O $(sudoers_uid) -G $(sudoers_gid) -M $(sudoers_mode) \
+ $(INSTALL) -o $(sudoers_uid) -g $(sudoers_gid) -m $(sudoers_mode) \
$(srcdir)/sudoers $(DESTDIR)$(sudoersdir)/sudoers
install-man:
- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0444 @mansrcdir@/sudo.$(mantype) $(DESTDIR)$(mandirsu)/sudo.$(mansectsu)
+ $(INSTALL) -o $(install_uid) -g $(install_gid) -m 0444 @mansrcdir@/sudo.$(mantype) $(DESTDIR)$(mandirsu)/sudo.$(mansectsu)
@rm -f $(DESTDIR)$(mandirsu)/sudoedit.$(mansectsu)
ln $(DESTDIR)$(mandirsu)/sudo.$(mansectsu) $(DESTDIR)$(mandirsu)/sudoedit.$(mansectsu)
- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0444 @mansrcdir@/visudo.$(mantype) $(DESTDIR)$(mandirsu)/visudo.$(mansectsu)
- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0444 @mansrcdir@/sudoers.$(mantype) $(DESTDIR)$(mandirform)/sudoers.$(mansectform)
+ $(INSTALL) -o $(install_uid) -g $(install_gid) -m 0444 @mansrcdir@/visudo.$(mantype) $(DESTDIR)$(mandirsu)/visudo.$(mansectsu)
+ $(INSTALL) -o $(install_uid) -g $(install_gid) -m 0444 @mansrcdir@/sudoers.$(mantype) $(DESTDIR)$(mandirform)/sudoers.$(mansectform)
@MAN_POSTINSTALL@
check: